Bug 458938 - Too many notifications cause KWin to crash (KDEConnect)
Summary: Too many notifications cause KWin to crash (KDEConnect)
Status: RESOLVED DUPLICATE of bug 458598
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.25.5
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-09 22:30 UTC by Peter Leconte
Modified: 2022-09-09 22:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of /usr/bin/kwin_wayland crash (896 bytes, text/plain)
2022-09-09 22:30 UTC, Peter Leconte
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Leconte 2022-09-09 22:30:21 UTC
Created attachment 151958 [details]
Backtrace of /usr/bin/kwin_wayland crash

SUMMARY
Too many notifications cause kwin wayland to crash.
Reproducible on my system with KDEconnect.

STEPS TO REPRODUCE
1. Use Wayland
2. Have loads of notifications on your phone
3. Connect with KDEconnect with notification plugin to flood notifications

OBSERVED RESULT
Plasma wayland restarts after being frozen for a few seconds (you can see faded notifications overlapping on the last frame)

EXPECTED RESULT
It doesn't crash and just shows all notifications.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.5
Kernel Version: 5.19.7-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 4800H with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD RENOIR
Manufacturer: HP

Running in a hybrid setup with an nvidia RTX 2060m.

ADDITIONAL INFORMATION
/
Comment 1 Nate Graham 2022-09-09 22:33:34 UTC

*** This bug has been marked as a duplicate of bug 458598 ***