Bug 444230 - Settings application crashes when changing Task switcher visualization
Summary: Settings application crashes when changing Task switcher visualization
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-22 09:15 UTC by Deepu
Modified: 2021-11-15 11:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.57 KB, text/plain)
2021-11-15 11:19 UTC, `{third: "Beedell", first: "Roke"}`{.JSON5}
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Deepu 2021-10-22 09:15:24 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.85.0
Operating System: Linux 5.14.12-200.fc34.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: Fedora 34 (KDE Plasma)

-- Information about the crash:
when changing Task switcher visualization and hitting apply, settings crashes on wayland under Fedora

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f886884a6a9 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#5  0x00007f88688371b9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#6  0x00007f8868853af3 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#7  0x00007f8866102c04 in ffi_call_unix64 () from /lib64/libffi.so.6
#8  0x00007f8866102107 in ffi_call () from /lib64/libffi.so.6
#9  0x00007f88687a4d10 in wl_closure_invoke.constprop () from /lib64/libwayland-client.so.0
#10 0x00007f88687a542b in dispatch_event.isra () from /lib64/libwayland-client.so.0
#11 0x00007f88687a561c in wl_display_dispatch_queue_pending () from /lib64/libwayland-client.so.0
#12 0x00007f886882f6a3 in QtWaylandClient::QWaylandDisplay::flushRequests() () from /lib64/libQt5WaylandClient.so.5
#13 0x00007f886ae4d3f0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#14 0x00007f886ae4fb4a in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib64/libQt5Core.so.5
#15 0x00007f886ae50363 in QSocketNotifier::event(QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007f886b9ec443 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007f886ae19798 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007f886ae6b5ff in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#19 0x00007f8868ba14cf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x00007f8868bf54f8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#21 0x00007f8868b9ec03 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#22 0x00007f886ae6ab78 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#23 0x00007f886ae181a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007f886ae206e4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#25 0x000055b426b8858c in main ()
[Inferior 1 (process 20822) detached]

Possible duplicates by query: bug 443346, bug 443000, bug 442318, bug 442289, bug 441707.

Reported using DrKonqi
Comment 1 Nate Graham 2021-10-22 16:45:27 UTC

*** This bug has been marked as a duplicate of bug 414834 ***
Comment 2 `{third: "Beedell", first: "Roke"}`{.JSON5} 2021-11-15 11:19:13 UTC
Created attachment 143571 [details]
New crash information added by DrKonqi

systemsettings5 (5.22.5) using Qt 5.15.2

- What I was doing when the application crashed:
Replacement of the theme of the task-switcher.

-- Backtrace (Reduced):
#6  0x00007f6130566e44 in QWaylandClientExtensionPrivate::handleRegistryGlobal (data=0x556c74907cc0, registry=0x556c74073840, id=80, interface=..., version=1) at global/qwaylandclientextension.cpp:67
#7  0x00007f6130553419 in QtWaylandClient::QWaylandDisplay::registry_global (this=<optimized out>, id=<optimized out>, interface=..., version=<optimized out>) at /usr/src/debug/qt5-qtwayland-5.15.2-11.fc35.x86_64/src/client/qwaylanddisplay.cpp:397
#8  0x00007f613056f6c3 in QtWayland::wl_registry::handle_global (data=0x556c74074280, object=<optimized out>, name=80, interface=0x556c75cf1d20 "org_kde_kwin_blur_manager", version=1) at /usr/src/debug/qt5-qtwayland-5.15.2-11.fc35.x86_64/src/client/qwayland-wayland.cpp:94
#9  0x00007f612de05c04 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#10 0x00007f612de05108 in ffi_call (cif=cif@entry=0x7ffe92f5f5c0, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7ffe92f5f690) at ../src/x86/ffi64.c:525