Bug 442660 - ScrollViewKCMs have hidden footers until the window is resized
Summary: ScrollViewKCMs have hidden footers until the window is resized
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.86.0
Platform: Archlinux Linux
: VHI normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: regression
: 442691 442731 442766 442899 442955 443093 443154 443204 443408 443409 443494 443541 444225 445151 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-18 15:07 UTC by Patrick Silva
Modified: 2021-11-08 11:30 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.87


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-09-18 15:07:15 UTC
STEPS TO REPRODUCE
1. right-click on a server side decoration
2. hover over "More actions" and choose "Configure special window/application settings"

OBSERVED RESULT
buttons and spinbox on bottom are hidden until the window is vertically resized

EXPECTED RESULT
buttons and spinbox on bottom are are visible on opening

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.22.90
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 1 Ismael Asensio 2021-09-18 21:11:36 UTC
I've bisected this to https://invent.kde.org/frameworks/kirigami/-/commit/7fa1943f653494a9122b9ca0f321730c25963ee2.

It affects KCMs using ScrollViewKCM (part of kdeclarative), but only when they are loaded independently (for instance using KCMShell). 

Their footer item stays hidden until the window is resized. The footer itself is not invisible (visible property is true), but it looks like it is placed behind the KCM buttons.

This is the case for kwinrules, but also bluetooth, autostart, etc.
Comment 2 Patrick Silva 2021-09-20 01:32:07 UTC
*** Bug 442691 has been marked as a duplicate of this bug. ***
Comment 3 Ismael Asensio 2021-09-20 11:08:04 UTC
*** Bug 442731 has been marked as a duplicate of this bug. ***
Comment 4 Ismael Asensio 2021-09-21 10:20:56 UTC
*** Bug 442766 has been marked as a duplicate of this bug. ***
Comment 5 Paul Worrall 2021-09-24 15:16:10 UTC
*** Bug 442899 has been marked as a duplicate of this bug. ***
Comment 6 Bug Janitor Service 2021-09-25 18:36:53 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/379
Comment 7 Paul Worrall 2021-09-26 12:58:15 UTC
*** Bug 442955 has been marked as a duplicate of this bug. ***
Comment 8 Ismael Asensio 2021-09-27 18:50:42 UTC
Git commit ba74ad3e66665f956c7674d8cde1f384e894f7b1 by Ismael Asensio.
Committed on 27/09/2021 at 17:07.
Pushed by iasensio into branch 'master'.

PageRow: Do not async load the global header

The calculation of the PageRows' implicitHeight does not take the
header title into accont until it is loaded.

If the PageRow is used inside a QQuickWidget with resize policy
SizeRootObjectToView (as in KCModuleQML) the initial sizeHint()
will use an implicitHeight that is not ready yet.
FIXED-IN: 5.87

M  +3    -1    src/controls/PageRow.qml

https://invent.kde.org/frameworks/kirigami/commit/ba74ad3e66665f956c7674d8cde1f384e894f7b1
Comment 9 Ismael Asensio 2021-09-28 19:48:01 UTC
*** Bug 443093 has been marked as a duplicate of this bug. ***
Comment 10 Ismael Asensio 2021-09-30 09:46:34 UTC
*** Bug 443154 has been marked as a duplicate of this bug. ***
Comment 11 Patrick Silva 2021-10-01 20:19:12 UTC
*** Bug 443204 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2021-10-06 19:59:00 UTC
*** Bug 443409 has been marked as a duplicate of this bug. ***
Comment 13 Nicolas Fella 2021-10-06 20:48:30 UTC
*** Bug 443408 has been marked as a duplicate of this bug. ***
Comment 14 Patrick Silva 2021-10-09 02:24:19 UTC
*** Bug 443494 has been marked as a duplicate of this bug. ***
Comment 15 Ismael Asensio 2021-10-10 10:11:03 UTC
*** Bug 443541 has been marked as a duplicate of this bug. ***
Comment 16 Nate Graham 2021-10-22 16:44:13 UTC
*** Bug 444225 has been marked as a duplicate of this bug. ***
Comment 17 Nicolas Fella 2021-11-08 11:30:34 UTC
*** Bug 445151 has been marked as a duplicate of this bug. ***