Bug 436495 - OpenGL Rendering backend crashes KWin in KWin::SceneOpenGL::createScene()
Summary: OpenGL Rendering backend crashes KWin in KWin::SceneOpenGL::createScene()
Status: RESOLVED DUPLICATE of bug 432570
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.21.4
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-05-02 18:01 UTC by I don't need a name
Modified: 2021-05-04 09:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description I don't need a name 2021-05-02 18:01:36 UTC
Application: kwin_x11 (5.21.4)

Qt Version: 5.15.2
Frameworks Version: 5.81.0
Operating System: Linux 5.10.33-1-lts x86_64
Windowing System: X11
Drkonqi Version: 5.21.4
Distribution: Arch Linux

-- Information about the crash:
This just happened out of nowhere, everything worked fine yesterday, I didn't even update anything.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault

[KCrash Handler]
#4  0x0000000000000000 in  ()
#5  0x00007fdca585d9d3 in KWin::SceneOpenGL::createScene(QObject*) () at /usr/lib/qt/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#6  0x00007fdca586d81e in KWin::OpenGLFactory::create(QObject*) const () at /usr/lib/qt/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#7  0x00007fdcd0041973 in KWin::Compositor::setupStart() () at /usr/lib/libkwin.so.5
#8  0x00007fdcd0044d8a in KWin::X11Compositor::start() () at /usr/lib/libkwin.so.5
#9  0x00007fdcd0043817 in KWin::Compositor::reinitialize() () at /usr/lib/libkwin.so.5
#10 0x00007fdcd0044665 in KWin::X11Compositor::reinitialize() () at /usr/lib/libkwin.so.5
#11 0x00007fdcd0058819 in KWin::CompositorDBusInterface::reinitialize() () at /usr/lib/libkwin.so.5
#12 0x00007fdccffd76e4 in KWin::CompositorDBusInterface::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () at /usr/lib/libkwin.so.5
#13 0x00007fdccffd79b1 in KWin::CompositorDBusInterface::qt_metacall(QMetaObject::Call, int, void**) () at /usr/lib/libkwin.so.5
#14 0x00007fdccd40e066 in  () at /usr/lib/libQt5DBus.so.5
#15 0x00007fdccd179352 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#16 0x00007fdcce34a762 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#17 0x000055b83e54585d in KWin::ApplicationX11::notify(QObject*, QEvent*) ()
#18 0x00007fdccd14c84a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#19 0x00007fdccd14f343 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#20 0x00007fdccd1a27ac in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#21 0x00007fdcc56bc56f in  () at /usr/lib/libQt5XcbQpa.so.5
#22 0x00007fdccd14b1ac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#23 0x00007fdccd153664 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#24 0x000055b83e547069 in main ()
[Inferior 1 (process 54725) detached]

The reporter indicates this bug may be a duplicate of or related to bug 432570.

Possible duplicates by query: bug 432570, bug 432496, bug 431863, bug 431529, bug 429383.

Reported using DrKonqi
Comment 1 David Redondo 2021-05-03 07:07:11 UTC
What GPU are you using?
Comment 2 Nate Graham 2021-05-03 20:03:48 UTC

*** This bug has been marked as a duplicate of bug 432570 ***
Comment 3 I don't need a name 2021-05-04 09:01:50 UTC
(In reply to David Redondo from comment #1)
> What GPU are you using?

geforce 8500 GT