Bug 431529 - Kwin crash randomly (mostly using firefox)
Summary: Kwin crash randomly (mostly using firefox)
Status: RESOLVED DUPLICATE of bug 432570
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.20.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-01-13 08:06 UTC by Gregory Duhamel
Modified: 2021-02-09 17:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (2.23 KB, text/plain)
2021-02-04 06:03 UTC, Anton Kuleshov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gregory Duhamel 2021-01-13 08:06:14 UTC
Application: kwin_x11 (5.20.5)

Qt Version: 5.15.2
Frameworks Version: 5.78.0
Operating System: Linux 5.9.16-200.fc33.x86_64 x86_64
Windowing system: X11
Distribution: Fedora 33 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:
KWIN crash randomly.

- Unusual behavior I noticed:
Higher chance of crash if i use firefox for a while (20 minutes)

- Custom settings of the application:

OS: Fedora 33 (KDE Plasma) x86_64 
Host: H370AORUSGAMING3WIFI 
Kernel: 5.9.16-200.fc33.x86_64 
Uptime: 1 hour, 23 mins 
Packages: 2863 (rpm), 13 (flatpak) 
Shell: zsh 5.8 
Resolution: 1024x1280, 2560x1440 
DE: Plasma 5.20.5 
WM: KWin 
WM Theme: Breeze 
Theme: Breeze [Plasma], Adwaita [GTK2], Breeze [GTK3] 
Icons: [Plasma], breeze [GTK2/3] 
Terminal: yakuake 
CPU: Intel i5-8600K (6) @ 4.300GHz 
GPU: NVIDIA GeForce GTX 1660 Ti 
Memory: 3384MiB / 31918MiB

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault

[KCrash Handler]
#4  0x0000000000000000 in  ()
#5  0x00007fb598056564 in KWin::SceneOpenGL::createScene(QObject*) () at /usr/lib64/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#6  0x00007fb59806541d in KWin::OpenGLFactory::create(QObject*) const () at /usr/lib64/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#7  0x00007fb5b61dd9e3 in KWin::Compositor::setupStart() [clone .part.0] () at /lib64/libkwin.so.5
#8  0x00007fb5b61e103e in KWin::X11Compositor::start() () at /lib64/libkwin.so.5
#9  0x00007fb5b61dee57 in KWin::Compositor::reinitialize() () at /lib64/libkwin.so.5
#10 0x00007fb5b4ead386 in void doActivate<false>(QObject*, int, void**) () at /lib64/libQt5Core.so.5
#11 0x00007fb5b4ea5d1e in QObject::event(QEvent*) () at /lib64/libQt5Core.so.5
#12 0x00007fb5b5912ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#13 0x00007fb5b4e7dbd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#14 0x00007fb5b4e808c7 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /lib64/libQt5Core.so.5
#15 0x00007fb5b4ec7afe in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#16 0x00007fb5a16f3852 in QXcbUnixEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5XcbQpa.so.5
#17 0x00007fb5b4e7c57b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#18 0x00007fb5b4e841b4 in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#19 0x000055954a2baaff in main ()
[Inferior 1 (process 1891) detached]

Possible duplicates by query: bug 429383, bug 427282, bug 426435, bug 418260, bug 415070.

Reported using DrKonqi
Comment 1 Vlad Zahorodnii 2021-01-13 11:50:12 UTC
The backtrace lacks debug symbols, so it's really hard to say where exactly kwin crashes. Can you install debug packages for kwin please and re-submit the backtrace?
Comment 2 Vlad Zahorodnii 2021-01-13 11:50:25 UTC
*** Bug 418260 has been marked as a duplicate of this bug. ***
Comment 3 Gregory Duhamel 2021-01-13 13:08:56 UTC
Hello Vlad,

thanks for your answer. I'm running on Fedora right now.

Hopes this would be sufficient :
sudo dnf debuginfo-install  kwin-common kwin kwin-wayland kf5-kwindowsystem kwin-libs

if it's then on next occurrence i will update this ticket with appropriate backtrace.

Regards,
Gregory.
Comment 4 Gregory Duhamel 2021-01-13 13:11:47 UTC
Speaking of :

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault

[KCrash Handler]
#4  0x0000000000000000 in  ()
#5  0x00007f28c013f564 in KWin::SceneOpenGL::createScene(QObject*) (parent=<optimized out>) at /usr/src/debug/kwin-5.20.5-1.fc33.x86_64/plugins/scenes/opengl/scene_opengl.cpp:454
#6  0x00007f28c014e41d in KWin::OpenGLFactory::create(QObject*) const (this=<optimized out>, parent=0x7f28bc003f70) at /usr/src/debug/kwin-5.20.5-1.fc33.x86_64/plugins/scenes/opengl/scene_opengl.cpp:2757
#7  0x00007f28d7bfa9e3 in KWin::Compositor::setupStart() (this=0x7f28bc003f70) at /usr/src/debug/kwin-5.20.5-1.fc33.x86_64/composite.cpp:246
#8  0x00007f28d7bfb235 in KWin::Compositor::setupStart() (this=this@entry=0x7f28bc003f70) at /usr/src/debug/kwin-5.20.5-1.fc33.x86_64/composite.cpp:296
#9  0x00007f28d7bfe03e in KWin::X11Compositor::start() (this=0x7f28bc003f70) at /usr/src/debug/kwin-5.20.5-1.fc33.x86_64/composite.cpp:961
#10 0x00007f28d7bfbe57 in KWin::Compositor::reinitialize() (this=0x7f28bc003f70) at /usr/src/debug/kwin-5.20.5-1.fc33.x86_64/composite.cpp:525
#11 0x00007f28d68ca386 in void doActivate<false>(QObject*, int, void**) () at /lib64/libQt5Core.so.5
#12 0x00007f28d68c2d1e in QObject::event(QEvent*) () at /lib64/libQt5Core.so.5
#13 0x00007f28d732fec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#14 0x00007f28d689abd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#15 0x00007f28d689d8c7 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /lib64/libQt5Core.so.5
#16 0x00007f28d68e4afe in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#17 0x00007f28c3110852 in QXcbUnixEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5XcbQpa.so.5
#18 0x00007f28d689957b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#19 0x00007f28d68a11b4 in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#20 0x00005645b0f72aff in main ()
[Inferior 1 (process 17399) detached]

is it sufficient ?

Regards,
Gregory.
Comment 5 Gregory Duhamel 2021-01-13 13:15:15 UTC
Changing status.
Comment 6 Vlad Zahorodnii 2021-01-13 13:23:44 UTC
Yeah, it's good enough. According to the backtrace, kwin crashes at https://invent.kde.org/plasma/kwin/-/blob/v5.20.5/plugins/scenes/opengl/scene_opengl.cpp#L454 Odd...
Comment 7 Gregory Duhamel 2021-01-13 13:28:20 UTC
Two recent  update on my desktop : 

- update of Nvidia driver to 460.32.03 (from 450.XX.XX)
- update of Frameworks to 5.78.0 from 5.75.X

That could be something ?

Regards,
Gregory.
Comment 8 Gregory Duhamel 2021-01-13 13:32:50 UTC
janv. 13 14:05:44 kwin_x11[17399]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 63522, resource id: 15228254, major code: 3 (GetWindowAttributes), minor code: 0
janv. 13 14:05:44 kwin_x11[17399]: qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 63523, resource id: 15228254, major code: 14 (GetGeometry), minor code: 0
janv. 13 14:09:15 kwin_x11[17399]: kwin_scene_opengl: OpenGL 2 compositing setup failed
janv. 13 14:09:15 kwin_x11[17399]: kwin_scene_opengl: OpenGL driver recommends XRender based compositing. Falling back to XRender.
janv. 13 14:09:15 kwin_x11[17399]: kwin_scene_opengl: To overwrite the detection use the environment variable KWIN_COMPOSE
janv. 13 14:09:15 kwin_x11[17399]: kwin_scene_opengl: For more information see https://community.kde.org/KWin/Environment_Variables#KWIN_COMPOSE
janv. 13 14:09:17 kwin_x11[60172]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2589, resource id: 148897828, major code: 3 (GetWindowAttributes), minor code: 0
janv. 13 14:09:17 kwin_x11[60172]: qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 2590, resource id: 148897828, major code: 14 (GetGeometry), minor code: 0
janv. 13 14:09:17 kwin_x11[60172]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2645, resource id: 148897847, major code: 3 (GetWindowAttributes), minor code: 0
janv. 13 14:09:17 kwin_x11[60172]: qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 2646, resource id: 148897847, major code: 14 (GetGeometry), minor code: 0
janv. 13 14:09:17 kwin_x11[60172]: kwin_core: Compositing is not possible
janv. 13 14:19:29 kwin_x11[60172]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 23716, resource id: 14680071, major code: 15 (QueryTree), minor code: 0
Comment 9 Vlad Zahorodnii 2021-01-13 13:35:27 UTC
Well, that sounds like a regression introduced by the recent update of the nvidia driver. On the other hand, kwin should not crash when it falls back to the xrender backend. Not sure why it crashes at delete backend;
Comment 10 Anton Kuleshov 2021-02-04 06:03:36 UTC
Created attachment 135411 [details]
New crash information added by DrKonqi

kwin_x11 (5.20.5) using Qt 5.15.2

- What I was doing when the application crashed:

Moved taskbar icon. This also happens when minimize/restore windows.

-- Backtrace (Reduced):
#5  0x00007fe6941a8fdb in KWin::SceneOpenGL::createScene(QObject*) () from /usr/lib64/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#6  0x00007fe6941a98b9 in KWin::OpenGLFactory::create(QObject*) const () from /usr/lib64/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#8  0x00007fe69d59a6e3 in KWin::X11Compositor::start() () from /usr/lib64/libkwin.so.5
#9  0x00007fe69d5985b4 in KWin::Compositor::reinitialize() () from /usr/lib64/libkwin.so.5
#10 0x00007fe69c3ba981 in void doActivate<false>(QObject*, int, void**) () from /usr/lib64/libQt5Core.so.5
Comment 11 Nate Graham 2021-02-09 17:47:41 UTC

*** This bug has been marked as a duplicate of bug 432570 ***