Bug 429383 - kwin crashes sometimes when switching between virtual desktops using screen corners
Summary: kwin crashes sometimes when switching between virtual desktops using screen c...
Status: RESOLVED DUPLICATE of bug 426435
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.19.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-11-20 09:22 UTC by Saadin
Modified: 2021-01-13 12:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Saadin 2020-11-20 09:22:44 UTC
Application: kwin_x11 (5.19.5)

Qt Version: 5.14.2
Frameworks Version: 5.74.0
Operating System: Linux 5.8.0-29-generic x86_64
Windowing system: X11
Distribution: Ubuntu 20.10

-- Information about the crash:
- What I was doing when the application crashed:
Switching between virtual deskop using hot corners of screen. This usually happens when I do quick switches between multiple virtual desktops (but not always). It mostly happens when I'm on a desktop with firefox, then I switch to another desktops and quickly switch back.

- Custom settings of the application:

Compositor is enabled with opengl 2
Top left corner is set to view desktop grid
6 virtual desktops (2 rows)

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Aborted
Content of s_kcrashErrorMessage: (null)
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:49
#7  0x00007f71f3446864 in __GI_abort () at abort.c:79
#8  0x00007f71f2be625e in glx_provider_resolver (entrypoints=0x7ffe3d46f66c, providers=0x7ffe3d46f676, name=0x7f71f2c6bc18 <entrypoint_strings+472> "glXCreateContextAttribsARB") at src/glx_generated_dispatch.c:3410
#9  glx_single_resolver (provider=<optimized out>, entrypoint_offset=<optimized out>) at src/glx_generated_dispatch.c:3423
#10 0x00007f71f2c4757d in epoxy_glXCreateContextAttribsARB_resolver () at src/glx_generated_dispatch.c:4240
#11 epoxy_glXCreateContextAttribsARB_global_rewrite_ptr (dpy=0x5636e5b3cde0, config=0x5636e5cef240, share_context=0x0, direct=1, attrib_list=0x5636e5ea8d60) at src/glx_generated_dispatch.c:4240
#12 0x00007f71ec53d8f4 in KWin::GlxBackend::initRenderingContext (this=this@entry=0x5636e5cfcfa0) at ./plugins/platforms/x11/standalone/glxbackend.h:96
#13 0x00007f71ec53de2c in KWin::GlxBackend::init (this=0x5636e5cfcfa0) at ./plugins/platforms/x11/standalone/glxbackend.cpp:203
#14 0x00007f71ec02553e in KWin::SceneOpenGL::createScene (parent=parent@entry=0x5636e5ba91e0) at ./plugins/scenes/opengl/scene_opengl.cpp:461
#15 0x00007f71ec025e0d in KWin::OpenGLFactory::create (this=<optimized out>, parent=0x5636e5ba91e0) at ./plugins/scenes/opengl/scene_opengl.cpp:2712
#16 0x00007f71f4e0884b in KWin::Compositor::setupStart (this=0x5636e5ba91e0) at ./composite.cpp:257
#17 0x00007f71f4e096d7 in KWin::X11Compositor::start (this=0x5636e5ba91e0) at ./composite.cpp:982
#18 0x00007f71f3aee651 in QObject::event (this=0x5636e5ba91e0, e=0x5636e5c44f50) at kernel/qobject.cpp:1339
#19 0x00007f71f4578013 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5636e5ba91e0, e=0x5636e5c44f50) at kernel/qapplication.cpp:3685
#20 0x00007f71f3ac21ca in QCoreApplication::notifyInternal2 (receiver=0x5636e5ba91e0, event=0x5636e5c44f50) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:153
#21 0x00007f71f3ac4bc1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5636e5b08520) at kernel/qcoreapplication.cpp:1815
#22 0x00007f71f3b16c47 in QEventDispatcherUNIX::processEvents (this=0x5636e5b775f0, flags=...) at kernel/qeventdispatcher_unix.cpp:466
#23 0x00007f71ed56f732 in QXcbUnixEventDispatcher::processEvents (this=0x5636e5b775f0, flags=...) at qxcbeventdispatcher.cpp:60
#24 0x00007f71f3ac0a4b in QEventLoop::exec (this=this@entry=0x7ffe3d46fe40, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:136
#25 0x00007f71f3ac8fc6 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:118
#26 0x00005636e454ea6d in main (argc=<optimized out>, argv=0x7ffe3d4700c8) at ./main_x11.cpp:479
[Inferior 1 (process 39712) detached]

The reporter indicates this bug may be a duplicate of or related to bug 422275, bug 368847.

Possible duplicates by query: bug 429344, bug 428581, bug 428149, bug 427384, bug 426435.

Reported using DrKonqi
Comment 1 Vlad Zahorodnii 2021-01-13 12:24:31 UTC

*** This bug has been marked as a duplicate of bug 426435 ***