Bug 432496 - OpenGL compositor causing system crash
Summary: OpenGL compositor causing system crash
Status: RESOLVED DUPLICATE of bug 432570
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-04 08:14 UTC by Nico
Modified: 2021-02-09 17:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of error msg (107.59 KB, image/png)
2021-02-04 08:14 UTC, Nico
Details
kwin.gdb (6.06 KB, application/octet-stream)
2021-02-08 23:53 UTC, Nico
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico 2021-02-04 08:14:25 UTC
Created attachment 135413 [details]
screenshot of error msg

SUMMARY
system crashes at random especially when running video applications

STEPS TO REPRODUCE
1. enable OpenGL (2.0 and/or 3.1)
2. running video applications
3. single and/or double scren

OBSERVED RESULT
system crashes to hard reset with previous kernels. Since kernel 5.10.12 system stalls temporarily and return to working, with automatic disable of OpenGL and loss of all KDE desktop effects

EXPECTED RESULT


SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Slackware current
(available in About System)
KDE Plasma Version: Plasma 5
KDE Frameworks Version: 
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-02-07 15:49:45 UTC
Can you please attach a backtrace of the crash? Thanks! See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
Comment 2 Nico 2021-02-08 23:53:27 UTC
Created attachment 135524 [details]
kwin.gdb

Hi Nate,
I apologize for the delay. I had to learn how to create a backtrace.
I think I managed to create one (file attached) after the crash (again) and I hope you'll find it useful.
Let me know whether, or not, i can be of further assistance.
Regards,

________________________________
From: Nate Graham <bugzilla_noreply@kde.org>
Sent: Sunday, February 7, 2021 4:49 PM
To: freenico2020@hotmail.com <freenico2020@hotmail.com>
Subject: [kde] [Bug 432496] OpenGL compositor causing system crash

https://bugs.kde.org/show_bug.cgi?id=432496

Nate Graham <nate@kde.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |BACKTRACE
                 CC|                            |nate@kde.org
             Status|REPORTED                    |NEEDSINFO

--- Comment #1 from Nate Graham <nate@kde.org> ---
Can you please attach a backtrace of the crash? Thanks! See
https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports

--
You are receiving this mail because:
You reported the bug.
Comment 3 Nate Graham 2021-02-09 17:44:57 UTC
Thanks! Here's the relevant part:


Thread 1 (Thread 0x7f80e92a9900 (LWP 7218) "kwin_x11"):
#0  0x0000000000000000 in  ()
#1  0x00007f80d9ffd949 in KWin::SceneOpenGL::createScene(QObject*) () at /usr/lib64/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#2  0x00007f80d9ffe105 in KWin::OpenGLFactory::create(QObject*) const () at /usr/lib64/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#3  0x00007f80f05f8491 in  () at /usr/lib64/libkwin.so.5
#4  0x00007f80f05f918e in KWin::X11Compositor::start() () at /usr/lib64/libkwin.so.5
#5  0x00007f80f05f715b in KWin::Compositor::reinitialize() () at /usr/lib64/libkwin.so.5
#6  0x00007f80ed8d3813 in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007f80ed8c9931 in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#8  0x00007f80ee3c226f in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#9  0x00007f80ed89f34a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#10 0x00007f80ed8a1b01 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQt5Core.so.5
#11 0x00007f80ed8f088a in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#12 0x00007f80e919471e in  () at /usr/lib64/libQt5XcbQpa.so.5
#13 0x00007f80ed89de8b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#14 0x00007f80ed8a5aac in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#15 0x0000000000407f26 in  ()
#16 0x00007f80ecf9e92a in __libc_start_main () at /lib64/libc.so.6
#17 0x00000000004083fa in _start ()
A debugging session is active.

Looks like this is the same as Bug 432570.

*** This bug has been marked as a duplicate of bug 432570 ***