Bug 427282 - sddm freeze at logging
Summary: sddm freeze at logging
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.18.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-10-03 07:37 UTC by navyn
Modified: 2021-12-04 04:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description navyn 2020-10-03 07:37:58 UTC
Application: kwin_x11 (5.18.5)

Qt Version: 5.12.8
Frameworks Version: 5.68.0
Operating System: Linux 5.4.0-48-generic x86_64
Windowing system: X11
Distribution: Ubuntu 20.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
juste loggin after boot


- Unusual behavior I noticed:
screen freeze, logging animation stop or black screen
devices seem to be unresponsive ,can't use keybord to go tty's.
sometimes if i wait a few i can reach my computer by ssh, but must of time no ping reply.


- Custom settings of the application:
I have install and uninstall proprietary graphical driver (amd) and rocm
screen resollution change : logging 3840x720, desktop 1920x1080

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f73d890d0c0 (LWP 1561))]

Thread 4 (Thread 0x7f73c7bff700 (LWP 1696)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x7f73dda80fb8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f73dda80f68, cond=0x7f73dda80f90) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f73dda80f90, mutex=0x7f73dda80f68) at pthread_cond_wait.c:638
#3  0x00007f73dd9835fa in  () at /lib/x86_64-linux-gnu/libQt5Script.so.5
#4  0x00007f73dd98361f in  () at /lib/x86_64-linux-gnu/libQt5Script.so.5
#5  0x00007f73df593609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f73df6cf293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f73d51ff700 (LWP 1693)):
#0  0x00007f73df6c2bf6 in __ppoll (fds=0x7f73c0000d68, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f73de0954a9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f73de096a14 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f73de0404db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f73dde78785 in QThread::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f73dcbcc1a9 in  () at /lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f73dde799d2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f73df593609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f73df6cf293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f73d73fb700 (LWP 1627)):
#0  0x00007f73df6c2bf6 in __ppoll (fds=0x7f73c800ecb8, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f73de0954a9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f73de096a14 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f73de0404db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f73dde78785 in QThread::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f73df0aaefa in  () at /lib/x86_64-linux-gnu/libQt5DBus.so.5
#6  0x00007f73dde799d2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f73df593609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f73df6cf293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f73d890d0c0 (LWP 1561)):
[KCrash Handler]
#5  0x00007f73dd5aba34 in xcb_render_query_pict_formats_formats_iterator () at /lib/x86_64-linux-gnu/libxcb-render.so.0
#6  0x00007f73dd5aba6d in xcb_render_query_pict_formats_screens_iterator () at /lib/x86_64-linux-gnu/libxcb-render.so.0
#7  0x00007f73db9d61df in  () at /lib/x86_64-linux-gnu/libkwinxrenderutils.so.12
#8  0x00007f73db9d581c in KWin::XRenderUtils::findPictFormat(unsigned int) () at /lib/x86_64-linux-gnu/libkwinxrenderutils.so.12
#9  0x00007f73d422cb83 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kwin.scenes/KWinSceneXRender.so
#10 0x00007f73d422d2a1 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kwin.scenes/KWinSceneXRender.so
#11 0x00007f73d422ddee in KWin::XRenderFactory::create(QObject*) const () at /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kwin.scenes/KWinSceneXRender.so
#12 0x00007f73df32a373 in  () at /lib/x86_64-linux-gnu/libkwin.so.5
#13 0x00007f73df32b5a6 in KWin::X11Compositor::start() () at /lib/x86_64-linux-gnu/libkwin.so.5
#14 0x00007f73de07a5b6 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f73de06dcf5 in QObject::event(QEvent*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f73dea59a66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007f73dea630f0 in QApplication::notify(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007f73de04193a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f73de0988b0 in QTimerInfoList::activateTimers() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f73de096b6f in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f73d84da6e2 in  () at /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#22 0x00007f73de0404db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f73de048246 in QCoreApplication::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f73df7a89ef in kdemain () at /lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#25 0x00007f73df5d40b3 in __libc_start_main (main=0x5624d00e5060, argc=1, argv=0x7fff1c976ae8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff1c976ad8) at ../csu/libc-start.c:308
#26 0x00005624d00e509e in _start ()
[Inferior 1 (process 1561) detached]

Reported using DrKonqi
Comment 1 kde.org 2021-11-04 20:58:25 UTC
This bug report is quite old and unfortunately lacks proper debug information. Can you still reproduce this issue with KDE 5.23? If so, can you please install debugging packages following the info provided in  https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports, try to reproduce the bug and submit a backtrace with debugging information.
Comment 2 Bug Janitor Service 2021-11-19 04:39:07 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2021-12-04 04:38:54 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!