Bug 418260 - KWin crash while configuring Cantata
Summary: KWin crash while configuring Cantata
Status: RESOLVED DUPLICATE of bug 432570
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-02-27 17:22 UTC by bs.blackscout.bs
Modified: 2021-02-09 17:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bs.blackscout.bs 2020-02-27 17:22:08 UTC
Application: kwin_x11 (5.18.2)

Qt Version: 5.14.1
Frameworks Version: 5.67.0
Operating System: Linux 5.5.6-arch1-1 x86_64
Windowing system: X11
Distribution: Arch Linux

-- Information about the crash:
- What I was doing when the application crashed:

I was configuring the Cantata Music Player settings and while clicking checkboxes and selecting tabs my mouse froze, sound continued working fine and then I was presented with the crash message.

- Side effects after restart:
I also have Latte Dock installed and the background now features a weird texture that wasn't there.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3d873b90c0 (LWP 646))]

Thread 7 (Thread 0x7f3d6d2af700 (LWP 16760)):
#0  0x00007f3d8f01abb6 in ppoll () at /usr/lib/libc.so.6
#1  0x00007f3d8d9afe81 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f3d8d9b163d in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f3d8d95a4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f3d8d77ee52 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f3d8d77ffc6 in  () at /usr/lib/libQt5Core.so.5
#6  0x00007f3d8c94646f in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f3d8f0253d3 in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7f3d84bdc700 (LWP 3475)):
#0  0x00007f3d8c94ccf5 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f3d8d785cb4 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /usr/lib/libQt5Core.so.5
#2  0x00007f3d8d785d92 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#3  0x00007f3d8c3f756b in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f3d8c3f77fb in  () at /usr/lib/libQt5Quick.so.5
#5  0x00007f3d8d77ffc6 in  () at /usr/lib/libQt5Core.so.5
#6  0x00007f3d8c94646f in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f3d8f0253d3 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f3d76dbe700 (LWP 818)):
#0  0x00007f3d8f01abb6 in ppoll () at /usr/lib/libc.so.6
#1  0x00007f3d8d9aff73 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f3d8d9b163d in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f3d8d95a4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f3d8d77ee52 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f3d8c08ff89 in  () at /usr/lib/libQt5Qml.so.5
#6  0x00007f3d8d77ffc6 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f3d8c94646f in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f3d8f0253d3 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f3d6e02e700 (LWP 763)):
#0  0x00007f3d8c94ccf5 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f3d8d27cf3c in  () at /usr/lib/libQt5Script.so.5
#2  0x00007f3d8d27cf59 in  () at /usr/lib/libQt5Script.so.5
#3  0x00007f3d8c94646f in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f3d8f0253d3 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f3d77fff700 (LWP 712)):
#0  0x00007f3d8d78054f in QMutex::unlock() () at /usr/lib/libQt5Core.so.5
#1  0x00007f3d8d95e225 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f3d8d9b1405 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f3d8d95a4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f3d8d77ee52 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f3d8c08ff89 in  () at /usr/lib/libQt5Qml.so.5
#6  0x00007f3d8d77ffc6 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f3d8c94646f in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f3d8f0253d3 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f3d85ded700 (LWP 700)):
#0  0x00007f3d8f01abb6 in ppoll () at /usr/lib/libc.so.6
#1  0x00007f3d8d9aff73 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f3d8d9b163d in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f3d8d95a4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f3d8d77ee52 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f3d8ea54b28 in  () at /usr/lib/libQt5DBus.so.5
#6  0x00007f3d8d77ffc6 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f3d8c94646f in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f3d8f0253d3 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f3d873b90c0 (LWP 646)):
[KCrash Handler]
#6  0x0000561c3abb5010 in  ()
#7  0x00007f3d6e0418d0 in KWin::SceneOpenGL::createScene(QObject*) () at /usr/lib/qt/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#8  0x00007f3d6e044fdb in KWin::OpenGLFactory::create(QObject*) const () at /usr/lib/qt/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#9  0x00007f3d8ecca625 in  () at /usr/lib/libkwin.so.5
#10 0x00007f3d8eccb5b3 in KWin::X11Compositor::start() () at /usr/lib/libkwin.so.5
#11 0x00007f3d8eccc169 in KWin::Compositor::reinitialize() () at /usr/lib/libkwin.so.5
#12 0x00007f3d8d99146e in  () at /usr/lib/libQt5Core.so.5
#13 0x00007f3d8d98926a in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#14 0x00007f3d8e3f5362 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#15 0x00007f3d8e3fe819 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#16 0x00007f3d8d95b962 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#17 0x00007f3d8d95e1c6 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#18 0x00007f3d8d9b1405 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#19 0x00007f3d86f74f5f in  () at /usr/lib/libQt5XcbQpa.so.5
#20 0x00007f3d8d95a4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#21 0x00007f3d8d9624d6 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#22 0x00007f3d8f0f4379 in kdemain () at /usr/lib/libkdeinit5_kwin_x11.so
#23 0x00007f3d8ef4d023 in __libc_start_main () at /usr/lib/libc.so.6
#24 0x0000561c38e7105e in _start ()
[Inferior 1 (process 646) detached]

Possible duplicates by query: bug 415070, bug 412391, bug 412049, bug 412008, bug 408678.

Reported using DrKonqi
Comment 1 Vlad Zahorodnii 2021-01-13 11:50:25 UTC

*** This bug has been marked as a duplicate of bug 431529 ***
Comment 2 Nate Graham 2021-02-09 17:47:37 UTC

*** This bug has been marked as a duplicate of bug 432570 ***