Bug 429833 - Resize window while annotating to show full image (or maximize when the images is larger than the window can be)
Summary: Resize window while annotating to show full image (or maximize when the image...
Status: RESOLVED FIXED
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
: 444149 446967 452368 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-29 23:44 UTC by Nate Graham
Modified: 2022-07-01 14:40 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.08


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2020-11-29 23:44:20 UTC
This is an alternative to Bug 426107.

Both are aiming at the same goal: to improve the UX when annotating a screenshot that is substantially larger than the prior size of Spectacle's window. Right now the existing window shows a small viewport that displays a fraction of the screensoht, which is not very user-friendly.
Comment 1 Nate Graham 2021-10-05 00:19:14 UTC
*** Bug 443192 has been marked as a duplicate of this bug. ***
Comment 2 Antonio Prcela 2021-11-08 21:24:50 UTC
a) resize the window of Spectacle when Annotate is activated, for example to show at least 50% of the image, but not getting out of the bounds of the current screen. When annotating is done, resize Spectacle to the previous window size.

b) in the Annotate widget, zoom out of the image, aka "fit image to window" (this would have to be applied upstream first).
Comment 3 Nate Graham 2021-11-16 01:24:08 UTC
*** Bug 444149 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-12-15 17:25:25 UTC
*** Bug 446967 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2022-03-02 22:17:50 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/127
Comment 6 Nate Graham 2022-04-08 15:11:36 UTC
*** Bug 452368 has been marked as a duplicate of this bug. ***
Comment 7 Antonio Prcela 2022-06-30 09:46:34 UTC
Git commit f2b9321cdd624024d0b6003335fa284943f1d102 by Antonio Prcela.
Committed on 29/06/2022 at 20:13.
Pushed by felixernst into branch 'master'.

Resize Spectacle's window to screenshot size when entering annotation mode

Also reverts back to prev size after annotation is done.

M  +3    -0    CMakeLists.txt
M  +3    -0    src/Config.h.in
M  +49   -17   src/Gui/KSMainWindow.cpp
M  +3    -0    src/Gui/KSMainWindow.h
M  +23   -0    src/Gui/KSWidget.cpp
M  +1    -0    src/Gui/KSWidget.h

https://invent.kde.org/graphics/spectacle/commit/f2b9321cdd624024d0b6003335fa284943f1d102