Bug 425992 - Network Speed widget is not working on neon unstable
Summary: Network Speed widget is not working on neon unstable
Status: CLOSED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: System Monitor (show other bugs)
Version: master
Platform: OpenSUSE Linux
: VHI normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords: regression
: 427693 427710 428041 428960 (view as bug list)
Depends on:
Blocks: 433063
  Show dependency treegraph
 
Reported: 2020-08-30 15:40 UTC by Patrick Silva
Modified: 2021-09-23 20:01 UTC (History)
18 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21


Attachments
screenshot (303.03 KB, image/png)
2020-08-30 15:40 UTC, Patrick Silva
Details
wrong download rate (580.46 KB, image/png)
2020-10-15 12:29 UTC, Patrick Silva
Details
Widget working lately (17.16 KB, image/jpeg)
2021-01-05 21:57 UTC, jonzn4SUSE
Details
screen recording on neon unstable (689.65 KB, video/webm)
2021-02-02 16:16 UTC, Patrick Silva
Details
network widget (203.09 KB, image/jpeg)
2021-02-17 17:02 UTC, jonzn4SUSE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-08-30 15:40:30 UTC
Created attachment 131294 [details]
screenshot

SUMMARY
Currently Network Speed widget shows no information on neon unstable.
See the attached screenshot please.

STEPS TO REPRODUCE
1. add Network Speed widget to desktop
2. 
3. 

EXPECTED RESULT
widget shows network speed

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.19.80
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2
Comment 1 David Redondo 2020-09-08 14:29:07 UTC
That's not the network speed widget I touched, Nate! :D

Doe the widget use old sensors that are not going through the conversion path?
Comment 2 Nate Graham 2020-09-08 14:30:30 UTC
I know, I just figured you might be roughly familiar with the issue since you're a noted fan of converting network widget graphs! :D
Comment 3 Patrick Silva 2020-10-14 20:24:09 UTC
*** Bug 427710 has been marked as a duplicate of this bug. ***
Comment 4 Patrick Silva 2020-10-14 20:28:59 UTC
*** Bug 427693 has been marked as a duplicate of this bug. ***
Comment 5 David Edmundson 2020-10-14 21:05:00 UTC
Just to confirm, the other sensors are still updating?
Comment 6 Franco Pellegrini 2020-10-14 21:35:28 UTC
I'm using cpu, ram, disk and net. The only with this problem is net.
Comment 7 David Redondo 2020-10-15 06:49:40 UTC
Does 'kstatsviewer network/all/download' or 'kstatsviewer network/all/upload' produce any output?
Any output when running ksystemstats --replace?
Comment 8 Patrick Silva 2020-10-15 09:59:39 UTC
On my Arch Linux only the sensors of Network Speed widget are not working.
On my neon unstable sensors of both Network Speed and Hard Disk Activity are not working.

@David Redondo
Your last command says "Unable to start backend, network information not available." on my neon unstable. The other commands produce no output.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.0
Comment 9 Franco Pellegrini 2020-10-15 10:01:17 UTC
| Does 'kstatsviewer network/all/download' or 'kstatsviewer network/all/upload' 

no output

| Any output when running ksystemstats --replace?

Unable to start backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?

------
Linux/KDE Plasma: KDE Neon
KDE Plasma Version: 5.20
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Comment 10 David Redondo 2020-10-15 10:20:16 UTC
Looks like to me like neon maybe build the ksysguard without networkmanager qt.
Comment 11 MikeC 2020-10-15 10:27:20 UTC
On my arch linux systems the two commands as follows both seem to hang with no output and I have to use ctrl c to kill them:

[mike@lenovo2 ~]$ kstatsviewer network/all/download
^C
[mike@lenovo2 ~]$ kstatsviewer network/all/upload
^C

I get the same as comment 9 output for:
[mike@lenovo2 ~]$ ksystemstats --replace
Unable to start backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?

This system is kernel 5.8.14-arch1-1, plasma 5.20.0-1, frameworks 5.75.0-1 and qt  5.15.1-3

Also the network speed applet only sees the Download Rate and Upload rate, that have no data, and the specific network interfaces that could previously be set for the speed data are no longer accessible in the applet settings.
Comment 12 David Redondo 2020-10-15 11:32:08 UTC
I have confirmed that on Neon it was build without networkmanagerqt and should be corrected on next update. 

MikeC, you probably have some other problem because I confirmed that for another arch user it works.
Comment 13 Arjen Hiemstra 2020-10-15 11:34:22 UTC
For those using Arch, are you using NetworkManager?
Comment 14 Patrick Silva 2020-10-15 11:39:37 UTC
(In reply to Arjen Hiemstra from comment #13)
> For those using Arch, are you using NetworkManager?

yes, I'm using it.
Comment 15 Arjen Hiemstra 2020-10-15 12:01:17 UTC
Could you provide the output of "nmcli"?
Comment 16 Patrick Silva 2020-10-15 12:29:40 UTC
Created attachment 132384 [details]
wrong download rate

(In reply to Arjen Hiemstra from comment #15)
> Could you provide the output of "nmcli"?

Well, I have just turned my Arch machine on and now the Network Speed is working even after re-login despite it indicates wrong download rate. My screenshot shows my system while I download the ISO image of Arch Linux, the correct download rate is 1.9 MiB/s but Network Speed widget says 4.3 MiB/s. plasma-nm applet also shows wrong download rate, but this is another issue I think.
Comment 17 Patrick Silva 2020-10-15 14:02:19 UTC
The widget stopped working again on Arch Linux after a few minutes using the system.

output of Redondo's commands:

1. network/all/download 0 (even during download)
2. network/all/upload 0
3. Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?

$nmcli
enp4s0: connected to Internet
        "Realtek RTL8111/8168/8411"
        ethernet (r8168), FC:AA:14:FC:4B:1B, hw, mtu 1500
        ip4 default
        inet4 192.168.0.50/24
        route4 192.168.0.0/24
        route4 0.0.0.0/0
        inet6 fe80::feaa:14ff:fefc:4b1b/64
        route6 fe80::/64
        route6 ff00::/8

lo: unmanaged
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 208.67.220.220 208.67.222.222
        interface: enp4s0

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.
Comment 18 MikeC 2020-10-15 14:16:42 UTC
On arch linux on m systems I do not use NetworkManager. The wireless is iwd and I use systemd-networkd for networking.  If I go into the applet configuration and select Sensors Details Then click Sensors -> All Network Devices the only options I see are Download Rate (B/s), Total Downloaded (B), Total Uploaded (B), and Upload Rate (B/s). but no interface names with the appropriate set of data names that include the transmission and received rate.
Comment 19 MikeC 2020-10-15 14:24:16 UTC
I don't know if it helps but on the laptop I am working on at the moment the network interface is wlan0, which is working without any problems, and the send and the receive error rate is zero. ifconfig shows all normal, and the status for systemd-networkd as well as iwd are showing normal.  So the problem seems to be with the plasma data engine and not with the rest of the networking. On another machine I have which is an Intel NUC, connected via ethernet, then the same issue occurs - the networking is run on that machine also via systemd-networkd, and the interface is eno1 - but the network speed monitor also only shows the generic "All Network Devices" which then has no data in the graphs, and does not show eno1 as an available interface in the applet sensor options. That machine is also running fully up to date Arch Linux with up to date plasma and frameworks, as well as qt5.
Comment 20 MikeC 2020-10-15 14:29:56 UTC
The output of the iwd status on my laptop is (with mac address obscured)
$ sudo systemctl status iwd
● iwd.service - Wireless service
     Loaded: loaded (/usr/lib/systemd/system/iwd.service; enabled; vendor preset: disabled)
     Active: active (running) since Thu 2020-10-15 14:23:43 BST; 54min ago
   Main PID: 372 (iwd)
      Tasks: 1 (limit: 18429)
     Memory: 3.0M
     CGroup: /system.slice/iwd.service
             └─372 /usr/lib/iwd/iwd

Oct 15 14:23:43 ryzen1 iwd[372]: Wireless daemon version 1.9
Oct 15 14:23:43 ryzen1 systemd[1]: Started Wireless service.
Oct 15 14:23:43 ryzen1 iwd[372]: station: Network configuration is disabled.
Oct 15 14:23:43 ryzen1 iwd[372]: Wiphy: 0, Name: phy0
Oct 15 14:23:43 ryzen1 iwd[372]:         Permanent Address: xx:xx:xx:xx:xx:xx
Oct 15 14:23:43 ryzen1 iwd[372]:         Bands: 2.4 GHz 5 GHz
Oct 15 14:23:43 ryzen1 iwd[372]:         Ciphers: CCMP TKIP BIP
Oct 15 14:23:43 ryzen1 iwd[372]:         Supported iftypes: ad-hoc station ap
Oct 15 14:23:43 ryzen1 iwd[372]: Wiphy phy0 will only use the default interface
Oct 15 14:23:44 ryzen1 iwd[372]: hardware_rekey not supported

and for systemd-networkd:
$ sudo systemctl status systemd-networkd
● systemd-networkd.service - Network Service
     Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2020-10-15 14:23:42 BST; 1h 5min ago
TriggeredBy: ● systemd-networkd.socket
       Docs: man:systemd-networkd.service(8)
   Main PID: 294 (systemd-network)
     Status: "Processing requests..."
      Tasks: 1 (limit: 18429)
     Memory: 4.5M
     CGroup: /system.slice/systemd-networkd.service
             └─294 /usr/lib/systemd/systemd-networkd

Oct 15 14:23:42 ryzen1 systemd-networkd[294]: wlan0: found matching network '/etc/systemd/network/25-wireless.network', based on potentially unpredictable ifname
Oct 15 14:23:42 ryzen1 systemd-networkd[294]: wlan0: IPv6 successfully enabled
Oct 15 14:23:43 ryzen1 systemd-networkd[294]: wlan0: Link UP
Oct 15 14:23:43 ryzen1 systemd-networkd[294]: wlan0: Link DOWN
Oct 15 14:23:44 ryzen1 systemd-networkd[294]: wlan0: Link UP
Oct 15 14:23:44 ryzen1 systemd-networkd[294]: wlan0: Gained carrier
Oct 15 14:23:44 ryzen1 systemd-networkd[294]: wlan0: Connected WiFi access point: mdc-guest (18:31:bf:87:a6:c0)
Oct 15 14:23:44 ryzen1 systemd-networkd[294]: wlan0: found matching network '/etc/systemd/network/25-wireless.network', based on potentially unpredictable ifname
Oct 15 14:23:46 ryzen1 systemd-networkd[294]: wlan0: DHCPv4 address 10.0.0.66/24 via 10.0.0.135
Oct 15 14:23:46 ryzen1 systemd-networkd[294]: wlan0: Gained IPv6LL
Comment 21 Franco Pellegrini 2020-10-15 14:42:40 UTC
1- On my work, i'm using netplan to configure all the interfaces. The widget does not work
2 - On my home, i'm using the default configuration provided by a fresh KDE neon configuration, and wired (did not test wifi). The widget does not work
Comment 22 MikeC 2020-10-15 14:57:33 UTC
If it is any help I ran the konsole command:

plasmaengineexplorer

and in the GUI that opens selected "Network" and clicked "Request source" and then in the search bar "wlan0" - and then all the data sources for wlan0 show up including "wlan0 recieved data rate" and the others that would be expected to be visible in the sensors selection options for the Network Speed applet.  Does this imply that the code within the applet needs to be changed so that the data sources are properly set, updated and displayed?
Comment 23 MikeC 2020-10-15 18:41:11 UTC
Is there any chance that this is actually a bug in ksysguard?  The failure to execute ksystemstats could be due to a bug in the libksysguard package? Is there a way to debug this?
Comment 24 MikeC 2020-10-15 18:57:46 UTC
Another data point - I added the hardware sensors -> k10temp and selected my CPU temp values - they load and display without problems, so it seems that it is the network interfaces that are not available to be loaded into the applet but that other data works fine.
Comment 25 JanKusanagi 2020-10-16 21:17:26 UTC
I really hope using NetworkManager is _not_ required now to use this widget...

The widget's config (besides having all kinds of weird bugs when selecting the "display style" or setting the widget's title) doesn't show any actual network interfaces, only the "all interfaces" which doesn't work at all.

KSysGuard has no issues with this, if that helps.

The weird thing is, I'm fairly sure that the widget worked on my first login into Plasma 5.20...
Comment 26 Franco Pellegrini 2020-10-16 22:59:31 UTC
(In reply to David Edmundson from comment #5)
> Just to confirm, the other sensors are still updating?

my disk activity widget (using an OS on a m.2) has the same issue. Buy if the os is on a Sata SSD, it work just fine.
Comment 27 Patrick Silva 2020-10-16 23:12:10 UTC
I have a SATA hard disk on my laptop running neon unstable and hard disk activity widget is not working for me too.

My partitions:

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1            2048 209712509 209710462  100G  7 HPFS/NTFS/exFAT
/dev/sda2       230600704 341833727 111233024   53G 83 Linux
/dev/sda3       352321520 893337599 541016080  258G  f W95 Ext'd (LBA)
/dev/sda4  *    893337600 970524671  77187072 36.8G 83 Linux
/dev/sda5       352321583 893337599 541016017  258G  7 HPFS/NTFS/exFAT
Comment 28 Patrick Silva 2020-10-17 01:44:36 UTC
After today's updates, Network Speed widget is working again on neon unstable.
But it sometimes stops working apparently without any reason as on my Arch Linux.
Comment 29 MikeC 2020-10-17 11:05:15 UTC
Which update versions give the working speed monitor applet? Was it an update to plasma or to this specific applet?
Comment 30 Nate Graham 2020-10-17 13:42:26 UTC
Plasma 5.20, apparently. The system Monitor applets are distributed with Plasma.

Patrick, you're saying that it mostly works now, but *sometimes* stops working?
Comment 31 Patrick Silva 2020-10-17 13:45:25 UTC
(In reply to Nate Graham from comment #30)
> 
> Patrick, you're saying that it mostly works now, but *sometimes* stops
> working?

Exactly.
Comment 32 Nate Graham 2020-10-17 15:02:33 UTC
That's odd. Can you pinpoint what circumstances seem to cause it to stop working? Is it broken after waking from sleep, for example? Or connecting to a different network? Etc.
Comment 33 MikeC 2020-10-17 18:34:26 UTC
I note that in Arch Linux I have now added the Netspeed Widget, and it shoes the correct download and upload speeds without any problem at all, where the Network Monitor applet fails to do so completely on my Arch machines.  I also had a look at the applet files, and noticed that the data source section of the file contents/ui/main.qml is very different to the code in the applet that isn't working.  I wonder if this needs to be checked?
Comment 34 Patrick Silva 2020-10-17 23:08:25 UTC
(In reply to Nate Graham from comment #32)
> That's odd. Can you pinpoint what circumstances seem to cause it to stop
> working? Is it broken after waking from sleep, for example? Or connecting to
> a different network? Etc.

I always connect my laptop to the same network.
Network Speed widget stops working on my neon unstable after waking from sleep but this is another bug (bug 423616) and it affects other system monitor widgets. I still do not know why Network Speed widget sometimes stops working.
Comment 35 Patrick Silva 2020-10-21 11:32:20 UTC
*** Bug 428041 has been marked as a duplicate of this bug. ***
Comment 36 Ben 2020-10-22 06:34:46 UTC
It works perfectly for me when I first load Plasma (X), but it dies as soon as I activate an OpenVPN connection. The only connections that show up in the plasmoid settings are "Wired Connection 1" both before and after activating the VPN. 

Normally, the connection I use is "eth1", and under network manager this is, indeed, "Wired connection 1". 

Running 5.20.0.
Comment 37 Franco Pellegrini 2020-10-22 09:28:07 UTC
In my case, it NEVER worked. Since fresh new installation until 5.20.1.
Comment 38 Ben 2020-10-22 12:07:51 UTC
I found the same when I first went to the new style of plasmoid (no data), but it worked after I added "ksystemstats" to autostart. In fact, it seems that it works if I restart "ksystemstats" after I activate the VPN connection.
Comment 39 Franco Pellegrini 2020-10-22 12:26:21 UTC
(In reply to Ben from comment #38)
> I found the same when I first went to the new style of plasmoid (no data),
> but it worked after I added "systemstats" to autostart. In fact, it seems
> that it works if I restart "ksystemstats" after I activate the VPN
> connection.

If I try to start Unable to start ksystemstats on kde neon, I get:
backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?
 
Unable to start backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?
Comment 40 Franco Pellegrini 2020-10-23 09:48:13 UTC
If I try sudo ksystemstats:

Unable to start backend, network information not available.
Could not determine Plasma version, got:  "The name org.kde.plasmashell was not provided by any .service files"

and it keeps waiting forever
Comment 41 MikeC 2020-10-23 20:41:42 UTC
If you run ksysguard I believe that it loads the process /usr/bin/ksystemstats if you want to check if that makes a difference to being able to access the network data?
Comment 42 Nicola Mori 2020-10-28 11:17:35 UTC
I'm experiencing the same problem. If i try to run ksystemstats I get:

Unable to start backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?

Running ksysguard the network activity is correctly displayed, and when closing it I get these messages on the terminal:

QProcess: Destroyed while process ("/usr/lib/ksysguard/ksgrd_network_helper") is still running.
org.kde.ksysguard.plugin.network: Helper process terminated abnormally!
org.kde.ksysguard.plugin.network: ""

Plasma 5.20.2 with frameworks 5.75 and Qt 5.15.1 on Archlinux.
Comment 43 MikeC 2020-10-28 20:52:15 UTC
I am running the separate applet called the Netspeed applet - and it displays the download and upload speeds numerically, continuously and correctly, but without a graph of the values. That works consistently without any problems, so if the System Monitor applet is not displaying the network speeds then it is the code for the data sources relating to getting the network interface data within this applet that has bugs, and needs to be re-coded.
Comment 44 MikeC 2020-10-28 20:55:18 UTC
The other applet I referred to in the previous comment is the Netspeed Widget 1.9 - that works fine in displaying network speeds. I am not using Neon but running plasma in arch linux and that was working fine both before and after 5.20.2
Comment 45 Nicola Mori 2020-11-11 07:39:20 UTC
The bug is still present in 5.20.3.
Comment 46 Patrick Silva 2020-11-11 16:06:29 UTC
*** Bug 428960 has been marked as a duplicate of this bug. ***
Comment 47 Franco Pellegrini 2020-11-11 22:18:57 UTC
Confirmed on

Operating System: KDE neon 5.20
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 48 jonzn4SUSE 2020-11-30 11:55:25 UTC
Same issue on openSUSE Tumbleweed.  I also noticed that the widget always works for the root user.  I switch to root and then back to the regular user the widget works for a while.  It also works when I pin Networks from the systray.


Operating System: openSUSE Tumbleweed 20201127
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2
Kernel Version: 5.9.10-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 49 vindicator 2020-12-03 09:16:15 UTC
I'm encountering this on 5.20.4.
I'm using netctl.
Only options are Total Download/Upload (no per interface).
System Monitor(ksysguard) IS showing an active Network History.

*****
$ ksystemstats --replace &
Unable to start backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?
******
Comment 50 jonzn4SUSE 2020-12-04 05:03:53 UTC
I run ksystemstats --replace & and get the same error, but the widget then works.

Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?

[1]    Exit 1                        ksystemstats --replace

Operating System: openSUSE Tumbleweed 20201202
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2
Kernel Version: 5.9.11-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 51 Vladislav Galin 2020-12-06 17:07:45 UTC
I see here the messages about such problem in Arch...

But funny, why it's working in Manjaro then?

Network speed sensors  
in my OS installations:           KDE 5.20.3              KDE 5.20.4

KaOS 2020.11                        fail                     fail
KDE Neon User edition               fail                     fail
Manjaro KDE 20.1                    O.K.                     O.K.
Fedora 33 KDE                       fail                  no update

It's very funny, 
thank you
Comment 52 Vladislav Galin 2020-12-08 06:46:22 UTC
I've just noticed a correlation:

Network speed sensors                           |  Logon options
in my OS installations: KDE 5.20.3   KDE 5.20.4 |
												|
KaOS 2020.11              fail         fail     |  Plasma, and Plasma Wayland
KDE Neon User edition     fail         fail     |  Plasma, and Plasma Wayland
Manjaro KDE 20.1          O.K.         O.K.     |  ONLY Plasma, with NO of Wayland
Fedora 33 KDE             fail      no update   |  Plasma, and Plasma Wayland

The new widgets design looks great, and I like it very much.
Hope that the correlation between that very annoying bug and the presence of Wayland might help.
Comment 53 Nicola Mori 2020-12-08 07:23:02 UTC
I've removed the plasma-wayland-session package from my system to remove the Plasam Wayland option as suggested by Vladislav but still the network widget does not work. If the issue is related to Wayland then maybe it's not related to Plasma Wayland itself.

Archlinux with Plasma 5.20.4-2, Frameworks 5.76.0-1 and Qt 5.15.2-1.
Comment 54 jonzn4SUSE 2020-12-14 23:51:20 UTC
Does the widget work for you root user?  Works for mine every time.

Operating System: openSUSE Tumbleweed 20201211
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2
Kernel Version: 5.9.12-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 55 Vladislav Galin 2020-12-21 14:26:45 UTC
I've tested booting as root. The new Network Speed widget doesn't work on:
Kaos booted as root;
Fedora booted as root.
I don't remember how to boot Neon (Ubuntu) as boot, so not tested.
The new Network Speed widget continue working okay only on Manjaro.
So no news so far...
And I've also checked booting a flash usb drive with the newest Manjaro stable 20.2 iso. This widget can be easily placed at the desktop of Manjaro and works okay in its Live session as well. 
I think the developers have already enough data to get rid of that shame with their new network sensors, or get back the old widgets until they have repaired the new ones.
Comment 56 Marcelo Bossoni 2020-12-29 23:01:40 UTC
Arch user here.

Network manager is installed (because of powerdevil that requires it) but not started/used.
I use netctl for network setup (it is a desktop with static ip)
Ran commands described on comments with the same output.
When searching for interfaces to show, it only show me "All interfaces" option.

But I remember this same widget working.

Also, ksysguard works fine.
Comment 57 jonzn4SUSE 2021-01-05 21:57:49 UTC
Created attachment 134594 [details]
Widget working lately
Comment 58 Franco Pellegrini 2021-01-05 21:59:16 UTC
(In reply to jonzn4suse from comment #57)
> Created attachment 134594 [details]
> Widget working lately

In my 3 different pc, it does not work.
Comment 59 Nicola Mori 2021-01-06 07:53:21 UTC
Also on my Archlinux system the widget still does not work after upgrading to Plasma 5.20.5. It's since Plasma 5.19.0 that it is broken for me, and while being a popular (20 persons in the CC list) and confirmed bug for a basic and default widget still nothing has been done for fixing it.

I ask the KDE devs watching this thread if there is anything that we the users can do to support the fix procedure. I'm growing tired of such a basic functionality being broken for so long.
Comment 60 David Redondo 2021-01-07 12:49:12 UTC
Git commit be88b542e38fecbf50cccc605731343a8f2656f6 by David Redondo.
Committed on 07/01/2021 at 12:48.
Pushed by davidre into branch 'master'.

Add a network backend that uses rtnetlink

Queries information about current network devices using the rtnetlink kernel
interface. This exposed all the info except a pretty name for the current
connection and wireless strength. We can use this as a fallback on Linux if
NetworkManager is not available.
Because this is our fallback on Linux libnl is now required (from recommended).

M  +10   -6    CMakeLists.txt
M  +14   -3    cmake/FindNL.cmake
M  +7    -2    plugins/global/network/CMakeLists.txt
M  +1    -0    plugins/global/network/NetworkBackend.h
M  +0    -2    plugins/global/network/NetworkDevice.h
M  +1    -1    plugins/global/network/NetworkManagerBackend.h
M  +13   -0    plugins/global/network/NetworkPlugin.cpp
M  +2    -0    plugins/global/network/NetworkPlugin.h
A  +160  -0    plugins/global/network/RtNetlinkBackend.cpp     [License: LGPL(3+eV) LGPL(v3.0) LGPL(v2.1)]
A  +48   -0    plugins/global/network/RtNetlinkBackend.h     [License: LGPL(3+eV) LGPL(v3.0) LGPL(v2.1)]

https://invent.kde.org/plasma/ksysguard/commit/be88b542e38fecbf50cccc605731343a8f2656f6
Comment 61 Nicola Mori 2021-01-07 15:18:07 UTC
Thanks David for the fix. I'm not familiar with KDE code but from the comment it seems to me that the fix is a fallback for when NetworkManager is not available. So should the widget work when NetworkManager is present? I'm asking because I have networkmanager and networkmanager-qt installed on my Archlinux system but the widget doesn't work: should I install some other NetworkManager component, or maybe I'm completely wrong and installing NetworkManager is not supposed to fix anything?
Thanks again.
Comment 62 jonzn4SUSE 2021-01-19 15:46:29 UTC
The widget has stopped working for me today.  Had to run ksystemstats --replace & for it to work.

Operating System: openSUSE Tumbleweed 20210118
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.7-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 63 Franco Pellegrini 2021-02-02 09:56:46 UTC
On my end, If I type 
sudo ksystemstats --replace
I get:
Unable to start backend, network information not available.
Could not determine Plasma version, got:  "The name org.kde.plasmashell was not provided by any .service files"

Operating System: KDE neon 5.20
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.4.0-65-generic
OS Type: 64-bit
Processors: 6 × Intel® Core™ i5-8400 CPU @ 2.80GHz
Memory: 22.9 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Comment 64 Patrick Silva 2021-02-02 16:15:28 UTC
This bug persists on neon unstable.
In the attached screen recording, my system is downloading updates but
the Network Speed widget displays download and upload rates as 0,0 B/s.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.21.80
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Comment 65 Patrick Silva 2021-02-02 16:16:01 UTC
Created attachment 135369 [details]
screen recording on neon unstable
Comment 66 David Redondo 2021-02-02 16:32:48 UTC
Actually it looks like we now have the info, the chart is displaying stuff but the legend is broken.
Comment 67 David Redondo 2021-02-02 16:40:28 UTC
I filed https://bugs.kde.org/show_bug.cgi?id=432426 for the legend issue
Comment 68 Franco Pellegrini 2021-02-02 17:41:25 UTC
This was never fixed. Don't know why is tagged as fixed...
Comment 69 David Redondo 2021-02-02 18:36:07 UTC
(In reply to Franco Pellegrini from comment #68)
> This was never fixed. Don't know why is tagged as fixed...

At the beginning we queried info from NetworkManager.
It was obviously not getting info for people not using NetworkManager.
Then I wrote a new backend getting network info from the kernel. While it cannot show a pretty name of a connection or wireless strengrh, we can use it if NetworkManager is not available during build or runtime. This is why the bug status is fixed. The automated comment 60 triggered by the commit should contain similiar info I think...
The "version fixed in" field should also explains why it doesn't work with Plasma 5.20.5
Comment 70 Nicola Mori 2021-02-02 18:43:07 UTC
@DavidRedondo as I already explained in comment 61 I have several NetworkManager packages installed in my Archlinux system, yet the network widget doesn't work. This makes me think that the issue might not be 100% connected to NetworkManager, but I got no reply to my comment asking for clarifications.
Comment 71 David Redondo 2021-02-02 19:25:14 UTC
(In reply to Nicola Mori from comment #70)
> @DavidRedondo as I already explained in comment 61 I have several
> NetworkManager packages installed in my Archlinux system, yet the network
> widget doesn't work. This makes me think that the issue might not be 100%
> connected to NetworkManager, but I got no reply to my comment asking for
> clarifications.

Do you use NetworkManager for managing your connections (not just having the packages)? With Plasma 5.21 it should now work in both cases. But maybe there is a case where with some combination it doesn't work and then we can look further?
Comment 72 Nicola Mori 2021-02-02 19:33:03 UTC
I don't use NetworkManager, I just have it installed. But in comment 14 another Arch user reports he is using it and still he has the problem. Maybe Arch builds ksysguard without networkmanager-qt (as per comment 10 I understand this might be the source of teh problem, right?).
Comment 73 Franco Pellegrini 2021-02-02 21:47:33 UTC
(In reply to David Redondo from comment #71)
> (In reply to Nicola Mori from comment #70)
> > @DavidRedondo as I already explained in comment 61 I have several
> > NetworkManager packages installed in my Archlinux system, yet the network
> > widget doesn't work. This makes me think that the issue might not be 100%
> > connected to NetworkManager, but I got no reply to my comment asking for
> > clarifications.
> 
> Do you use NetworkManager for managing your connections (not just having the
> packages)? With Plasma 5.21 it should now work in both cases. But maybe
> there is a case where with some combination it doesn't work and then we can
> look further?

I use the default KDE Neon installation, and the problem appear in all my PCs.
Comment 74 David Redondo 2021-02-03 08:19:36 UTC
(In reply to Franco Pellegrini from comment #73)
> I use the default KDE Neon installation, and the problem appear in all my
> PCs.

I see that you are on 5.20.5, which does not have the new backend. While the default KDE Neon should use NetworkManager that is a bit curious. If nmcli correctly shows verything I have no idea at the moment.

(In reply to Nicola Mori from comment #72)
> I don't use NetworkManager, I just have it installed. But in comment 14
> another Arch user reports he is using it and still he has the problem. Maybe
> Arch builds ksysguard without networkmanager-qt (as per comment 10 I
> understand this might be the source of teh problem, right?).

When it is build without networkmanager-qt we should have now the new backend in Plasma 5.21 hopefully. I wonder maybe there is also a case where it is build with NetworManager but you don't use  it for your connections.

If you run "NLCB=debug ksystemstats --replace" and don't see a bunch of stuff then we are using the NetworkManager backend, if you see a lot of output, it's using the rtnetlink backend which should always work.
Comment 75 Nicola Mori 2021-02-03 08:29:33 UTC
@David I just rebuilt ksysguard on my system where networkmanager-qt is installed. The CMake output seems to indicate that Kf5NetworkManagerQy is correctly found:


-- The following RECOMMENDED packages have been found:

 * KF5NetworkManagerQt (required version >= 5.74)
   Provides an improved backend for Network statistics


but libKF5NetworkManagerQt.so is not linked to the ksysguard nor the ksystemstats executables. anyway network information is correctly displayed by ksysguard, the widget still don't work and running "NLCB=debug sudo ksystemstats --replace" gives:

Unable to start backend, network information not available.
Unable to register DBus service org.kde.ksystemstats. Maybe it is already running?
Comment 76 David Redondo 2021-02-03 08:48:49 UTC
(In reply to Nicola Mori from comment #75)
> @David I just rebuilt ksysguard on my system where networkmanager-qt is
> installed. The CMake output seems to indicate that Kf5NetworkManagerQy is
> correctly found:
> 
> 
> -- The following RECOMMENDED packages have been found:
> 
>  * KF5NetworkManagerQt (required version >= 5.74)
>    Provides an improved backend for Network statistics
> 
> 
> but libKF5NetworkManagerQt.so is not linked to the ksysguard nor the
> ksystemstats executables. anyway network information is correctly displayed
> by ksysguard, the widget still don't work and running "NLCB=debug sudo
> ksystemstats --replace" gives:
> 
> Unable to start backend, network information not available.
> Unable to register DBus service org.kde.ksystemstats. Maybe it is already
> running?

It's linked into a plugin. Seems like --replace option also is not in Plasma 5.20 and the message is not in Plasma 5.21 so you are running/building an older one?
See: https://invent.kde.org/plasma/ksysguard/-/commit/348e452a523849bf9fd35ee323ea807229575962
Comment 77 Nicola Mori 2021-02-03 09:07:23 UTC
According to my package manager, the ksystemstats executable in my system is part of the ksysguard 5.20.5 package:

$ pacman -Qo `which ksystemstats`      
/usr/bin/ksystemstats is owned by ksysguard 5.20.5-1

I don't know if this is relevant or not, but judging from other comments (e.g. comment 62) it seems the --replace option should work with version 5.20.5.
Comment 78 Nate Graham 2021-02-03 14:40:48 UTC
That means you're still using 5.20.5, which makes sense because 5.21 hasn't been released yet. Once it is, this will be fixed for you once you upgrade to it. See https://community.kde.org/Get_Involved/Issue_Reporting#Understand_what_the_resolution_statuses_mean

Let me know if anything is still unclear.
Comment 79 Nicola Mori 2021-02-03 15:01:19 UTC
@Nate Thanks, I already had clear in mind that the fix is going to ship in 5.21. I just had a residual curiosity about what makes the widget work bad in 5.20, since I think I compiled ksysguard with networkmanager-qt and still the widget does not work (maybe I should use NetworkManager to configure my connection?) while ksysguard itself shows the network traffic correctly. But it's not a big deal now that the fix is coming, even if I'd like to restore this functionality possibly without waiting for 5.21.
Comment 80 jonzn4SUSE 2021-02-17 17:02:56 UTC
Created attachment 135772 [details]
network widget

Still broken in 5.21.  see screenshot

Operating System: openSUSE Tumbleweed 20210215
KDE Plasma Version: 5.21.0
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.16-1-default
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 81 David Redondo 2021-02-17 17:21:37 UTC
Can you check if this is actually https://bugs.kde.org/show_bug.cgi?id=433063 ?
Comment 82 jonzn4SUSE 2021-02-17 20:24:19 UTC
I noticed that in past, but just run cmd(ksystemstats --replace &) to get it to work.
Comment 83 lists@rhsoft.net 2021-02-25 10:29:56 UTC
and why was the old one which worked pretty fine on systems just using "ip" command for configure EIGHT interfcaces including bridges and wireless access points replaced to begin with?

same for the disk-io widget whcih at least basicly works but most of the configuration has no effect
Comment 85 lists@rhsoft.net 2021-02-25 10:41:01 UTC
> gives some of the reasons why the move to ksystemstats

fine, but i would prefer replacing things when they are new ones *really* working *at least* as good as the current ones

----------------

i mean look at all the options simply not working for the disk-io widget and you see that this stuff is far away from finished and shouldn't considered to be thrown at users at that point in time

on a german desktop all the time it switches between "Schreiben" and "Disk Write Access" and that state is what users becoming when upgrade from Fedora 32 to 33?

----------------

at the end of the day these are the things why Plasma as good as it is in theory isn't default on most distributions, that and the tragedy that every major release needs years to get as clean and stable as the past one is horrible

and i know KDE from 1.0 - after years of not using Linux i switched with KDE3 finally and both 4/5 where horrible, never saw that much crashes and lost configs as after the first login with Plasma5

if it ain't broken don't fix it please
Comment 86 jonzn4SUSE 2021-03-21 07:35:59 UTC
This video shows running the command to get the widget to work.

https://youtu.be/3QOdc7H_ZaM?t=110


Operating System: openSUSE Tumbleweed 20210319
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.6-1-default
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 87 lists@rhsoft.net 2021-09-23 20:01:39 UTC
after upgrade to Fedora 34 it's working again

it's a joke that all the time random things stop working and sometimes get fixed 6 or 12 months later - still don't get what was wrong with the for years working stuff which needed to be replaced with something broken before it was ready

well, now some autostarts don#t worj, CTRL+F2 didn't work and god knows what is broken now which i didn't realize within the past few hours

what about just stop develop new features and only fix bugs for some years? there are enough for a lifetime