Bug 427693 - System Monitor Sensor 1.0 does not retain interfaces after logout in plasma 5.20
Summary: System Monitor Sensor 1.0 does not retain interfaces after logout in plasma 5.20
Status: RESOLVED DUPLICATE of bug 425992
Alias: None
Product: plasmashell
Classification: Plasma
Component: System Monitor (show other bugs)
Version: master
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-14 14:15 UTC by MikeC
Modified: 2020-10-14 20:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MikeC 2020-10-14 14:15:03 UTC
SUMMARY
After update to Plasma 5.20 the network speed monitor applet loses the network interface settings on logout

STEPS TO REPRODUCE
1. Place the System Monitor Sensor applet on the desktop
2. In the configuration settings choose interface received and sent rate
3. Applet shows the upload and download speeds
4. Logout
5. Log back in
6. Network speed graph is now empty and no longer shows the interfaces or any data

OBSERVED RESULT
Applet loses interface settings and speed graphs on logout

EXPECTED RESULT
Applet should retain the interface definitions and speed graphs should be present when logging back in.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 5.8.14-arch1-1
(available in About System)
KDE Plasma Version: 5.20.0-1
KDE Frameworks Version: 5.75.0-1
Qt Version: 5.15.1-3

ADDITIONAL INFORMATION
Comment 1 Patrick Silva 2020-10-14 20:28:59 UTC

*** This bug has been marked as a duplicate of bug 425992 ***