Bug 423616 - System monitor desktop widgets are frozen after resume from suspend
Summary: System monitor desktop widgets are frozen after resume from suspend
Status: RESOLVED WORKSFORME
Alias: None
Product: plasmashell
Classification: Plasma
Component: System Monitor (show other bugs)
Version: 5.19.3
Platform: Archlinux Linux
: VHI normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords:
: 426876 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-28 14:33 UTC by Nicola Mori
Modified: 2021-01-08 14:43 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicola Mori 2020-06-28 14:33:08 UTC
SUMMARY
All my system monitor desktop widgets (Network speed, Memory usage, and a couple of customized ones) are not updated after resuming my laptop from suspend-to-ram. Killing and restarting the Plasma shell does not help.

STEPS TO REPRODUCE
1. Suspend to ram
2. Resume from suspend

OBSERVED RESULT
After resume the widgets are not updated with time.

EXPECTED RESULT
The widgets should be refreshed to show the current system status.


SOFTWARE/OS VERSIONS
Linux: Archlinux
KDE Plasma Version: 5.19.2
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Comment 1 Nicola Mori 2020-07-08 15:23:30 UTC
With Plasma 5.19.3 I don't experience the problem anymore, so I guess that it has been incidentally fixed in this release. Thanks!
Comment 2 Nicola Mori 2020-07-10 07:28:47 UTC
I spoke too early, I got again a freeze with Plasma 5.19.3.
Comment 3 Nate Graham 2020-09-23 18:14:14 UTC
*** Bug 426876 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2020-10-29 23:55:58 UTC
Which face (pie, line, text) did you use when this happened?
Comment 5 Nicola Mori 2020-10-30 07:17:24 UTC
It surely happened with bar chart and with text-only. I don't remember exactly about line, and I don't use pie.
Actually, it's a bit that I don't notice any problem but I might have overlooked that. I'll keep the eyes opened and report here in a few days.
Thanks.
Comment 6 Nicola Mori 2020-11-02 13:13:09 UTC
I didn't experience any freeze with 5.20.2 during the last few days, so probably the bug has been incidentally fixed. I think this issue can be closed, I'll reopen it should the freeze happen again.
Comment 7 Nate Graham 2021-01-08 14:43:15 UTC
*** Bug 426876 has been marked as a duplicate of this bug. ***