Bug 418491 - ksysguard crashes on close
Summary: ksysguard crashes on close
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-03-05 10:57 UTC by Eric Wenzke
Modified: 2020-03-30 09:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Wenzke 2020-03-05 10:57:41 UTC
Application: ksysguard (5.18.2)

Qt Version: 5.14.1
Frameworks Version: 5.67.0
Operating System: Linux 5.3.0-40-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.18

-- Information about the crash:
- What I was doing when the application crashed:
After closing the window, the crash message appears, doesn't happen all the time but quite often.

The crash can be reproduced every time.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f755e414c00 (LWP 21574))]

Thread 4 (Thread 0x7f7522f3a700 (LWP 21577)):
#0  0x00007f755dcee0b4 in __GI___libc_read (fd=8, buf=0x7f7522f39760, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f754b7842d0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f754b73f0b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f754b73f570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f754b73f6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f755955b0db in QEventDispatcherGlib::processEvents (this=0x7f751c000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f75594fa63a in QEventLoop::exec (this=this@entry=0x7f7522f39970, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f755930b317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007f7559c87555 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007f755930c7ec in QThreadPrivate::start (arg=0x7f7559effda0) at thread/qthread_unix.cpp:342
#10 0x00007f754d6bf6db in start_thread (arg=0x7f7522f3a700) at pthread_create.c:463
#11 0x00007f755dcff88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f7529220700 (LWP 21576)):
#0  0x00007f754d6c59f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c10ac644c8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55c10ac64478, cond=0x55c10ac644a0) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55c10ac644a0, mutex=0x55c10ac64478) at pthread_cond_wait.c:655
#3  0x00007f752a77cecb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f752a77cac7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f754d6bf6db in start_thread (arg=0x7f7529220700) at pthread_create.c:463
#6  0x00007f755dcff88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f753291e700 (LWP 21575)):
#0  0x00007f755dcf2bf9 in __GI___poll (fds=0x7f753291d8a8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f754e154747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f754e15636a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f7534a65cc0 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f755930c7ec in QThreadPrivate::start (arg=0x55c10ac17c60) at thread/qthread_unix.cpp:342
#5  0x00007f754d6bf6db in start_thread (arg=0x7f753291e700) at pthread_create.c:463
#6  0x00007f755dcff88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f755e414c00 (LWP 21574)):
[KCrash Handler]
#6  0x00007f7559394d4a in operator== (s1=..., s2=...) at text/qstring.cpp:3383
#7  0x00007f755aa49205 in QLabel::setText (this=0x55c10b05d590, text=...) at widgets/qlabel.cpp:287
#8  0x00007f755e042170 in TopLevel::answerReceived (this=0x55c10afce470, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:466
#9  0x00007f755d08db8a in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007f755d094e24 in ?? () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f7559536fe7 in QtPrivate::QSlotObjectBase::call (a=0x7fff9249afa0, r=0x55c10b0bae10, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#12 doActivate<false> (sender=0x55c10b0bba50, signal_index=15, argv=0x7fff9249afa0) at kernel/qobject.cpp:3870
#13 0x00007f75595318a2 in QMetaObject::activate (sender=sender@entry=0x55c10b0bba50, m=m@entry=0x7f75599c77e0 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7fff9249afa0) at kernel/qobject.cpp:3930
#14 0x00007f755946a2ba in QProcess::readyReadStandardOutput (this=this@entry=0x55c10b0bba50, _t1=...) at .moc/moc_qprocess.cpp:367
#15 0x00007f7559470b11 in QProcessPrivate::tryReadFromChannel (this=0x55c10afd4a70, channel=0x55c10afd4b80) at io/qprocess.cpp:1073
#16 0x00007f7559470fe0 in QProcessPrivate::_q_canReadStandardOutput (this=<optimized out>) at io/qprocess.cpp:1084
#17 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff9249b150) at .moc/moc_qprocess.cpp:208
#18 0x00007f7559536dc9 in doActivate<false> (sender=0x55c10b08b060, signal_index=3, argv=0x7fff9249b150) at kernel/qobject.cpp:3882
#19 0x00007f75595318a2 in QMetaObject::activate (sender=sender@entry=0x55c10b08b060, m=m@entry=0x7f75599c9bc0 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff9249b150) at kernel/qobject.cpp:3930
#20 0x00007f755953a5c8 in QSocketNotifier::activated (this=this@entry=0x55c10b08b060, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:141
#21 0x00007f755953a982 in QSocketNotifier::event (this=0x55c10b08b060, e=0x7fff9249b420) at kernel/qsocketnotifier.cpp:266
#22 0x00007f755a9158bc in QApplicationPrivate::notify_helper (this=this@entry=0x55c10ac0bff0, receiver=receiver@entry=0x55c10b08b060, e=e@entry=0x7fff9249b420) at kernel/qapplication.cpp:3684
#23 0x00007f755a91cac0 in QApplication::notify (this=0x7fff9249b710, receiver=0x55c10b08b060, e=0x7fff9249b420) at kernel/qapplication.cpp:3430
#24 0x00007f75594fbdb8 in QCoreApplication::notifyInternal2 (receiver=0x55c10b08b060, event=0x7fff9249b420) at kernel/qcoreapplication.cpp:1092
#25 0x00007f75594fbf8e in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7fff9249b420) at kernel/qcoreapplication.cpp:1487
#26 0x00007f755955bc88 in socketNotifierSourceDispatch (source=0x55c10ac61660) at kernel/qeventdispatcher_glib.cpp:107
#27 0x00007f754b73f417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f754b73f650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f754b73f6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f755955b0bc in QEventDispatcherGlib::processEvents (this=0x55c10ac62ed0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#31 0x00007f75594fa63a in QEventLoop::exec (this=this@entry=0x7fff9249b640, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#32 0x00007f7559503db0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#33 0x00007f755e04407a in kdemain (argc=<optimized out>, argv=<optimized out>) at ./gui/ksysguard.cpp:627
#34 0x00007f755dbffb97 in __libc_start_main (main=0x55c10951a720 <main>, argc=1, argv=0x7fff9249b858, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9249b848) at ../csu/libc-start.c:310
#35 0x000055c10951a75a in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 418449.

Possible duplicates by query: bug 418449, bug 416379, bug 415503, bug 414845, bug 414802.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-03-30 09:06:11 UTC

*** This bug has been marked as a duplicate of bug 350140 ***