Bug 418449 - KSysGuard crashed on close
Summary: KSysGuard crashed on close
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.16.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-03-04 00:07 UTC by Lastique
Modified: 2020-03-30 09:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2020-03-04 00:07:13 UTC
Application: ksysguard (5.16.5)

Qt Version: 5.12.4
Frameworks Version: 5.62.0
Operating System: Linux 5.3.0-40-lowlatency x86_64
Distribution: Ubuntu 19.10

-- Information about the crash:
- What I was doing when the application crashed:

KSysGuard crashed when I closed its window. The crash is not 100% reproducible.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc32424ef00 (LWP 15815))]

Thread 4 (Thread 0x7fc31b7fe700 (LWP 15822)):
#0  0x00007fc32de48c3d in g_mutex_lock () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc32ddfc940 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc32ddfcb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc336099653 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fc3360405cb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fc335e79a45 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fc3363c7efa in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fc335e7ac92 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fc32e658669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007fc337a4c323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fc31bfff700 (LWP 15821)):
#0  0x00007fc32e65f6e0 in futex_abstimed_wait_cancelable (private=<optimized out>, abstime=0x7fc31bffe600, clockid=<optimized out>, expected=0, futex_word=0x7fc314000d2c) at ../sysdeps/unix/sysv/linux/futex-internal.h:208
#1  0x00007fc32e65f6e0 in __pthread_cond_wait_common (abstime=0x7fc31bffe600, clockid=<optimized out>, mutex=0x560286b2ea38, cond=0x7fc314000d00) at pthread_cond_wait.c:520
#2  0x00007fc32e65f6e0 in __pthread_cond_timedwait (cond=0x7fc314000d00, mutex=0x560286b2ea38, abstime=0x7fc31bffe600) at pthread_cond_wait.c:656
#3  0x00007fc321446794 in  () at /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.440.64
#4  0x00007fc3211a444c in  () at /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.440.64
#5  0x00007fc32144596c in  () at /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.440.64
#6  0x00007fc32e658669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007fc337a4c323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fc323634700 (LWP 15819)):
#0  0x00007fc337a3fc2f in __GI___poll (fds=0x7fc3236335a8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fc32e6bb917 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fc32e6bd53a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fc323b6f288 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fc335e7ac92 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fc32e658669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007fc337a4c323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fc32424ef00 (LWP 15815)):
[KCrash Handler]
#6  0x00007fc335efd6dd in operator==(QString const&, QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fc336cd833b in QLabel::setText(QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007fc337b92223 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007fc3377bc378 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007fc3377c3802 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007fc33606d558 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007fc335fbd49e in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007fc335fc3ba9 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007fc335fc3f12 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007fc33606d3f8 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007fc33607a0c5 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fc33607a421 in QSocketNotifier::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007fc336b9ca86 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007fc336ba5e00 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007fc336041a2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007fc33609a295 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007fc32ddfc84d in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fc32ddfcad0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fc32ddfcb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fc336099635 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fc3360405cb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fc336048336 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007fc337b93fdf in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#29 0x00007fc3379511e3 in __libc_start_main (main=0x560285822060, argc=1, argv=0x7ffe9df87338, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe9df87328) at ../csu/libc-start.c:308
#30 0x000056028582209e in _start ()
[Inferior 1 (process 15815) detached]

Reported using DrKonqi
Comment 1 Christoph Feck 2020-03-30 09:06:06 UTC

*** This bug has been marked as a duplicate of bug 350140 ***