Bug 414845 - ksysguard crashes on close
Summary: ksysguard crashes on close
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.17.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-12-05 04:25 UTC by ptsd
Modified: 2019-12-27 17:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ptsd 2019-12-05 04:25:00 UTC
Application: ksysguard (5.17.0)

Qt Version: 5.12.4
Frameworks Version: 5.62.0
Operating System: Linux 5.3.0-24-generic x86_64
Distribution: Ubuntu 19.10

-- Information about the crash:
- What I was doing when the application crashed: I closed ksysguard from the latte panel (hover over running program, press close on thumbnail)

- Unusual behavior I noticed: i was attempting to run solaris-qt Version v2.8.1.0-1a02f8e at the same time, yet was getting errors that Solaris was running and could not open, so I verified with ksysguard that it was in fact NOT RUNNING before attempting to start solaris-qt again

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6de2a3e440 (LWP 13498))]

Thread 3 (Thread 0x7f6dda32a700 (LWP 13500)):
#0  0x00007f6dec61bc68 in g_mutex_unlock () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6dec5cf27e in g_main_context_query () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6dec5cf9b8 in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6dec5cfb73 in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6df486c6c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6df481363b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6df464ca75 in QThread::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f6df4b9aefa in  () at /lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007f6df464dcc2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6dece2b669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#10 0x00007f6df6234323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f6de1e24700 (LWP 13499)):
#0  0x00007f6df6227c2f in __GI___poll (fds=0x7f6de1e235a8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f6dece8e917 in  () at /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f6dece9053a in xcb_wait_for_event () at /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6de2382288 in  () at /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f6df464dcc2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6dece2b669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007f6df6234323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f6de2a3e440 (LWP 13498)):
[KCrash Handler]
#6  0x00007f6df539b958 in QWidget::sizePolicy() const () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#7  0x00007f6df54aa453 in  () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007f6df54ab42b in QLabel::setText(QString const&) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007f6df6379bb3 in  () at /lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#10 0x00007f6df5fa33b8 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f6df5faa842 in  () at /lib/x86_64-linux-gnu/libksgrd.so.7
#12 0x00007f6df48405c8 in QMetaObject::activate(QObject*, int, int, void**) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f6df47904ce in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f6df4796bd9 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f6df4796f42 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f6df4840468 in QMetaObject::activate(QObject*, int, int, void**) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f6df484d135 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f6df484d491 in QSocketNotifier::event(QEvent*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f6df536fa86 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007f6df5378e00 in QApplication::notify(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007f6df4814a9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f6df486d305 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f6dec5cf84d in g_main_context_dispatch () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f6dec5cfad0 in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f6dec5cfb73 in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f6df486c6a5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007f6df481363b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f6df481b3a6 in QCoreApplication::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f6df637b97e in kdemain () at /lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#30 0x00007f6df61391e3 in __libc_start_main (main=0x564fb7aba060, argc=1, argv=0x7ffc7cc1e018, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc7cc1e008) at ../csu/libc-start.c:308
#31 0x0000564fb7aba09e in _start ()
[Inferior 1 (process 13498) detached]

The reporter indicates this bug may be a duplicate of or related to bug 414802.

Possible duplicates by query: bug 414802, bug 414728, bug 414700, bug 414685, bug 414528.

Reported using DrKonqi
Comment 1 Christoph Feck 2019-12-27 17:47:26 UTC

*** This bug has been marked as a duplicate of bug 350140 ***