Bug 417435 - Chash when update packages
Summary: Chash when update packages
Status: RESOLVED DUPLICATE of bug 414047
Alias: None
Product: apper
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0.0
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-02-11 17:03 UTC by Italo Schneider
Modified: 2020-03-06 12:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Italo Schneider 2020-02-11 17:03:44 UTC
Application: apper (1.0.0)

Qt Version: 5.14.1
Frameworks Version: 5.67.0
Operating System: Linux 5.5.2-arch2-2 x86_64
Distribution: Arch Linux

-- Information about the crash:
- What I was doing when the application crashed:
It updated normally but ended the program suddenly afterwards.

-- Backtrace:
Application: Apper (apper), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7feff2b08180 (LWP 5054))]

Thread 7 (Thread 0x7fefdbfff700 (LWP 5064)):
#0  0x00007feff662acf5 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fefe9ef7dec in  () at /usr/lib/dri/i965_dri.so
#2  0x00007fefe9ef79e8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007feff662446f in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007feff6dc83d3 in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7fefe8832700 (LWP 5063)):
#0  0x00007feff662acf5 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fefe9ef7dec in  () at /usr/lib/dri/i965_dri.so
#2  0x00007fefe9ef79e8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007feff662446f in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007feff6dc83d3 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7fefe9033700 (LWP 5062)):
#0  0x00007feff662acf5 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fefe9ef7dec in  () at /usr/lib/dri/i965_dri.so
#2  0x00007fefe9ef79e8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007feff662446f in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007feff6dc83d3 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7fefe9834700 (LWP 5061)):
#0  0x00007feff662acf5 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fefe9ef7dec in  () at /usr/lib/dri/i965_dri.so
#2  0x00007fefe9ef79e8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007feff662446f in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007feff6dc83d3 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7fefebf7a700 (LWP 5056)):
#0  0x00007feff6dbdabf in poll () at /usr/lib/libc.so.6
#1  0x00007feff6295120 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007feff62951f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007feff737603c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007feff731c4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007feff7140e52 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007feff7659b28 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007feff7141fc6 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007feff662446f in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007feff6dc83d3 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7feff1cd3700 (LWP 5055)):
#0  0x00007feff6dbdabf in poll () at /usr/lib/libc.so.6
#1  0x00007feff53ea630 in  () at /usr/lib/libxcb.so.1
#2  0x00007feff53ec2db in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007feff26a8b81 in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007feff7141fc6 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007feff662446f in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007feff6dc83d3 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7feff2b08180 (LWP 5054)):
[KCrash Handler]
#6  0x00007feff8dfc873 in  () at /usr/lib/apper/libapper_private.so
#7  0x00007feff8df54eb in PackageModel::clearSelectedNotPresent() () at /usr/lib/apper/libapper_private.so
#8  0x0000561a53837b2b in  ()
#9  0x00007feff735346e in  () at /usr/lib/libQt5Core.so.5
#10 0x00007feff8d52bd9 in PackageKit::Transaction::finished(PackageKit::Transaction::Exit, unsigned int) () at /usr/lib/libpackagekitqt5.so.1
#11 0x00007feff8d57016 in  () at /usr/lib/libpackagekitqt5.so.1
#12 0x00007feff8d54d11 in  () at /usr/lib/libpackagekitqt5.so.1
#13 0x00007feff73534a0 in  () at /usr/lib/libQt5Core.so.5
#14 0x00007feff8d6d401 in  () at /usr/lib/libpackagekitqt5.so.1
#15 0x00007feff8d6e353 in  () at /usr/lib/libpackagekitqt5.so.1
#16 0x00007feff7666350 in  () at /usr/lib/libQt5DBus.so.5
#17 0x00007feff734b26a in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#18 0x00007feff7ee3362 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#19 0x00007feff7eec819 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#20 0x00007feff731d962 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#21 0x00007feff73201c6 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#22 0x00007feff73769d4 in  () at /usr/lib/libQt5Core.so.5
#23 0x00007feff629339e in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#24 0x00007feff62951b1 in  () at /usr/lib/libglib-2.0.so.0
#25 0x00007feff62951f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#26 0x00007feff7376020 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#27 0x00007feff731c4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#28 0x00007feff73244d6 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#29 0x0000561a538283ab in  ()
#30 0x00007feff6cf0023 in __libc_start_main () at /usr/lib/libc.so.6
#31 0x0000561a5382849e in _start ()
[Inferior 1 (process 5054) detached]

Possible duplicates by query: bug 417285, bug 416900, bug 416816, bug 416730, bug 416549.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-03-06 12:24:42 UTC

*** This bug has been marked as a duplicate of bug 414047 ***