Bug 416549 - IMAP crashing
Summary: IMAP crashing
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-21 19:06 UTC by Grzegorz
Modified: 2020-09-22 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz 2020-01-21 19:06:55 UTC
Application: akonadi_imap_resource (5.13.1 (19.12.1))

Qt Version: 5.13.1
Frameworks Version: 5.66.0
Operating System: Linux 5.4.10-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:
Kmail was open on diffrentvirtual desktop
- Custom settings of the application:
Crashes are irregular, but as far i didn't experienced them when there were no rules set to filter mail

The crash can be reproduced sometimes.

-- Backtrace:
Application: Konto IMAP 13 (akonadi_imap_resource), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f866d90ef80 (LWP 14410))]

Thread 25 (Thread 0x7f86037fe700 (LWP 14436)):
#0  0x00007f867ee31bdf in poll () at /lib64/libc.so.6
#1  0x00007f867b62c2ee in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f867b62c40f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f867d1e7a2b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f867d19015b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f867cfc8011 in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f867cfc9192 in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#8  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 24 (Thread 0x7f8603fff700 (LWP 14435)):
#0  0x00007f867ee31bdf in poll () at /lib64/libc.so.6
#1  0x00007f867b62c2ee in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f867b62c40f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f867d1e7a2b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f867d19015b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f867cfc8011 in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f867cfc9192 in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#8  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 23 (Thread 0x7f861d7fa700 (LWP 14432)):
#0  0x00007f867ee31bdf in poll () at /lib64/libc.so.6
#1  0x00007f867b62c2ee in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f867b62c40f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f867d1e7a2b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f867d19015b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f867cfc8011 in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f867cfc9192 in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#8  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 22 (Thread 0x7f861dffb700 (LWP 14431)):
#0  0x00007f867c47bb90 in pthread_getspecific () at /lib64/libpthread.so.0
#1  0x00007f867b655640 in g_thread_self () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f867b62c3ff in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f867d1e7a2b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f867d19015b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f867cfc8011 in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f867e3124f6 in  () at /usr/lib64/libQt5DBus.so.5
#7  0x00007f867cfc9192 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#9  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 21 (Thread 0x7f861e7fc700 (LWP 14430)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 20 (Thread 0x7f861effd700 (LWP 14429)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 19 (Thread 0x7f861f7fe700 (LWP 14428)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 18 (Thread 0x7f861ffff700 (LWP 14427)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 17 (Thread 0x7f863cff9700 (LWP 14426)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 16 (Thread 0x7f863d7fa700 (LWP 14425)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 15 (Thread 0x7f863dffb700 (LWP 14424)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 14 (Thread 0x7f863e7fc700 (LWP 14423)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 13 (Thread 0x7f863effd700 (LWP 14422)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 12 (Thread 0x7f863f7fe700 (LWP 14421)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 11 (Thread 0x7f863ffff700 (LWP 14420)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 10 (Thread 0x7f865cd95700 (LWP 14419)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 9 (Thread 0x7f865d596700 (LWP 14418)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 8 (Thread 0x7f865dd97700 (LWP 14417)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 7 (Thread 0x7f865e598700 (LWP 14416)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7f865ed99700 (LWP 14415)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f865f59a700 (LWP 14414)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f8668a19700 (LWP 14413)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f8669390700 (LWP 14412)):
#0  0x00007f867c47a6a5 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f8669a1a05b in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f8669a19ec7 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#4  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f866b8cf700 (LWP 14411)):
#0  0x00007f867ee31bdf in poll () at /lib64/libc.so.6
#1  0x00007f867c2c2752 in  () at /usr/lib64/libxcb.so.1
#2  0x00007f867c2c340a in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007f866ba43fb0 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f867cfc9192 in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007f867c473f2a in start_thread () at /lib64/libpthread.so.0
#6  0x00007f867ee3c4af in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f866d90ef80 (LWP 14410)):
[KCrash Handler]
#6  0x00007f867ed790d1 in raise () at /lib64/libc.so.6
#7  0x00007f867ed6255d in abort () at /lib64/libc.so.6
#8  0x00007f867cdbb64b in  () at /usr/lib64/libstdc++.so.6
#9  0x00007f867cdc6ff8 in  () at /usr/lib64/libstdc++.so.6
#10 0x00007f867cdc7063 in  () at /usr/lib64/libstdc++.so.6
#11 0x00007f867cdc7309 in __cxa_rethrow () at /usr/lib64/libstdc++.so.6
#12 0x0000562614f502ac in  ()
#13 0x0000562614f5fc7b in  ()
#14 0x0000562614f7ee80 in  ()
#15 0x00007f867d1bc6c8 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#16 0x00007f867e59de0c in KJob::result(KJob*, KJob::QPrivateSignal) () at /usr/lib64/libKF5CoreAddons.so.5
#17 0x00007f867e5a28d3 in KJob::finishJob(bool) () at /usr/lib64/libKF5CoreAddons.so.5
#18 0x00007f867ec41718 in KIMAP::Job::handleErrorReplies(KIMAP::Response const&) () at /usr/lib64/libKF5IMAP.so.5
#19 0x00007f867ec49486 in KIMAP::MoveJob::handleResponse(KIMAP::Response const&) () at /usr/lib64/libKF5IMAP.so.5
#20 0x00007f867ec3c02d in KIMAP::SessionPrivate::responseReceived(KIMAP::Response const&) () at /usr/lib64/libKF5IMAP.so.5
#21 0x00007f867d1bcf7a in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#22 0x00007f867dd87c62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#23 0x00007f867dd911e0 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#24 0x00007f867d1915f2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#25 0x00007f867d194288 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQt5Core.so.5
#26 0x00007f867d1e83d3 in  () at /usr/lib64/libQt5Core.so.5
#27 0x00007f867b62bff8 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#28 0x00007f867b62c380 in  () at /usr/lib64/libglib-2.0.so.0
#29 0x00007f867b62c40f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#30 0x00007f867d1e7a11 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#31 0x00007f867d19015b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#32 0x00007f867d197dc2 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#33 0x00007f867eb1b3de in Akonadi::ResourceBase::init(Akonadi::ResourceBase&) () at /usr/lib64/libKF5AkonadiAgentBase.so.5
#34 0x0000562614f55de9 in  ()
#35 0x00007f867ed63e0b in __libc_start_main () at /lib64/libc.so.6
#36 0x0000562614f55fda in  ()
[Inferior 1 (process 14410) detached]

The reporter indicates this bug may be a duplicate of or related to bug 415339, bug 415930.

Possible duplicates by query: bug 416416, bug 416379, bug 416360, bug 416337, bug 416307.

Reported using DrKonqi
Comment 1 Grzegorz 2020-01-21 19:10:42 UTC
I forgot to mention: I have second mail setup in KMail (Gmail account) that hasn't seen single crash
Comment 2 Ahmad Samir 2020-08-23 19:13:27 UTC
If you still see this issue, please install the required debuginfo package and post a new backtrace (the current one is incomplete).
Comment 3 Bug Janitor Service 2020-09-07 04:33:08 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2020-09-22 04:33:13 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!