Bug 417285 - Akonadi crashed and refuses to start after adding toolbar icon to kmail
Summary: Akonadi crashed and refuses to start after adding toolbar icon to kmail
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.13.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-02-07 20:43 UTC by Benjamin Hiebert
Modified: 2020-09-22 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Hiebert 2020-02-07 20:43:22 UTC
Application: akonadi_control (5.13.1)

Qt Version: 5.14.1
Frameworks Version: 5.66.0
Operating System: Linux 5.5.2-1.g3a91916-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
Everything was working fine until i added an icon to the kmail toolbar through kontact and it immediately crashed and now crashes and refuses to work every single time i try to start it.

-- Backtrace:
Application: Akonadi Control (akonadi_control), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd1a4d6dd80 (LWP 12285))]

Thread 3 (Thread 0x7fd19bfff700 (LWP 12287)):
#0  0x00007fd1a7d275fc in read () at /lib64/libc.so.6
#1  0x00007fd1a68611df in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fd1a6819e47 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fd1a681a292 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fd1a681a40f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007fd1a70b1c6b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007fd1a7059bfb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#7  0x00007fd1a6e8462e in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#8  0x00007fd1a7abe507 in  () at /usr/lib64/libQt5DBus.so.5
#9  0x00007fd1a6e856f8 in  () at /usr/lib64/libQt5Core.so.5
#10 0x00007fd1a6b99efa in start_thread () at /lib64/libpthread.so.0
#11 0x00007fd1a7d364bf in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fd1a2ccb700 (LWP 12286)):
#0  0x00007fd1a7d2bbcf in poll () at /lib64/libc.so.6
#1  0x00007fd1a5810752 in  () at /usr/lib64/libxcb.so.1
#2  0x00007fd1a581140a in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007fd1a2ec2ab0 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007fd1a6e856f8 in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007fd1a6b99efa in start_thread () at /lib64/libpthread.so.0
#6  0x00007fd1a7d364bf in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fd1a4d6dd80 (LWP 12285)):
[KCrash Handler]
#6  0x00007fd1a7c72ea1 in raise () at /lib64/libc.so.6
#7  0x00007fd1a7c5c53d in abort () at /lib64/libc.so.6
#8  0x000055756551c201 in akMessageHandler(QtMsgType, QMessageLogContext const&, QString const&) (type=<optimized out>, msg=..., context=...) at /usr/src/debug/akonadi-server-19.12.1-216.1.x86_64/src/shared/akdebug.cpp:205
#9  0x000055756551c201 in akMessageHandler(QtMsgType, QMessageLogContext const&, QString const&) (type=<optimized out>, context=..., msg=...) at /usr/src/debug/akonadi-server-19.12.1-216.1.x86_64/src/shared/akdebug.cpp:194
#10 0x000055756551cbdc in (anonymous namespace)::RemoteLogger::dbusLogger(QtMsgType, QMessageLogContext const&, QString const&) (type=QtFatalMsg, ctx=..., msg=...) at /usr/src/debug/akonadi-server-19.12.1-216.1.x86_64/src/shared/akremotelog.cpp:178
#11 0x00007fd1a6e7d3f8 in  () at /usr/lib64/libQt5Core.so.5
#12 0x00007fd1a6e7d519 in  () at /usr/lib64/libQt5Core.so.5
#13 0x00007fd1a6e4cad6 in QMessageLogger::fatal(char const*, ...) const () at /usr/lib64/libQt5Core.so.5
#14 0x00005575655186b3 in AgentManager::AgentManager(bool, QObject*) (parent=0x0, verbose=<optimized out>, this=0x7ffdd68d2b40) at /usr/include/c++/9/bits/atomic_base.h:326
#15 0x00005575655186b3 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/akonadi-server-19.12.1-216.1.x86_64/src/akonadicontrol/main.cpp:81
[Inferior 1 (process 12285) detached]

Possible duplicates by query: bug 417195, bug 417072, bug 416986, bug 416900, bug 416816.

Reported using DrKonqi
Comment 1 Ahmad Samir 2020-08-23 10:31:26 UTC
I am not sure this is related to adding an icon to the toolbar, more to do with that there's already another instance of akonadiserver running, and then the AgentManager ctor hitting this:
    qFatal("akonadiserver already running!");

could be that the issue was triggered by adding an icon, I don't know; it could be that the akonadiserver instance is stuck... what I would try is:
akonatictl stop
akonadictl start

do you still see this issue?
Comment 2 Bug Janitor Service 2020-09-07 04:33:09 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2020-09-22 04:33:13 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!