Bug 416067 - System Settings crash when selecting Deutch
Summary: System Settings crash when selecting Deutch
Status: RESOLVED DUPLICATE of bug 411795
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_formats (show other bugs)
Version: 5.17.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-09 20:45 UTC by gktoilet
Modified: 2020-01-20 13:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gktoilet 2020-01-09 20:45:55 UTC
Application: systemsettings5 (5.17.5)

Qt Version: 5.13.2
Frameworks Version: 5.65.0
Operating System: Linux 5.0.0-37-generic x86_64
Distribution: KDE neon User Edition 5.17

-- Information about the crash:
- What I was doing when the application crashed:
I click on the Deutch setting in region, this then crashes System setting, but it doesn't happen in danish or english british nor american english.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5f09d57800 (LWP 14315))]

Thread 7 (Thread 0x7f5ed1284700 (LWP 14323)):
#0  0x00007f5efe935a74 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5efe9364fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5efe9366dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5f05bd4b9b in QEventDispatcherGlib::processEvents (this=0x7f5ec4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f5f05b7506a in QEventLoop::exec (this=this@entry=0x7f5ed1283d80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f5f059903aa in QThread::exec (this=this@entry=0x55c3091c4d20) at thread/qthread.cpp:531
#6  0x00007f5f03733815 in QQmlThreadPrivate::run (this=0x55c3091c4d20) at qml/ftw/qqmlthread.cpp:152
#7  0x00007f5f05991b52 in QThreadPrivate::start (arg=0x55c3091c4d20) at thread/qthread_unix.cpp:360
#8  0x00007f5f00cf56db in start_thread (arg=0x7f5ed1284700) at pthread_create.c:463
#9  0x00007f5f0528e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f5ed3dbb700 (LWP 14322)):
#0  0x00007f5f05281bf9 in __GI___poll (fds=0x7f5ecc003ce0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5efe9365c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5efe9366dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5f05bd4b9b in QEventDispatcherGlib::processEvents (this=0x7f5ecc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f5f05b7506a in QEventLoop::exec (this=this@entry=0x7f5ed3dbad80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f5f059903aa in QThread::exec (this=this@entry=0x55c30376a770) at thread/qthread.cpp:531
#6  0x00007f5f03733815 in QQmlThreadPrivate::run (this=0x55c30376a770) at qml/ftw/qqmlthread.cpp:152
#7  0x00007f5f05991b52 in QThreadPrivate::start (arg=0x55c30376a770) at thread/qthread_unix.cpp:360
#8  0x00007f5f00cf56db in start_thread (arg=0x7f5ed3dbb700) at pthread_create.c:463
#9  0x00007f5f0528e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f5edc8ab700 (LWP 14321)):
#0  0x00007f5efe97c664 in g_mutex_unlock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5efe935fd9 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5efe936570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5efe9366dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5f05bd4b9b in QEventDispatcherGlib::processEvents (this=0x7f5ed8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5f05b7506a in QEventLoop::exec (this=this@entry=0x7f5edc8aad80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007f5f059903aa in QThread::exec (this=this@entry=0x55c303461cd0) at thread/qthread.cpp:531
#7  0x00007f5f03733815 in QQmlThreadPrivate::run (this=0x55c303461cd0) at qml/ftw/qqmlthread.cpp:152
#8  0x00007f5f05991b52 in QThreadPrivate::start (arg=0x55c303461cd0) at thread/qthread_unix.cpp:360
#9  0x00007f5f00cf56db in start_thread (arg=0x7f5edc8ab700) at pthread_create.c:463
#10 0x00007f5f0528e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f5ee60c4700 (LWP 14319)):
#0  0x00007f5f00cfb9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c302fd0fb8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55c302fd0f68, cond=0x55c302fd0f90) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55c302fd0f90, mutex=0x55c302fd0f68) at pthread_cond_wait.c:655
#3  0x00007f5ee73972cb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f5ee7396ff7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f5f00cf56db in start_thread (arg=0x7f5ee60c4700) at pthread_create.c:463
#6  0x00007f5f0528e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f5eeeafb700 (LWP 14318)):
#0  0x00007f5f0527d0b4 in __GI___libc_read (fd=15, buf=0x7f5eeeafab60, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f5efe97b2d0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5efe9360b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5efe936570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5efe9366dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5f05bd4b9b in QEventDispatcherGlib::processEvents (this=0x7f5ee8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f5f05b7506a in QEventLoop::exec (this=this@entry=0x7f5eeeafad70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f5f059903aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#8  0x00007f5f0604b0e5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007f5f05991b52 in QThreadPrivate::start (arg=0x7f5f062c2d80) at thread/qthread_unix.cpp:360
#10 0x00007f5f00cf56db in start_thread (arg=0x7f5eeeafb700) at pthread_create.c:463
#11 0x00007f5f0528e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f5ef6d50700 (LWP 14317)):
#0  0x00007f5f05281bf9 in __GI___poll (fds=0x7f5ef6d4fca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5f008b9747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5f008bb36a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5ef9b35e10 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f5f05991b52 in QThreadPrivate::start (arg=0x55c302f25c90) at thread/qthread_unix.cpp:360
#5  0x00007f5f00cf56db in start_thread (arg=0x7f5ef6d50700) at pthread_create.c:463
#6  0x00007f5f0528e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f5f09d57800 (LWP 14315)):
[KCrash Handler]
#6  QQmlData::wasDeleted (object=0x55c30aec1170) at ../../include/QtQml/5.13.2/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:342
#7  QV4::QObjectWrapper::wrap (engine=engine@entry=0x55c3091b72e0, object=0x55c30aec1170) at ../../include/QtQml/5.13.2/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:215
#8  0x00007f5f0365904c in QV4::ExecutionEngine::fromVariant (this=this@entry=0x55c3091b72e0, variant=...) at jsruntime/qv4engine.cpp:1524
#9  0x00007f5f035b8a76 in searchContextProperties (v4=v4@entry=0x55c3091b72e0, context=context@entry=0x55c30ae8aad0, name=<optimized out>, hasProperty=hasProperty@entry=0x7fffbcb90bd7, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at jsruntime/qv4qmlcontext.cpp:126
#10 0x00007f5f035b9905 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=receiver@entry=0x0, hasProperty=hasProperty@entry=0x7fffbcb90bd7, base=base@entry=0x0, lookup=0x0, lookup@entry=0x55c30920d700) at jsruntime/qv4qmlcontext.cpp:274
#11 0x00007f5f035ba145 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x55c30920d700, engine=0x55c3091b72e0, base=0x0) at jsruntime/qv4qmlcontext.cpp:478
#12 0x00007f5ecb7be21c in ?? ()
#13 0x0000000000000000 in ?? ()

Possible duplicates by query: bug 413792, bug 413083, bug 411910, bug 411837, bug 411795.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-01-20 13:17:10 UTC

*** This bug has been marked as a duplicate of bug 411795 ***