Bug 413083 - trying to add language Neddersass'sch to Plasma translations
Summary: trying to add language Neddersass'sch to Plasma translations
Status: RESOLVED DUPLICATE of bug 411795
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.17.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-10-17 11:38 UTC by Carlo Borger
Modified: 2019-10-17 11:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo Borger 2019-10-17 11:38:40 UTC
Application: systemsettings5 (5.17.0)

Qt Version: 5.13.1
Frameworks Version: 5.63.0
Operating System: Linux 5.3.5-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed: 
I added the language Neddersass'sch to the Plasma translations it makes the System Settings application crash. this is reproducable every time.

- Unusual behavior I noticed: 
Before this I noticed the user login (SDDM) refuses to start after a user has logged in, this gives an errormessage in journalctl -e :
============================================================================================================================================================
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Loading file:///usr/share/sddm/themes/Frog/Main.qml...
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Adding view for "DisplayPort-1" QRect(1920,0 1920x1200)
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Loading file:///usr/share/sddm/themes/Frog/Main.qml...
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Adding view for "HDMI-0" QRect(3840,0 1920x1080)
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Message received from daemon: Capabilities
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Message received from daemon: HostName
Oct 17 13:23:25 linux-ngu6 sddm-greeter[9542]: Hunspell dictionary is missing for "en_GB" . Search paths ("/usr/share/qt5/qtvi>
Oct 17 13:23:29 linux-ngu6 systemd[1]: Stopping User Manager for UID 1000...
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Stopped target Main User Target.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Stopped target Basic System.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Stopped target Paths.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Stopped target Sockets.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Stopped target Timers.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: dbus.socket: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Closed D-Bus User Message Bus Socket.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: pulseaudio.socket: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Closed Sound System.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Reached target Shutdown.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: systemd-exit.service: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Started Exit the Session.
Oct 17 13:23:29 linux-ngu6 systemd[9454]: Reached target Exit the Session.
Oct 17 13:23:29 linux-ngu6 systemd[1]: user@1000.service: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[1]: Stopped User Manager for UID 1000.
Oct 17 13:23:29 linux-ngu6 systemd[1]: Stopping User Runtime Directory /run/user/1000...
Oct 17 13:23:29 linux-ngu6 systemd[2579]: run-user-1000.mount: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[2836]: run-user-1000.mount: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[1]: run-user-1000.mount: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[1]: user-runtime-dir@1000.service: Succeeded.
Oct 17 13:23:29 linux-ngu6 systemd[1]: Stopped User Runtime Directory /run/user/1000.
Oct 17 13:23:29 linux-ngu6 systemd[1]: Removed slice User Slice of UID 1000.
============================================================================================================================================================

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc3d280a900 (LWP 10834))]

Thread 21 (Thread 0x7fc37aa66700 (LWP 10858)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 20 (Thread 0x7fc37b7fe700 (LWP 10857)):
#0  0x00007fc3d509fbdf in poll () from /lib64/libc.so.6
#1  0x00007fc3d32dc3ce in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fc3d32dd343 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fc3843d3516 in ?? () from /usr/lib64/libgio-2.0.so.0
#4  0x00007fc3d32b9acd in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#6  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 19 (Thread 0x7fc37bfff700 (LWP 10856)):
#0  0x00007fc3d509b60c in read () from /lib64/libc.so.6
#1  0x00007fc3d328e70f in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fc3d32dacbe in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fc3d32dc372 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fc3d32dc49f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fc3d32dc4f1 in ?? () from /usr/lib64/libglib-2.0.so.0
#6  0x00007fc3d32b9acd in ?? () from /usr/lib64/libglib-2.0.so.0
#7  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#8  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 18 (Thread 0x7fc386dee700 (LWP 10854)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 17 (Thread 0x7fc3875ef700 (LWP 10853)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 16 (Thread 0x7fc395771700 (LWP 10850)):
#0  0x00007fc3d509fbdf in poll () from /lib64/libc.so.6
#1  0x00007fc3d32dc3ce in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fc3d32dc49f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fc3d563f99b in QEventDispatcherGlib::processEvents (this=0x7fc380000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fc3d55e80db in QEventLoop::exec (this=this@entry=0x7fc395770c80, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007fc3d5420021 in QThread::exec (this=this@entry=0x5640bb6a45e0) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007fc3d471a3f5 in QQmlThreadPrivate::run (this=0x5640bb6a45e0) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.1.x86_64/src/qml/qml/ftw/qqmlthread.cpp:152
#7  0x00007fc3d54211a2 in QThreadPrivate::start (arg=0x5640bb6a45e0) at thread/qthread_unix.cpp:360
#8  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#9  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 15 (Thread 0x7fc396ffd700 (LWP 10848)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 14 (Thread 0x7fc3977fe700 (LWP 10847)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 13 (Thread 0x7fc397fff700 (LWP 10846)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7fc3b8ff9700 (LWP 10845)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7fc3b97fa700 (LWP 10844)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7fc3b9ffb700 (LWP 10843)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fc3ba7fc700 (LWP 10842)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fc3baffd700 (LWP 10841)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fc3bb7fe700 (LWP 10840)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fc3bbfff700 (LWP 10839)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fc3c892f700 (LWP 10838)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fc3c9271700 (LWP 10837)):
#0  0x00007fc3d3c646a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc3c988ab8b in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fc3c988aa37 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fc3cbb06700 (LWP 10836)):
#0  0x00007fc3d509fbdf in poll () from /lib64/libc.so.6
#1  0x00007fc3d32dc3ce in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fc3d32dc49f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fc3d563f99b in QEventDispatcherGlib::processEvents (this=0x7fc3c4000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fc3d55e80db in QEventLoop::exec (this=this@entry=0x7fc3cbb05c70, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007fc3d5420021 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007fc3d58c84f6 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007fc3d54211a2 in QThreadPrivate::start (arg=0x7fc3d594ad80) at thread/qthread_unix.cpp:360
#8  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#9  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fc3d0a23700 (LWP 10835)):
#0  0x00007fc3d509fbdf in poll () from /lib64/libc.so.6
#1  0x00007fc3d3c2d742 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007fc3d3c2e3fa in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007fc3d0c20f90 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007fc3d54211a2 in QThreadPrivate::start (arg=0x5640bad5bd20) at thread/qthread_unix.cpp:360
#5  0x00007fc3d3c5df2a in start_thread () from /lib64/libpthread.so.0
#6  0x00007fc3d50aa4af in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fc3d280a900 (LWP 10834)):
[KCrash Handler]
#6  QQmlData::wasDeleted (object=0x5640bc5a3360) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.1.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:342
#7  QV4::QObjectWrapper::wrap (engine=engine@entry=0x5640bb6c13f0, object=0x5640bc5a3360) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.1.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:215
#8  0x00007fc3d4634f7c in QV4::ExecutionEngine::fromVariant (this=this@entry=0x5640bb6c13f0, variant=...) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.1.x86_64/src/qml/jsruntime/qv4engine.cpp:1524
#9  0x00007fc3d458ad3d in searchContextProperties (v4=v4@entry=0x5640bb6c13f0, context=context@entry=0x5640bc57bad0, name=<optimized out>, hasProperty=hasProperty@entry=0x7fff4b90e187, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at /usr/include/qt5/QtCore/qlist.h:116
#10 0x00007fc3d458bbd0 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=<optimized out>, hasProperty=0x7fff4b90e187, base=0x0, lookup=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.1.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:301
#11 0x00007fc3d458c504 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x5640bb90e1e0, engine=0x5640bb6c13f0, base=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.1.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:398
#12 0x00007fc3865dc39c in ?? ()
#13 0x0000000000000000 in ?? ()
[Inferior 1 (process 10834) detached]

The reporter indicates this bug may be a duplicate of or related to bug 404518.

Possible duplicates by query: bug 411910, bug 411837, bug 411795, bug 411594, bug 410790.

Reported using DrKonqi
Comment 1 David Edmundson 2019-10-17 11:52:20 UTC

*** This bug has been marked as a duplicate of bug 411795 ***