Bug 415960 - Email account (IMAP) crashes arbitrarily
Summary: Email account (IMAP) crashes arbitrarily
Status: RESOLVED DUPLICATE of bug 415339
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-07 10:42 UTC by Iyán Méndez Veiga
Modified: 2020-01-17 10:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iyán Méndez Veiga 2020-01-07 10:42:28 UTC
Application: akonadi_imap_resource (5.13.0 (19.12.0))

Qt Version: 5.14.0
Frameworks Version: 5.65.0
Operating System: Linux 5.4.8-arch1-1 x86_64
Distribution: Arch Linux

-- Information about the crash:
Since last big update (19.12) one of my email accounts using IMAP crashes arbitrarely (or that's what it looks to me).  It only happens to one in particular, the rest still function perfectly. I am using Archlinux, but I have compiled with debug symbols some of the involved packages (kdepim-runtime, akonadi...).

The crash can be reproduced sometimes.

-- Backtrace:
Application: me@iyanmv.com (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f867c9cab80 (LWP 996))]

Thread 10 (Thread 0x7f86537fe700 (LWP 4462)):
#0  0x00007f868e6a542c in read () at /usr/lib/libc.so.6
#1  0x00007f868cae69f0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f868cb349e1 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f868cb360c8 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f868cb361f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f868ec7ccdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f868ec2339c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f868ea48e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f868ea49fd6 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#10 0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7f8670d27700 (LWP 1149)):
#0  0x00007f868cb33d42 in  () at /usr/lib/libglib-2.0.so.0
#1  0x00007f868cb3467c in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f868cb3593b in g_main_context_prepare () at /usr/lib/libglib-2.0.so.0
#3  0x00007f868cb36046 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f868cb361f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f868ec7ccdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f868ec2339c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f868ea48e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f868ea49fd6 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#10 0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7f8671f38700 (LWP 1102)):
#0  0x00007f868e6a99ef in poll () at /usr/lib/libc.so.6
#1  0x00007f868cb36120 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f868cb361f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f868ec7ccdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f868ec2339c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f868ea48e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f868ea49fd6 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7f8672739700 (LWP 1101)):
#0  0x00007f868e6a542c in read () at /usr/lib/libc.so.6
#1  0x00007f868cae69f0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f868cb349e1 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f868cb360c8 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f868cb361f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f868ec7ccdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f868ec2339c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f868ea48e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f868fe21b28 in  () at /usr/lib/libQt5DBus.so.5
#9  0x00007f868ea49fd6 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7f8673fff700 (LWP 1098)):
#0  0x00007f868dc2ec45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f867a38ed0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f867a38e908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f8678cf6700 (LWP 1097)):
#0  0x00007f868dc2ec45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f867a38ed0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f867a38e908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f86794f7700 (LWP 1096)):
#0  0x00007f868dc2ec45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f867a38ed0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f867a38e908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f8679cf8700 (LWP 1095)):
#0  0x00007f868dc2ec45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f867a38ed0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f867a38e908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f867bf3b700 (LWP 1079)):
#0  0x00007f868e6a99ef in poll () at /usr/lib/libc.so.6
#1  0x00007f868da6e630 in  () at /usr/lib/libxcb.so.1
#2  0x00007f868da702db in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007f867c88ba01 in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f868ea49fd6 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f868dc284cf in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f868e6b42d3 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f867c9cab80 (LWP 996)):
[KCrash Handler]
#6  0x000055f9c440ec00 in ImapAccount::authenticationMode() const (this=0x0) at /usr/src/debug/kdepim-runtime-19.12.0/resources/imap/imapaccount.cpp:85
#7  0x000055f9c443e597 in SessionPool::requestPassword() (this=0x55f9c4b65840) at /usr/src/debug/kdepim-runtime-19.12.0/resources/imap/sessionpool.cpp:88
#8  0x000055f9c44429a5 in SessionPool::processPendingRequests() (this=0x55f9c4b65840) at /usr/src/debug/kdepim-runtime-19.12.0/resources/imap/sessionpool.cpp:302
#9  0x00007f868ec5213a in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#10 0x00007f868f878472 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#11 0x00007f868f881c89 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#12 0x00007f868ec24832 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#13 0x00007f868ec27096 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#14 0x00007f868ec7d674 in  () at /usr/lib/libQt5Core.so.5
#15 0x00007f868cb3439e in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#16 0x00007f868cb361b1 in  () at /usr/lib/libglib-2.0.so.0
#17 0x00007f868cb361f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#18 0x00007f868ec7ccc0 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#19 0x00007f868ec2339c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#20 0x00007f868ec2b3a6 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#21 0x00007f869075dd22 in Akonadi::ResourceBase::init(Akonadi::ResourceBase&) (r=...) at /usr/include/qt/QtCore/qcoreapplication.h:116
#22 0x000055f9c43db778 in Akonadi::ResourceBase::init<ImapResource>(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/include/KF5/AkonadiAgentBase/resourcebase.h:181
#23 0x00007f868e5dc153 in __libc_start_main () at /usr/lib/libc.so.6
#24 0x000055f9c43d989e in _start () at /usr/src/debug/kdepim-runtime-19.12.0/resources/imap/main.cpp:22
[Inferior 1 (process 996) detached]

The reporter indicates this bug may be a duplicate of or related to bug 415930, bug 415339, bug 409419.

Possible duplicates by query: bug 415930, bug 415339, bug 409419, bug 361101, bug 357227.

Reported using DrKonqi
Comment 1 Iyán Méndez Veiga 2020-01-10 06:12:25 UTC
Exactly same issue after upgrading to 19.12.1.
Comment 2 Christophe Giboudeaux 2020-01-17 10:00:49 UTC

*** This bug has been marked as a duplicate of bug 415339 ***