Bug 361101 - Kmail IMAP crash with hotmail account
Summary: Kmail IMAP crash with hotmail account
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-03-28 16:48 UTC by noucamp13
Modified: 2018-12-02 03:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noucamp13 2016-03-28 16:48:09 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 3.19.0-32-generic x86_64
Distribution: Linux Mint 17.3 Rosa

-- Information about the crash:
- Unusual behavior I noticed:
I have serveral IMAP accounts, 2 of them with Hotmail, and this one in particular takes a long time to load new email. Sometimes, after coming from hybernation, the email does not respond anymore. Shutting down the application and re-opening it is not enough. I am forced to restart the computer.

Prior to this happening, I had come back from hybernation (Kmail had been closed) and I received repeated messages that Akonadi was unable to delete events in the calendar. I was forced to restart the computer as no application was responding. Upon restarting, I opened Kmail and the problem described with the IMAP acocunt happened.

The behaviour described with the Calendar deletion has happened several times in the past.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Casa Infinito of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f32415447c0 (LWP 2817))]

Thread 3 (Thread 0x7f32271cc700 (LWP 3744)):
#0  0x00007f323ced682d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f323be9ec10 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f323be5db14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f323be5df7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f323be5e0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3240b767be in QEventDispatcherGlib::processEvents (this=0x7f32140008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f3240b480af in QEventLoop::processEvents (this=this@entry=0x7f32271cbe20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3240b483a5 in QEventLoop::exec (this=this@entry=0x7f32271cbe20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3240a44c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9  0x00007f3240a4732f in QThreadPrivate::start (arg=0xf32c70) at thread/qthread_unix.cpp:349
#10 0x00007f323c542182 in start_thread (arg=0x7f32271cc700) at pthread_create.c:312
#11 0x00007f323cee547d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f322cb96700 (LWP 3745)):
#0  0x00007f323ced682d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f323be9ec10 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f323be5db14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f323be5df7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f323be5e0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3240b767be in QEventDispatcherGlib::processEvents (this=0x7f3220005e80, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f3240b480af in QEventLoop::processEvents (this=this@entry=0x7f322cb95e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3240b483a5 in QEventLoop::exec (this=this@entry=0x7f322cb95e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3240a44c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9  0x00007f3240a4732f in QThreadPrivate::start (arg=0x101b750) at thread/qthread_unix.cpp:349
#10 0x00007f323c542182 in start_thread (arg=0x7f322cb96700) at pthread_create.c:312
#11 0x00007f323cee547d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f32415447c0 (LWP 2817)):
[KCrash Handler]
#6  operator char const* (this=<optimized out>) at /usr/include/qt4/QtCore/qbytearray.h:425
#7  KIMAP::Session::selectedMailBox (this=0xff8020) at ../../kimap/session.cpp:449
#8  0x0000000000446b1f in RetrieveItemsTask::startRetrievalTasks (this=this@entry=0xf41c50) at ../../../resources/imap/retrieveitemstask.cpp:150
#9  0x0000000000446e0e in RetrieveItemsTask::doStart (this=0xf41c50, session=<optimized out>) at ../../../resources/imap/retrieveitemstask.cpp:98
#10 0x000000000043ab13 in ResourceTask::onSessionRequested (this=0xf41c50, requestId=<optimized out>, session=0xff8020, errorCode=0) at ../../../resources/imap/resourcetask.cpp:119
#11 0x00000000004648b5 in ResourceTask::qt_static_metacall (_o=0x7ffc2de894b0, _c=16744480, _id=-1, _a=0x1035e40) at moc_resourcetask.cpp:69
#12 0x00007f3240b5d87a in QMetaObject::activate (sender=sender@entry=0xf3ea80, m=m@entry=0x482160 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffc2de89730) at kernel/qobject.cpp:3539
#13 0x0000000000464962 in SessionPool::sessionRequestDone (this=this@entry=0xf3ea80, _t1=_t1@entry=123, _t2=_t2@entry=0xff8020, _t3=_t3@entry=0, _t4=...) at moc_sessionpool.cpp:153
#14 0x000000000045086a in SessionPool::processPendingRequests (this=0xf3ea80) at ../../../resources/imap/sessionpool.cpp:257
#15 0x0000000000464a2d in SessionPool::qt_static_metacall (_o=0x7ffc2de894b0, _c=16744480, _id=-1, _a=0x1035e40) at moc_sessionpool.cpp:92
#16 0x00007f3240b61c1e in QObject::event (this=0xf3ea80, e=<optimized out>) at kernel/qobject.cpp:1194
#17 0x00007f323fee2e2c in QApplicationPrivate::notify_helper (this=this@entry=0xd94f70, receiver=receiver@entry=0xf3ea80, e=e@entry=0xe377b0) at kernel/qapplication.cpp:4567
#18 0x00007f323fee94a0 in QApplication::notify (this=this@entry=0x7ffc2de89ec0, receiver=receiver@entry=0xf3ea80, e=e@entry=0xe377b0) at kernel/qapplication.cpp:4353
#19 0x00007f323e027cca in KApplication::notify (this=0x7ffc2de89ec0, receiver=0xf3ea80, event=0xe377b0) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f3240b494dd in QCoreApplication::notifyInternal (this=0x7ffc2de89ec0, receiver=receiver@entry=0xf3ea80, event=event@entry=0xe377b0) at kernel/qcoreapplication.cpp:953
#21 0x00007f3240b4cb3d in sendEvent (event=0xe377b0, receiver=0xf3ea80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xd57220) at kernel/qcoreapplication.cpp:1577
#23 0x00007f3240b4cfe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#24 0x00007f3240b76f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#25 postEventSourceDispatch (s=0xd79fc0) at kernel/qeventdispatcher_glib.cpp:287
#26 0x00007f323be5de04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f323be5e048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f323be5e0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f3240b767a1 in QEventDispatcherGlib::processEvents (this=0xd58700, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#30 0x00007f323ff84be6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f3240b480af in QEventLoop::processEvents (this=this@entry=0x7ffc2de89e30, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f3240b483a5 in QEventLoop::exec (this=this@entry=0x7ffc2de89e30, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007f3240b4db79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#34 0x00007f323fee137c in QApplication::exec () at kernel/qapplication.cpp:3828
#35 0x00007f324102a783 in Akonadi::ResourceBase::init (r=r@entry=0xeef920) at ../../akonadi/resourcebase.cpp:579
#36 0x0000000000418993 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:193
#37 0x00007f323ce0cec5 in __libc_start_main (main=0x4182e0 <main(int, char**)>, argc=3, argv=0x7ffc2de89fd8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc2de89fc8) at libc-start.c:287
#38 0x0000000000418854 in _start ()

Possible duplicates by query: bug 349904.

Reported using DrKonqi
Comment 1 Andrew Crouthamel 2018-11-01 13:53:39 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Bug Janitor Service 2018-11-16 11:40:19 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-12-02 03:46:28 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!