Bug 415930 - imap account crash
Summary: imap account crash
Status: RESOLVED DUPLICATE of bug 415339
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-06 14:00 UTC by Philippe ROUBACH
Modified: 2020-01-17 10:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2020-01-06 14:00:39 UTC
Application: akonadi_imap_resource (5.13.0 (19.12.0))

Qt Version: 5.14.0
Frameworks Version: 5.65.0
Operating System: Linux 4.12.14-lp151.28.36-default x86_64
Distribution: "openSUSE Leap 15.1"

-- Information about the crash:
- What I was doing when the application crashed:
kontact was minimized in the systray.

i was reading somthing with firefox

-- Backtrace:
Application: Free Telecom (epistemepromeneur) (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1f6da29a00 (LWP 21400))]

Thread 8 (Thread 0x7f1f24ed8700 (LWP 31947)):
#0  0x00007f1f64445c10 in pthread_getspecific () from /lib64/libpthread.so.0
#1  0x00007f1f60ef1fd0 in g_thread_self () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f60eca2ad in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1f68599a3b in QEventDispatcherGlib::processEvents (this=0x7f1f180128f0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f1f6853903a in QEventLoop::exec (this=this@entry=0x7f1f24ed7bb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f1f6834a467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007f1f6834b93c in QThreadPrivate::start (arg=0x5563483c48f0) at thread/qthread_unix.cpp:342
#7  0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f1f27fff700 (LWP 29297)):
#0  0x00007f1f67a1ac98 in read () from /lib64/libc.so.6
#1  0x00007f1f60f0eca0 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f60ec9cb8 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1f60eca150 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f1f60eca2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f1f68599a3b in QEventDispatcherGlib::processEvents (this=0x7f1f1c008000, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f1f6853903a in QEventLoop::exec (this=this@entry=0x7f1f27ffebb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f1f6834a467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007f1f6834b93c in QThreadPrivate::start (arg=0x556347fd0ce0) at thread/qthread_unix.cpp:342
#9  0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f1f3531d700 (LWP 21565)):
#0  0x00007f1f67a1ac98 in read () from /lib64/libc.so.6
#1  0x00007f1f60f0eca0 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f60ec9cb8 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1f60eca150 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f1f60eca2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f1f68599a3b in QEventDispatcherGlib::processEvents (this=0x7f1f20000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f1f6853903a in QEventLoop::exec (this=this@entry=0x7f1f3531cbb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f1f6834a467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007f1f6834b93c in QThreadPrivate::start (arg=0x55634835a7d0) at thread/qthread_unix.cpp:342
#9  0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f1f3652e700 (LWP 21439)):
#0  0x00007f1f67a1f19b in poll () from /lib64/libc.so.6
#1  0x00007f1f60eca1a9 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f60eca2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1f68599a3b in QEventDispatcherGlib::processEvents (this=0x7f1f2c000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f1f6853903a in QEventLoop::exec (this=this@entry=0x7f1f3652dbb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f1f6834a467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007f1f6834b93c in QThreadPrivate::start (arg=0x556348316950) at thread/qthread_unix.cpp:342
#7  0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f1f36d2f700 (LWP 21431)):
#0  0x00007f1f67a1ac98 in read () from /lib64/libc.so.6
#1  0x00007f1f60f0eca0 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f60ec9cb8 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1f60eca150 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f1f60eca2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f1f68599a3b in QEventDispatcherGlib::processEvents (this=0x7f1f28000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f1f6853903a in QEventLoop::exec (this=this@entry=0x7f1f36d2eb80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f1f6834a467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007f1f6a164115 in ?? () from /usr/lib64/libQt5DBus.so.5
#9  0x00007f1f6834b93c in QThreadPrivate::start (arg=0x7f1f6a3dbda0) at thread/qthread_unix.cpp:342
#10 0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f1f3d1c4700 (LWP 21429)):
#0  0x00007f1f644448ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f3dec99ab in ?? () from /usr/lib64/dri/i965_dri.so
#2  0x00007f1f3dec96b7 in ?? () from /usr/lib64/dri/i965_dri.so
#3  0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f1f42b23700 (LWP 21421)):
#0  0x00007f1f67a1f19b in poll () from /lib64/libc.so.6
#1  0x00007f1f63a83307 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f1f63a84f3a in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f1f45085fe0 in QXcbEventQueue::run (this=0x556347fb4160) at qxcbeventqueue.cpp:228
#4  0x00007f1f6834b93c in QThreadPrivate::start (arg=0x556347fb4160) at thread/qthread_unix.cpp:342
#5  0x00007f1f6443e569 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f1f67a299ef in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1f6da29a00 (LWP 21400)):
[KCrash Handler]
#6  ImapAccount::authenticationMode (this=0x0) at /usr/src/debug/kdepim-runtime-19.12.0-lp151.206.2.x86_64/resources/imap/imapaccount.cpp:85
#7  0x0000556347a988b6 in SessionPool::requestPassword (this=0x556348326920) at /usr/src/debug/kdepim-runtime-19.12.0-lp151.206.2.x86_64/resources/imap/sessionpool.cpp:88
#8  0x0000556347a9d0a5 in SessionPool::processPendingRequests (this=0x556348326920) at /usr/src/debug/kdepim-runtime-19.12.0-lp151.206.2.x86_64/resources/imap/sessionpool.cpp:302
#9  0x00007f1f6856d88b in QObject::event (this=0x556348326920, e=0x5563483154a0) at kernel/qobject.cpp:1339
#10 0x00007f1f697efbac in QApplicationPrivate::notify_helper (this=this@entry=0x556347f8a5d0, receiver=receiver@entry=0x556348326920, e=e@entry=0x5563483154a0) at kernel/qapplication.cpp:3693
#11 0x00007f1f697f7180 in QApplication::notify (this=0x7ffe4e0f0c60, receiver=0x556348326920, e=0x5563483154a0) at kernel/qapplication.cpp:3439
#12 0x00007f1f6853a7b8 in QCoreApplication::notifyInternal2 (receiver=0x556348326920, event=0x5563483154a0) at kernel/qcoreapplication.cpp:1092
#13 0x00007f1f6853a98e in QCoreApplication::sendEvent (receiver=receiver@entry=0x556348326920, event=event@entry=0x5563483154a0) at kernel/qcoreapplication.cpp:1487
#14 0x00007f1f6853d431 in QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x556347f7fe60) at kernel/qcoreapplication.cpp:1832
#15 0x00007f1f6853d9c8 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1691
#16 0x00007f1f6859a373 in postEventSourceDispatch (s=0x556347ffa520) at kernel/qeventdispatcher_glib.cpp:277
#17 0x00007f1f60ec9e87 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f1f60eca230 in ?? () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f1f60eca2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f1f68599a1c in QEventDispatcherGlib::processEvents (this=0x556347ffb400, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#21 0x00007f1f6853903a in QEventLoop::exec (this=this@entry=0x7ffe4e0f0bb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#22 0x00007f1f685427b0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#23 0x00007f1f68edf0dc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1845
#24 0x00007f1f697efb05 in QApplication::exec () at kernel/qapplication.cpp:2833
#25 0x00007f1f6c1c49bd in Akonadi::ResourceBase::init (r=...) at /usr/src/debug/akonadi-server-19.12.0-lp151.213.2.x86_64/src/agentbase/resourcebase.cpp:611
#26 0x0000556347a4a09f in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/KF5/AkonadiAgentBase/resourcebase.h:199
#27 0x00007f1f67951f8a in __libc_start_main () from /lib64/libc.so.6
#28 0x0000556347a49f2a in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 21400) detached]

Possible duplicates by query: bug 415339, bug 409419, bug 361101, bug 357227, bug 353442.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2020-01-17 10:00:41 UTC

*** This bug has been marked as a duplicate of bug 415339 ***
Comment 2 Philippe ROUBACH 2020-01-17 10:12:05 UTC
another time exactly same problem