Bug 357227 - Failure to move large numbers of emails to trash
Summary: Failure to move large numbers of emails to trash
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-12-27 18:31 UTC by newarkdevil5
Modified: 2018-12-01 03:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description newarkdevil5 2015-12-27 18:31:49 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.0-38-generic x86_64
Distribution: Linux Mint 17.2 Rafaela

-- Information about the crash:
- What I was doing when the application crashed: Kmail crashed while deleting hundreds of emails on IMAP account.

The crash can be reproduced sometimes.

-- Backtrace:
Application: newarkdevil5@yahoo.com of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f36628c27c0 (LWP 10260))]

Thread 3 (Thread 0x7f364e973700 (LWP 10263)):
#0  0x00007f365d21e61d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f365d21e979 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f365d1dc699 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f365d1dcf03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f365d1dd0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3661ef57be in QEventDispatcherGlib::processEvents (this=0x7f36480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f3661ec70af in QEventLoop::processEvents (this=this@entry=0x7f364e972de0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3661ec73a5 in QEventLoop::exec (this=this@entry=0x7f364e972de0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3661dc3c5f in QThread::exec (this=this@entry=0x13c0e90) at thread/qthread.cpp:537
#9  0x00007f3661ea8823 in QInotifyFileSystemWatcherEngine::run (this=0x13c0e90) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f3661dc632f in QThreadPrivate::start (arg=0x13c0e90) at thread/qthread_unix.cpp:349
#11 0x00007f365d8c1182 in start_thread (arg=0x7f364e973700) at pthread_create.c:312
#12 0x00007f365e26447d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f3647fff700 (LWP 10603)):
#0  0x00007f365d21e61d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f365d21e9a9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f365d1dcfd9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f365d1dd0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3661ef57be in QEventDispatcherGlib::processEvents (this=0x7f3640201a60, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f3661ec70af in QEventLoop::processEvents (this=this@entry=0x7f3647ffee20, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f3661ec73a5 in QEventLoop::exec (this=this@entry=0x7f3647ffee20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f3661dc3c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#8  0x00007f3661dc632f in QThreadPrivate::start (arg=0x13fec50) at thread/qthread_unix.cpp:349
#9  0x00007f365d8c1182 in start_thread (arg=0x7f3647fff700) at pthread_create.c:312
#10 0x00007f365e26447d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f36628c27c0 (LWP 10260)):
[KCrash Handler]
#6  operator char const* (this=<optimized out>) at /usr/include/qt4/QtCore/qbytearray.h:425
#7  KIMAP::Session::selectedMailBox (this=this@entry=0x13d9d20) at ../../kimap/session.cpp:449
#8  0x000000000044478d in RetrieveItemTask::doStart (this=0x14ec2c0, session=0x13d9d20) at ../../../resources/imap/retrieveitemtask.cpp:55
#9  0x000000000043ab13 in ResourceTask::onSessionRequested (this=0x14ec2c0, requestId=<optimized out>, session=0x13d9d20, errorCode=0) at ../../../resources/imap/resourcetask.cpp:119
#10 0x00000000004648b5 in ResourceTask::qt_static_metacall (_o=0x7ffd5858bfb0, _c=20815136, _id=-1, _a=0x0) at moc_resourcetask.cpp:69
#11 0x00007f3661edc87a in QMetaObject::activate (sender=sender@entry=0x1207fe0, m=m@entry=0x482160 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffd5858c1a0) at kernel/qobject.cpp:3539
#12 0x0000000000464962 in SessionPool::sessionRequestDone (this=this@entry=0x1207fe0, _t1=_t1@entry=90, _t2=_t2@entry=0x13d9d20, _t3=_t3@entry=0, _t4=...) at moc_sessionpool.cpp:153
#13 0x000000000045086a in SessionPool::processPendingRequests (this=0x1207fe0) at ../../../resources/imap/sessionpool.cpp:257
#14 0x0000000000464a2d in SessionPool::qt_static_metacall (_o=0x7ffd5858bfb0, _c=20815136, _id=-1, _a=0x0) at moc_sessionpool.cpp:92
#15 0x00007f3661ee0c1e in QObject::event (this=0x1207fe0, e=<optimized out>) at kernel/qobject.cpp:1194
#16 0x00007f3661261e2c in QApplicationPrivate::notify_helper (this=this@entry=0x109c220, receiver=receiver@entry=0x1207fe0, e=e@entry=0x126b3b0) at kernel/qapplication.cpp:4567
#17 0x00007f36612684a0 in QApplication::notify (this=this@entry=0x7ffd5858c930, receiver=receiver@entry=0x1207fe0, e=e@entry=0x126b3b0) at kernel/qapplication.cpp:4353
#18 0x00007f365f3a6cca in KApplication::notify (this=0x7ffd5858c930, receiver=0x1207fe0, event=0x126b3b0) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f3661ec84dd in QCoreApplication::notifyInternal (this=0x7ffd5858c930, receiver=receiver@entry=0x1207fe0, event=event@entry=0x126b3b0) at kernel/qcoreapplication.cpp:953
#20 0x00007f3661ecbb3d in sendEvent (event=0x126b3b0, receiver=0x1207fe0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1061220) at kernel/qcoreapplication.cpp:1577
#22 0x00007f3661ecbfe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#23 0x00007f3661ef5f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=0x1085ec0) at kernel/qeventdispatcher_glib.cpp:287
#25 0x00007f365d1dce04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f365d1dd048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f365d1dd0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f3661ef57a1 in QEventDispatcherGlib::processEvents (this=0x1062700, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#29 0x00007f3661303be6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f3661ec70af in QEventLoop::processEvents (this=this@entry=0x7ffd5858c8a0, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f3661ec73a5 in QEventLoop::exec (this=this@entry=0x7ffd5858c8a0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007f3661eccb79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#33 0x00007f366126037c in QApplication::exec () at kernel/qapplication.cpp:3828
#34 0x00007f36623a9783 in Akonadi::ResourceBase::init (r=r@entry=0x11f4400) at ../../akonadi/resourcebase.cpp:579
#35 0x0000000000418993 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:193
#36 0x00007f365e18bec5 in __libc_start_main (main=0x4182e0 <main(int, char**)>, argc=3, argv=0x7ffd5858ca48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd5858ca38) at libc-start.c:287
#37 0x0000000000418854 in _start ()

Reported using DrKonqi
Comment 1 Andrew Crouthamel 2018-11-01 13:43:49 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Bug Janitor Service 2018-11-16 11:37:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-12-01 03:51:10 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!