Bug 395718 - knsrc files should be installed in /usr/share rather than in /etc
Summary: knsrc files should be installed in /usr/share rather than in /etc
Status: RESOLVED FIXED
Alias: None
Product: frameworks-knewstuff
Classification: Unclassified
Component: general (show other bugs)
Version: 5.47.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords: usability
: 395715 395717 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-22 00:43 UTC by Alex Ander
Modified: 2021-06-10 21:25 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.57


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Ander 2018-06-22 00:43:49 UTC
Under "Application Addons" you will find Plasmate, which populates all its items from https://download.kde.org/khotnewstuff/plasmoids/plasmoids.xml, as I understand. But, if you see this file, all items have relese date in 2013. Does it mean, the list wasn't updated many years? 

What is this category for, if we have extra "Plasma Addons"?
Comment 1 Aleix Pol 2018-06-22 15:14:39 UTC
This is a file that is stale on your file system. A quick action you can take to solve the problem is to just remove it from /etc/xdg.

The problem is that when a project decides to stop existing (or stop doing kns for that matter) they'll stop installing the file but most distros have the policy of not removing files in /etc/*.
Comment 2 Aleix Pol 2018-06-22 15:16:21 UTC
*** Bug 395717 has been marked as a duplicate of this bug. ***
Comment 3 Alex Ander 2018-06-22 22:03:37 UTC
*** Bug 395715 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2019-02-15 18:10:29 UTC
Looks like this may be simply a matter of using QStandardPaths::GenericDataLocation instead of QStandardPaths::ConfigLocation in a few places.
Comment 5 Nate Graham 2019-03-17 09:29:31 UTC
Support for this got in with https://phabricator.kde.org/D19338.

Discover patch: https://phabricator.kde.org/D19340

Other apps and providers will be patched too once they can rely on Frameworks 5.57.