Bug 390922 - "parley.knsrc: error with preparation of delivery" message on launch
Summary: "parley.knsrc: error with preparation of delivery" message on launch
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.12.4
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 19:58 UTC by Øystein Steffensen-Alværvik
Modified: 2018-06-27 21:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Message (in Norwegian) (356.58 KB, image/png)
2018-02-22 19:58 UTC, Øystein Steffensen-Alværvik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Øystein Steffensen-Alværvik 2018-02-22 19:58:43 UTC
Created attachment 110911 [details]
Message (in Norwegian)

(Message translated from Norwegian).
This message appears every time I launch Discover. Started to appear after update to Plasma 5.12.2.

Neon User 5.12.2
Framework 5.43
Qt 5.9.3
Comment 1 Nate Graham 2018-02-23 16:33:03 UTC
Users don't know what to do with these kinds of un-actionable messages. Shall we mark this as a duplicate of the bug that tracks suppressing these messages? Bug 390959
Comment 2 Øystein Steffensen-Alværvik 2018-02-25 18:21:34 UTC
(In reply to Nate Graham from comment #1)
> Users don't know what to do with these kinds of un-actionable messages.
> Shall we mark this as a duplicate of the bug that tracks suppressing these
> messages? Bug 390959

Are you asking me? If so, I agree.
Comment 3 Nate Graham 2018-02-26 00:22:04 UTC
Thanks! Though I was asking Aleix, the lead developer.
Comment 4 Aleix Pol 2018-02-26 13:36:45 UTC
Git commit 1d2b86a9202baf2f38715445c77adddc06956b5a by Aleix Pol.
Committed on 26/02/2018 at 13:35.
Pushed by apol into branch 'Plasma/5.12'.

Don't show error messages for files that shouldn't be there

Distributions won't fix it and annoys our users

M  +4    -1    libdiscover/backends/KNSBackend/KNSBackend.cpp

https://commits.kde.org/discover/1d2b86a9202baf2f38715445c77adddc06956b5a
Comment 5 Øystein Steffensen-Alværvik 2018-03-25 09:11:31 UTC
Still getting this message, upon launch of Discover, using Plasma 5.12.3. Still KDE Neon, with latest updates. Discover is also version 5.12.3 (which I can tell from the decreased width of the sidebar).

Can anyone else confirm?
Comment 6 Nate Graham 2018-03-25 21:25:50 UTC
Feel free to re-open if you're still seeing it.
Comment 7 Øystein Steffensen-Alværvik 2018-04-10 12:53:05 UTC
Aleix Pol, I see that you changed the status to Fixed once more. Is there a new fix I'm unaware of, or do you disagree with me reopening the bug? (Because I still see this error message).
Comment 8 Aleix Pol 2018-04-10 18:57:11 UTC
I thought Nate confirmed it as fixed and forgot to change the status given his message.

Have not investigated yet sorry.
Comment 9 Nate Graham 2018-04-10 19:07:50 UTC
I did close it as fixed because I wasn't seeing the messages anymore, but ystein re-opened it because he was still seeing them in 5.12.3, which had the commit that was supposed to have fixed it.
Comment 10 Øystein Steffensen-Alværvik 2018-06-27 20:21:12 UTC
Not seeing this error message in 5.13, but another one: 'calligra_stencils.knsrc: All categories missing'. In case it is unrelated to this bug I opened a new one: https://bugs.kde.org/show_bug.cgi?id=395934
Also marking this as Resolved Fixed – if that's the wrong tag please change.
Comment 11 Nate Graham 2018-06-27 21:24:26 UTC
None of these errors come from Discover; they're the result of old stale .knsrc files in /etc/xdg that your distro's packaging didn't clean up. We're tracking the KNS-side fix for that in Bug 395718.

Meanwhile, the only thing we can do on the Discover side is to put in some logic to silence these particular errors. I'm starting a new bug to track that: Bug 395937.