Bug 395717 - Discover shows in console many errors regarding KNS backend
Summary: Discover shows in console many errors regarding KNS backend
Status: RESOLVED DUPLICATE of bug 395718
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.13.1
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-22 00:22 UTC by Alex Ander
Modified: 2018-06-22 15:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Ander 2018-06-22 00:22:58 UTC
I don't know, if it important or not, but it looks like errors:

invalid kns backend! "/etc/xdg/ksysguard.knsrc" because: "Config group not found! Check your KNS3 installation."
invalid kns backend! "/etc/xdg/servicemenu.knsrc" because: "Config group not found! Check your KNS3 installation."
Discarding invalid backend "ksysguard.knsrc"
Discarding invalid backend "servicemenu.knsrc"
setting currentApplicationBackend PackageKitBackend(0x24be0b0)
org.kde.knewstuff.core: Could not find category "KAddressbook Theme"
invalid kns backend! "/etc/xdg/kaddressbook_themes.knsrc" because: "All categories are missing"
Discarding invalid backend "kaddressbook_themes.knsrc"
qrc:/qml/DiscoverDrawer.qml:155: TypeError: Cannot read property 'name' of null
qrc:/qml/DiscoverDrawer.qml:155: TypeError: Cannot read property 'name' of null
kns error "/etc/xdg/kaddressbook_themes.knsrc" "Invalid Kaddressbook_themes backend, contact your distributor."
org.kde.knewstuff.core: Could not find category "Calligra Flow Stencil"
invalid kns backend! "/etc/xdg/calligra_stencils.knsrc" because: "All categories are missing"
Discarding invalid backend "calligra_stencils.knsrc"
qrc:/qml/DiscoverDrawer.qml:155: TypeError: Cannot read property 'name' of null
qrc:/qml/DiscoverDrawer.qml:155: TypeError: Cannot read property 'name' of null
qrc:/qml/DiscoverDrawer.qml:155: TypeError: Cannot read property 'name' of null
qrc:/qml/DiscoverDrawer.qml:155: TypeError: Cannot read property 'name' of null
kns error "/etc/xdg/calligra_stencils.knsrc" "Invalid Calligra_stencils backend, contact your distributor."
org.kde.knewstuff.core: Could not find category "Xfce Icon Theme"
invalid kns backend! "/etc/xdg/cgcicon.knsrc" because: "All categories are missing"
Discarding invalid backend "cgcicon.knsrc"
kns error "/etc/xdg/cgcicon.knsrc" "Invalid Icon Themes backend, contact your distributor."
Comment 1 Aleix Pol 2018-06-22 15:16:21 UTC
Very related to that bug.

Feel free to report to the separate projects (ksysguard, servicemenu, kaddressbook, calligra) if you think the knsrc file is still maintained.

*** This bug has been marked as a duplicate of bug 395718 ***