Bug 393063 - Kwin-Crash, when starting libreoffice writer
Summary: Kwin-Crash, when starting libreoffice writer
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.9
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-04-12 19:55 UTC by Josef Overmann
Modified: 2018-04-13 06:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Overmann 2018-04-12 19:55:14 UTC
Application: kwin_x11 (5.8.9)

Qt Version: 5.6.1
Frameworks Version: 5.36.0
Operating System: Linux 4.13.0-36-generic x86_64
Distribution: Linux Mint 18.2 Sonya

-- Information about the crash:
- What I was doing when the application crashed:
Marking Test with Mouse and copying it for transfer to writer

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8570327940 (LWP 3302))]

Thread 6 (Thread 0x7f8565ab7700 (LWP 4064)):
#0  0x00007f8587e305d3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f8585c9ebcf in qt_safe_select (nfds=11, fdread=fdread@entry=0x7f8558000a58, fdwrite=fdwrite@entry=0x7f8558000ce8, fdexcept=fdexcept@entry=0x7f8558000f78, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f8585ca060e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f8558000f78, writefds=0x7f8558000ce8, readfds=0x7f8558000a58, nfds=<optimized out>, this=0x7f855803ebd0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f85580008c0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f8585ca0b22 in QEventDispatcherUNIX::processEvents (this=0x7f855803ebd0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f8585c4bffa in QEventLoop::exec (this=this@entry=0x7f8565ab6c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f8585a749e4 in QThread::exec (this=this@entry=0x1d0cf10) at thread/qthread.cpp:500
#7  0x00007f8580c446b5 in QQmlThreadPrivate::run (this=0x1d0cf10) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f8585a79808 in QThreadPrivate::start (arg=0x1d0cf10) at thread/qthread_unix.cpp:341
#9  0x00007f8581aea6ba in start_thread (arg=0x7f8565ab7700) at pthread_create.c:333
#10 0x00007f8587e3a41d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f854dedf700 (LWP 3412)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f8584e12574 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007f8584e125b9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007f8581aea6ba in start_thread (arg=0x7f854dedf700) at pthread_create.c:333
#4  0x00007f8587e3a41d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f854fb99700 (LWP 3404)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f856478948b in ?? () from /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so
#2  0x00007f8564789397 in ?? () from /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so
#3  0x00007f8581aea6ba in start_thread (arg=0x7f854fb99700) at pthread_create.c:333
#4  0x00007f8587e3a41d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f8566b48700 (LWP 3400)):
#0  0x00007f8587e305d3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f8585c9ebcf in qt_safe_select (nfds=13, fdread=fdread@entry=0x7f8554000a78, fdwrite=fdwrite@entry=0x7f8554000d08, fdexcept=fdexcept@entry=0x7f8554000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f8585ca060e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f8554000f98, writefds=0x7f8554000d08, readfds=0x7f8554000a78, nfds=<optimized out>, this=0x7f85540008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f85540008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f8585ca0b22 in QEventDispatcherUNIX::processEvents (this=0x7f85540008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f8585c4bffa in QEventLoop::exec (this=this@entry=0x7f8566b47c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f8585a749e4 in QThread::exec (this=this@entry=0x1a1e000) at thread/qthread.cpp:500
#7  0x00007f8580c446b5 in QQmlThreadPrivate::run (this=0x1a1e000) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f8585a79808 in QThreadPrivate::start (arg=0x1a1e000) at thread/qthread_unix.cpp:341
#9  0x00007f8581aea6ba in start_thread (arg=0x7f8566b48700) at pthread_create.c:333
#10 0x00007f8587e3a41d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f856d3ae700 (LWP 3336)):
#0  0x00007f8585c9ef72 in QEventDispatcherUNIXPrivate::initThreadWakeUp (this=this@entry=0x7f85600008e0) at kernel/qeventdispatcher_unix.cpp:269
#1  0x00007f8585ca05d6 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f85600008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:189
#2  0x00007f8585ca0b22 in QEventDispatcherUNIX::processEvents (this=0x7f85600008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#3  0x00007f8585c4bffa in QEventLoop::exec (this=this@entry=0x7f856d3adc50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007f8585a749e4 in QThread::exec (this=this@entry=0x7f85884c2d40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#5  0x00007f858844f515 in QDBusConnectionManager::run (this=0x7f85884c2d40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#6  0x00007f8585a79808 in QThreadPrivate::start (arg=0x7f85884c2d40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#7  0x00007f8581aea6ba in start_thread (arg=0x7f856d3ae700) at pthread_create.c:333
#8  0x00007f8587e3a41d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f8570327940 (LWP 3302)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f84bd113320) at ../../include/QtQml/5.6.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:372
#7  QQmlBinding::write (this=this@entry=0x1fd7ac0, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007f8580c3153a in QQmlBinding::update (this=0x1fd7ac0, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007f8580c3a84f in QQmlObjectCreator::finalize (this=0x21696f0, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#10 0x00007f8580bc720e in QQmlComponentPrivate::complete (enginePriv=0x1f63040, state=0x1ff6bf0) at qml/qqmlcomponent.cpp:919
#11 0x00007f8580bc72d7 in QQmlComponentPrivate::completeCreate (this=0x1ff6b50) at qml/qqmlcomponent.cpp:955
#12 0x00007f8580bc7140 in QQmlComponent::create (this=0x1ff6ac0, context=0x2101a70) at qml/qqmlcomponent.cpp:781
#13 0x00007f8566b67047 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#14 0x00007f8587a39831 in ?? () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#15 0x00007f8587919791 in KWin::Client::createDecoration(QRect const&) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#16 0x00007f858791a383 in KWin::Client::updateDecoration(bool, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#17 0x00007f8587979d27 in KWin::Client::manage(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#18 0x00007f85878fb574 in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#19 0x00007f858796702f in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#20 0x00007f8585c4b16f in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f8568001960, result=result@entry=0x7fff30edd3f8) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f856fb35ca5 in QXcbConnection::handleXcbEvent (this=this@entry=0x182c2a0, event=event@entry=0x7f8568001960) at qxcbconnection.cpp:1091
#22 0x00007f856fb36c06 in QXcbConnection::processXcbEvents (this=0x182c2a0) at qxcbconnection.cpp:1723
#23 0x00007f8585c7b719 in QObject::event (this=0x182c2a0, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f8586583afc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x182c2a0, e=0x7f85680053c0) at kernel/qapplication.cpp:3804
#25 0x00007f8586589036 in QApplication::notify (this=0x7fff30edda30, receiver=0x182c2a0, e=0x7f85680053c0) at kernel/qapplication.cpp:3561
#26 0x00007f8585c4e2a8 in QCoreApplication::notifyInternal2 (receiver=0x182c2a0, event=event@entry=0x7f85680053c0) at kernel/qcoreapplication.cpp:1015
#27 0x00007f8585c5016a in QCoreApplication::sendEvent (event=0x7f85680053c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1813db0) at kernel/qcoreapplication.cpp:1650
#29 0x00007f8585ca0a02 in QEventDispatcherUNIX::processEvents (this=0x1871fa0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f856fba58fd in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f8585c4bffa in QEventLoop::exec (this=this@entry=0x7fff30edd920, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f8585c546bc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f8588106226 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#34 0x00007f8587d53830 in __libc_start_main (main=0x400730, argc=3, argv=0x7fff30eddbb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff30eddba8) at ../csu/libc-start.c:291
#35 0x0000000000400769 in _start ()

Possible duplicates by query: bug 377576, bug 374681, bug 374129, bug 374100, bug 374002.

Reported using DrKonqi
Comment 1 Martin Flöser 2018-04-13 06:12:43 UTC
Bug fixed long ago. Please complain to your distribution because the patch is missing.

*** This bug has been marked as a duplicate of bug 361236 ***