Bug 374129 - KDE Crash exactly one time per boot up session
Summary: KDE Crash exactly one time per boot up session
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-12-24 22:05 UTC by Michael
Modified: 2017-01-05 06:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2016-12-24 22:05:22 UTC
Application: kwin_x11 (5.8.4)

Qt Version: 5.6.1
Frameworks Version: 5.28.0
Operating System: Linux 4.4.0-57-lowlatency x86_64
Distribution: Ubuntu 16.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
On this occasion I was opening LibreOffice for the first time after re-installing it. See below for repeatability with other applications.

- History of this error:
Prior to the gigantic update I installed 21 Dec 2016 this same error occured except I could not install the debug tools. I tried to create a manual report but never succeeded.
   1) I upgraded from Kubuntu 14.04 to Kubuntu 16.04 over a year ago. The process crashed during installation. I used a list of all the instllation systems and completed all the missing items successfully. There were some concerns that remain:
        a) On startup Cadence would not auto start: "Bridge type: ALSA->Loop->Jack" each time I started from boot up. It auto-started every second time. This is still true and repeatable.
        b) Window decorations would not show the title bar (hidden above the left corner of the screen). Must use  <ALT> <right mouse>  to move window. This is still true and repeatable.
        c) Most applications start up w/o kde plasma crash when first window is started, however, if that application opens a second window, the crash occurs. This is still true and repeatable.
        d) Once a crash has occured, further crashes generally do not occur. This is true whether I restart KDE (Plasma) or not.
        e) Icons on the desktop could not be <right click><start>. An error about the format of the icon link is sees. The same icon could be <double clicked> to open the application. No icon worked. This changed but not for the best. (see below - same issue)
        f) The partition reports itself as Ubuntu 14.04

2) I think I have two copies of KDE (Plasma) running at the same time and one interferes with the other until on crashes.

3) I currently have some new problems, however I was now able to install kde debug tools.:
        a) On startup Cadence would not auto start: "Bridge type: ALSA->Loop->Jack" each time I started from boot up. It auto-started every second time. This is still true and repeatable.
        b) Window decorations would not show the title bar (hidden above the left corner of the screen). Must use  <ALT> <right mouse>  to move window. This is still true and repeatable.
        c) Most applications start up w/o kde plasma crash when first window is started, however, if that application opens a second window, the crash occurs. This is still true and repeatable.
        d) Once a crash has occured, further crashes generally do not occur. This is true whether I restart KDE (Plasma) or not.
        e) Some Icons on the desktop can not open <right click><start>. 
                i) E.g., a desktop folder: An error about the file system being unwritable occurs. The same icon could be <double clicked> to open the application with the same error ("dolphin - KDialog... Configuration file '/home/dad/.config/dolphinrc" not writable. Please contact your system administrator') occurs. After acknowledging the error, the folder opens in dolphin (both cases). Now some icons work. This change is still not for the best. 
                ii) I had the same problem for LibreOffice and looked at the file directory in question. It was marked drwxr--r--  O set it to drwxrwxrwx but this still failed. I did a purge and deleted the directory. The re-install fixed it.
                iii) "-rw-r--r-- 1 root root  2055 Aug  3 17:16 dolphinrc" is what I see. Since dolphin is run by the O/S, Once started, dolphin can start other applications the read and write.
                iv) <right click> on a folder and select <open> does nothing.
                v) <right click> on a folder and select <open with> then select <utilities> and then <files> and the plasma desktop changes to large icons, reorganized. I did not select "use this every time" option. The file system application that opens is "files", not dolphin. "file does not complain  ("file - KDialog... Configuration file '/home/dad/.config/filetyperc" not writable. Please contact your system administrator') if I select dolphin, it complains and then works. konqurer and Gwenview have no problems. Kid3-qt works but is not a file system application. One wonders why writaility is needed. I used chmod 646 dolphinrc and the error went away.
        f) The partition reports itself as Ubuntu 14.04

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fede09f5940 (LWP 3783))]

Thread 6 (Thread 0x7fed2abd6700 (LWP 4614)):
#0  0x00007fede04ee9e3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fedde35ca1f in qt_safe_select (nfds=13, fdread=fdread@entry=0x7fed24000a58, fdwrite=fdwrite@entry=0x7fed24000ce8, fdexcept=fdexcept@entry=0x7fed24000f78, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007fedde35e45e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7fed24000f78, writefds=0x7fed24000ce8, readfds=0x7fed24000a58, nfds=<optimized out>, this=0x7fed2408f220) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7fed240008c0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007fedde35e972 in QEventDispatcherUNIX::processEvents (this=0x7fed2408f220, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007fedde309e4a in QEventLoop::exec (this=this@entry=0x7fed2abd5c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fedde1329e4 in QThread::exec (this=this@entry=0xe5fb90) at thread/qthread.cpp:500
#7  0x00007fedd93296b5 in QQmlThreadPrivate::run (this=0xe5fb90) at qml/ftw/qqmlthread.cpp:141
#8  0x00007fedde137808 in QThreadPrivate::start (arg=0xe5fb90) at thread/qthread_unix.cpp:341
#9  0x00007fedda1c66ba in start_thread (arg=0x7fed2abd6700) at pthread_create.c:333
#10 0x00007fede04f882d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7fedb2fc6700 (LWP 4010)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007feddd4d0574 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007feddd4d05b9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007fedda1c66ba in start_thread (arg=0x7fedb2fc6700) at pthread_create.c:333
#4  0x00007fede04f882d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fedc088e700 (LWP 3995)):
#0  0x00007ffdf9d86caf in clock_gettime ()
#1  0x00007fede0506c86 in __GI___clock_gettime (clock_id=1, tp=tp@entry=0x7fedc088da10) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fedde1e36c6 in qt_clock_gettime (ts=0x7fedc088da10, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#5  0x00007fedde35ed59 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fedb8001118) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007fedde35e15b in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7fedb80008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:171
#7  0x00007fedde35e972 in QEventDispatcherUNIX::processEvents (this=0x7fedb80008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#8  0x00007fedde309e4a in QEventLoop::exec (this=this@entry=0x7fedc088dc60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x00007fedde1329e4 in QThread::exec (this=this@entry=0xa9e160) at thread/qthread.cpp:500
#10 0x00007fedd93296b5 in QQmlThreadPrivate::run (this=0xa9e160) at qml/ftw/qqmlthread.cpp:141
#11 0x00007fedde137808 in QThreadPrivate::start (arg=0xa9e160) at thread/qthread_unix.cpp:341
#12 0x00007fedda1c66ba in start_thread (arg=0x7fedc088e700) at pthread_create.c:333
#13 0x00007fede04f882d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fedc3373700 (LWP 3871)):
#0  0x00007fede04ee9e3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fedde35ca1f in qt_safe_select (nfds=8, fdread=fdread@entry=0x7fedbc000a78, fdwrite=fdwrite@entry=0x7fedbc000d08, fdexcept=fdexcept@entry=0x7fedbc000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007fedde35e45e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7fedbc000f98, writefds=0x7fedbc000d08, readfds=0x7fedbc000a78, nfds=<optimized out>, this=0x7fedbc0008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7fedbc0008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007fedde35e972 in QEventDispatcherUNIX::processEvents (this=0x7fedbc0008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007fedde309e4a in QEventLoop::exec (this=this@entry=0x7fedc3372c50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fedde1329e4 in QThread::exec (this=this@entry=0x7fede0b51d40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#7  0x00007fede0ade515 in QDBusConnectionManager::run (this=0x7fede0b51d40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#8  0x00007fedde137808 in QThreadPrivate::start (arg=0x7fede0b51d40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#9  0x00007fedda1c66ba in start_thread (arg=0x7fedc3373700) at pthread_create.c:333
#10 0x00007fede04f882d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fedc8f6e700 (LWP 3834)):
#0  0x00007fede04ecb5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007feddf651c62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007feddf6538d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fedc9c1bd29 in QXcbEventReader::run (this=0x96ba30) at qxcbconnection.cpp:1325
#4  0x00007fedde137808 in QThreadPrivate::start (arg=0x96ba30) at thread/qthread_unix.cpp:341
#5  0x00007fedda1c66ba in start_thread (arg=0x7fedc8f6e700) at pthread_create.c:333
#6  0x00007fede04f882d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fede09f5940 (LWP 3783)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7fed29bd7320) at ../../include/QtQml/5.6.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:372
#7  QQmlBinding::write (this=this@entry=0x1a64280, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007fedd931653a in QQmlBinding::update (this=0x1a64280, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007fedd931f84f in QQmlObjectCreator::finalize (this=0x18d19b0, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#10 0x00007fedd92ac20e in QQmlComponentPrivate::complete (enginePriv=0xddd670, state=0xe0e2c0) at qml/qqmlcomponent.cpp:919
#11 0x00007fedd92ac2d7 in QQmlComponentPrivate::completeCreate (this=0xe0e220) at qml/qqmlcomponent.cpp:955
#12 0x00007fedd92ac140 in QQmlComponent::create (this=0xb654b0, context=0x18e43b0) at qml/qqmlcomponent.cpp:781
#13 0x00007fedc0acb047 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#14 0x00007fede00f8761 in ?? () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#15 0x00007feddffd8621 in KWin::Client::createDecoration(QRect const&) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#16 0x00007feddffd9213 in KWin::Client::updateDecoration(bool, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#17 0x00007fede0038b87 in KWin::Client::manage(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#18 0x00007feddffba3e4 in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#19 0x00007fede0025e8f in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#20 0x00007fedde308fbf in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7fedc40061e0, result=result@entry=0x7ffdf9d67998) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007fedc9c1fca5 in QXcbConnection::handleXcbEvent (this=this@entry=0x960080, event=event@entry=0x7fedc40061e0) at qxcbconnection.cpp:1091
#22 0x00007fedc9c20c06 in QXcbConnection::processXcbEvents (this=0x960080) at qxcbconnection.cpp:1723
#23 0x00007fedde339569 in QObject::event (this=0x960080, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007feddec41afc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x960080, e=0x7fedc40066f0) at kernel/qapplication.cpp:3804
#25 0x00007feddec47036 in QApplication::notify (this=0x7ffdf9d67fd0, receiver=0x960080, e=0x7fedc40066f0) at kernel/qapplication.cpp:3561
#26 0x00007fedde30c0f8 in QCoreApplication::notifyInternal2 (receiver=0x960080, event=event@entry=0x7fedc40066f0) at kernel/qcoreapplication.cpp:1015
#27 0x00007fedde30dfba in QCoreApplication::sendEvent (event=0x7fedc40066f0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x943630) at kernel/qcoreapplication.cpp:1650
#29 0x00007fedde35e852 in QEventDispatcherUNIX::processEvents (this=0x988df0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007fedc9c8f8fd in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007fedde309e4a in QEventLoop::exec (this=this@entry=0x7ffdf9d67ec0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007fedde31250c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007fede07c4226 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#34 0x00007fede0412830 in __libc_start_main (main=0x400730, argc=1, argv=0x7ffdf9d68158, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdf9d68148) at ../csu/libc-start.c:291
#35 0x0000000000400769 in _start ()

Possible duplicates by query: bug 374100, bug 374002, bug 372015, bug 370614, bug 368993.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-12-25 17:08:46 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 2 Michael 2017-01-04 20:53:31 UTC
Marc,
I installed the breeze decorations. All I get was a lot more problems added into the current situation:
1) All the icons on the desktop disappeared. (For some reason, the change in decorations renewed the entire breeze desktop and deleted the icons and other items shown on the screen in directory "/home/dad/Desktop". BUT, all the elements are alive and well in "/home/dad/Desktop" if I use dolphin or any other file program I can access and use them.
2) All reported previous problems continued.
3) The desktop crashes appear not to occur any more.
4) The kde debug functions went away, but without a crash I cannot test it. I tried a test and got this:
I tried to re-install the debug for kde I get:
"root@dad314159:/home/dad/Desktop# apt-get install --reinstall kded5-dbg*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package kded5-dbg_5.18.0-0ubuntu1_amd64.deb
E: Couldn't find any package by glob 'kded5-dbg_5.18.0-0ubuntu1_amd64.deb'
E: Couldn't find any package by regex 'kded5-dbg_5.18.0-0ubuntu1_amd64.deb'"
To fix this, I tried to download the offending packages:
When I download kded5-dbg_5.18.0-0ubuntu1_amd64.deb and try to install it I get refusal because a later version is already installed.
============NEW MAJOR PROBLEM================
5) My WiFi disappeared and that included the ifconfig recognition of the WiFi hardware. I am dual boot, so I checked with Win10 and it worked just fine (dual boot). I re-installed the network software "apt-get install --reinstall -f --allow-downgrades net*" and this failed at the debug section. I then tried "apt-get install --reinstall -f --allow-downgrades netw*" and succeeded. (No downgrades needed) Still, no Wlan1. I installed the Broadcomm device software, and it failed, but when I un-installed it, the O/S (via ifconfig) saw the Wlan1 device again, and continues to do so each new boot. I now can get the WiFi by performing the following:
     a) Open an xterminal
     b) shift to "su" via "sudo su"
     c) execute: sudo nm-applet &    (Note: the sudo is needed  ???)
(an icon of two screens appears on the launch bar and when moused says "NETWORKING". It does nothing.)
     d) wait while numerous complaints about the modem are printed.
     e) execute: killall nm-applet && nm-applet &
The two screen icon disappears and a two particle orbiting icon takes it's place. I will then get password login from keyring (which I created the first time when asked since this latest version of a disaster started). Once entered, the WiFi starts using the WiFi password I provided when asked since this latest version of a disaster started. The wifi "bars" icon will now replace the previous icon.

I would really like to download a kubuntu iso disk that will re-install everything on this broken partition without destroying my data links and desktop information. It would contain all agreeing versions of operational software, correct ppa information, etc. It would leave applications like pianoteq, virtualbox, wine, eclipse, etc., intact. This would be an alignment disk that can ask the user about each application it will need to re-install (to deal with dependencies), etc. Is there such a thing???
Comment 3 Martin Flöser 2017-01-05 06:44:04 UTC
Setting back to duplicate. The initial backtrace in this bug report is the well known issue. Please do not put multiple different issues into one bug report. This makes it impossible to investigate and fix the issue. A developer looking at the bug cannot know what is the actual issue this bug report is about.

If you find new issues in other areas: create a new bug report. One per issue.

*** This bug has been marked as a duplicate of bug 361236 ***