Bug 374681 - KWin crashes when closing app
Summary: KWin crashes when closing app
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.3
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-01-07 10:47 UTC by Al
Modified: 2017-01-10 16:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-21599-0.html (69 bytes, text/html)
2017-01-07 15:03 UTC, Martin Flöser
Details
New crash information added by DrKonqi (10.68 KB, text/plain)
2017-01-10 15:45 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Al 2017-01-07 10:47:00 UTC
Application: kwin_x11 (5.8.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.4.36-8-default x86_64
Distribution: "openSUSE Leap 42.2"

-- Information about the crash:
- What I was doing when the application crashed:

KWin has crashed when closing KWrite. I has also crashed at login time in another session and opening Dolphin.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f284b665940 (LWP 1653))]

Thread 6 (Thread 0x7f2828aff700 (LWP 2137)):
#0  0x00007f284849e1f9 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f281407d4b0, flags=..., flags@entry=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:185
#1  0x00007f284849e527 in QEventDispatcherUNIX::processEvents (this=0x7f28140683d0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#2  0x00007f284844dfdb in QEventLoop::exec (this=this@entry=0x7f2828afec70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#3  0x00007f2848288f1a in QThread::exec (this=this@entry=0x315b840) at thread/qthread.cpp:500
#4  0x00007f2842e759b8 in QQmlThreadPrivate::run (this=0x315b840) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#5  0x00007f284828d9e9 in QThreadPrivate::start (arg=0x315b840) at thread/qthread_unix.cpp:341
#6  0x00007f284b092734 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f284add0d3d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f2819568700 (LWP 1750)):
#0  0x00007f284b0970af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f284741e93b in ?? () from /usr/lib64/libQt5Script.so.5
#2  0x00007f284741e969 in ?? () from /usr/lib64/libQt5Script.so.5
#3  0x00007f284b092734 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f284add0d3d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f2829b90700 (LWP 1698)):
#0  0x00007fff27deaadc in clock_gettime ()
#1  0x00007f284addd806 in clock_gettime () from /lib64/libc.so.6
#2  0x00007f2848338826 in qt_clock_gettime (ts=0x7f2829b8fb30, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#5  0x00007f284849e989 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f2820001118) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f284849ef05 in QTimerInfoList::timerWait (this=this@entry=0x7f2820001118, tm=...) at kernel/qtimerinfo_unix.cpp:381
#7  0x00007f284849e58a in QEventDispatcherUNIX::processEvents (this=0x7f28200008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#8  0x00007f284844dfdb in QEventLoop::exec (this=this@entry=0x7f2829b8fc70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x00007f2848288f1a in QThread::exec (this=this@entry=0x24308f0) at thread/qthread.cpp:500
#10 0x00007f2842e759b8 in QQmlThreadPrivate::run (this=0x24308f0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#11 0x00007f284828d9e9 in QThreadPrivate::start (arg=0x24308f0) at thread/qthread_unix.cpp:341
#12 0x00007f284b092734 in start_thread () from /lib64/libpthread.so.0
#13 0x00007f284add0d3d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f282bdf5700 (LWP 1669)):
#0  0x00007f284adc9b03 in select () from /lib64/libc.so.6
#1  0x00007f284849c849 in qt_safe_select (nfds=8, fdread=0x7f2824000a78, fdwrite=0x7f2824000d08, fdexcept=0x7f2824000f98, orig_timeout=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f284849e0c3 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f28240008e0, flags=..., flags@entry=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:196
#3  0x00007f284849e527 in QEventDispatcherUNIX::processEvents (this=0x7f28240008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#4  0x00007f284844dfdb in QEventLoop::exec (this=this@entry=0x7f282bdf4c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f2848288f1a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:500
#6  0x00007f28420561d5 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007f284828d9e9 in QThreadPrivate::start (arg=0x7f28422bece0) at thread/qthread_unix.cpp:341
#8  0x00007f284b092734 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f284add0d3d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f2831da0700 (LWP 1662)):
#0  0x00007f284adc849d in poll () from /lib64/libc.so.6
#1  0x00007f2849f4f3e2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f2849f50fcf in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f2832a50839 in QXcbEventReader::run (this=0x2336e90) at qxcbconnection.cpp:1325
#4  0x00007f284828d9e9 in QThreadPrivate::start (arg=0x2336e90) at thread/qthread_unix.cpp:341
#5  0x00007f284b092734 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f284add0d3d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f284b665940 (LWP 1653)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f2787741320) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/jsruntime/qv4value_p.h:348
#7  QQmlBinding::write (this=this@entry=0x39bd7c0, core=..., result=..., isUndefined=<optimized out>, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:257
#8  0x00007f2842e6324a in QQmlBinding::update (this=0x39bd7c0, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:191
#9  0x00007f2842e6c2f6 in QQmlObjectCreator::finalize (this=0x361c4f0, interrupt=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlobjectcreator.cpp:1193
#10 0x00007f2842dfa93b in QQmlComponentPrivate::complete (enginePriv=0x345fa80, state=state@entry=0x34491b0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:919
#11 0x00007f2842dfa9f7 in QQmlComponentPrivate::completeCreate (this=0x3449110) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:955
#12 0x00007f2842dfa880 in QQmlComponent::create (this=0x3448a90, context=0x3ad31c0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:781
#13 0x00007f2829baf7cf in ?? () from /usr/lib64/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#14 0x00007f284a9f4047 in ?? () from /usr/lib64/libkwin.so.5
#15 0x00007f284a8d8891 in KWin::Client::createDecoration(QRect const&) () from /usr/lib64/libkwin.so.5
#16 0x00007f284a8d95ab in KWin::Client::updateDecoration(bool, bool) () from /usr/lib64/libkwin.so.5
#17 0x00007f284a93aed6 in KWin::Client::manage(unsigned int, bool) () from /usr/lib64/libkwin.so.5
#18 0x00007f284a8bc994 in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib64/libkwin.so.5
#19 0x00007f284a9290e0 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib64/libkwin.so.5
#20 0x00007f284844d270 in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f282c001500, result=result@entry=0x7fff27cf6f68) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f2832a4ebe4 in QXcbConnection::handleXcbEvent (this=this@entry=0x232b100, event=event@entry=0x7f282c001500) at qxcbconnection.cpp:1091
#22 0x00007f2832a50c3b in QXcbConnection::processXcbEvents (this=0x232b100) at qxcbconnection.cpp:1723
#23 0x00007f284847b166 in QObject::event (this=0x232b100, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f2849156e3c in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x232b100, e=0x7f282c005010) at kernel/qapplication.cpp:3804
#25 0x00007f284915b49a in QApplication::notify (this=0x7fff27cf7610, receiver=0x232b100, e=0x7f282c005010) at kernel/qapplication.cpp:3561
#26 0x00007f284844ffc5 in QCoreApplication::notifyInternal2 (receiver=0x232b100, event=event@entry=0x7f282c005010) at kernel/qcoreapplication.cpp:1015
#27 0x00007f2848451daa in QCoreApplication::sendEvent (event=0x7f282c005010, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x230e670) at kernel/qcoreapplication.cpp:1650
#29 0x00007f284849e4b4 in QEventDispatcherUNIX::processEvents (this=0x235e7d0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f2832ab294d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f284844dfdb in QEventLoop::exec (this=this@entry=0x7fff27cf7510, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f2848455ec6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f284b2b09cc in kdemain () from /usr/lib64/libkdeinit5_kwin_x11.so
#34 0x00007f284ad076e5 in __libc_start_main () from /lib64/libc.so.6
#35 0x0000000000400809 in _start ()

Possible duplicates by query: bug 374129, bug 374100, bug 374002, bug 372015, bug 370614.

Reported using DrKonqi
Comment 1 Martin Flöser 2017-01-07 15:03:07 UTC
As a workaround use the breeze decoration.

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 2 Martin Flöser 2017-01-07 15:03:16 UTC
Created attachment 103262 [details]
attachment-21599-0.html
Comment 3 Michael 2017-01-10 15:45:10 UTC
Created attachment 103330 [details]
New crash information added by DrKonqi

kwin_x11 (5.8.5) using Qt 5.6.1

- What I was doing when the application crashed:
Using Thunderbird, first application I opened today. Changed from e-mail sub-mailbox Trash (under local folders) to Inbox, then attempted to open up tools drop down menu. Crash occurred exactly at this point. All windows on screen dissappeared and then re-appeared. The crash symbol (square sad face on launch bar) started this bug report. The red (ladybug) symbol did not appear as formerly had been the case for crash reports. I installed the prompted for debug s/w succwssfully this time (always failed previously). I had successfully sent and received e-mails before this incident.

-- Backtrace (Reduced):
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f992b801320) at ../../include/QtQml/5.6.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:372
#7  QQmlBinding::write (this=this@entry=0x1ca6570, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007f99dee8953a in QQmlBinding::update (this=0x1ca6570, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007f99dee9284f in QQmlObjectCreator::finalize (this=0x204ef70, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#10 0x00007f99dee1f20e in QQmlComponentPrivate::complete (enginePriv=0xf975f0, state=0x1549300) at qml/qqmlcomponent.cpp:919
Comment 4 Martin Flöser 2017-01-10 16:06:42 UTC
Set back to duplicate. There is no need to report the crash any further. Just use breeze till the fix gets into your distribution.

*** This bug has been marked as a duplicate of bug 361236 ***