Bug 374100 - Kwin random crashes
Summary: Kwin random crashes
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-12-23 20:47 UTC by Thullyo
Modified: 2016-12-24 08:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thullyo 2016-12-23 20:47:09 UTC
Application: kwin_x11 (5.8.4)

Qt Version: 5.6.1
Frameworks Version: 5.28.0
Operating System: Linux 4.4.0-57-generic x86_64
Distribution: Ubuntu 16.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I just oppened Firefox, but sometimes it also happens with some random other Kubuntu applications and at system inicialization.

- Unusual behavior I noticed:
When launching Firefox and sometimes with some random other Kubuntu applications, their windows closes for a brief moment but then get back up. But when it happens at system start, all the windows lose their borders, and keep stacking up, positioned at the left top corner of the screen, and no crash report of kwin-x11 appears before a few minutes.

I would like to also add that the debugging package kwin-dbg, right now, is worthless for this report, as its current version only applies to an older version of kwin/kwin-x11.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f32bc6b7940 (LWP 1698))]

Thread 7 (Thread 0x7f3296ffe700 (LWP 2206)):
#0  0x00007f32bc1a99e3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f32ba017a1f in qt_safe_select (nfds=14, fdread=fdread@entry=0x7f3284000a78, fdwrite=fdwrite@entry=0x7f3284000d08, fdexcept=fdexcept@entry=0x7f3284000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f32ba01945e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3284000f98, writefds=0x7f3284000d08, readfds=0x7f3284000a78, nfds=<optimized out>, this=0x7f32840008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f32840008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f32ba019972 in QEventDispatcherUNIX::processEvents (this=0x7f32840008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f32b9fc4e4a in QEventLoop::exec (this=this@entry=0x7f3296ffdc60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f32b9ded9e4 in QThread::exec (this=this@entry=0x2da3900) at thread/qthread.cpp:500
#7  0x00007f32b4fe46b5 in QQmlThreadPrivate::run (this=0x2da3900) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f32b9df2808 in QThreadPrivate::start (arg=0x2da3900) at thread/qthread_unix.cpp:341
#9  0x00007f32b5e816ba in start_thread (arg=0x7f3296ffe700) at pthread_create.c:333
#10 0x00007f32bc1b382d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f328a7c6700 (LWP 2058)):
#0  0x00007f32bc1a99e3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f32ba017a1f in qt_safe_select (nfds=11, fdread=fdread@entry=0x7f3200000a58, fdwrite=fdwrite@entry=0x7f3200000ce8, fdexcept=fdexcept@entry=0x7f3200000f78, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f32ba01945e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3200000f78, writefds=0x7f3200000ce8, readfds=0x7f3200000a58, nfds=<optimized out>, this=0x7f3200086450) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f32000008c0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f32ba019972 in QEventDispatcherUNIX::processEvents (this=0x7f3200086450, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f32b9fc4e4a in QEventLoop::exec (this=this@entry=0x7f328a7c5c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f32b9ded9e4 in QThread::exec (this=this@entry=0x3f36540) at thread/qthread.cpp:500
#7  0x00007f32b4fe46b5 in QQmlThreadPrivate::run (this=0x3f36540) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f32b9df2808 in QThreadPrivate::start (arg=0x3f36540) at thread/qthread_unix.cpp:341
#9  0x00007f32b5e816ba in start_thread (arg=0x7f328a7c6700) at pthread_create.c:333
#10 0x00007f32bc1b382d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f32967fd700 (LWP 1772)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f32b918b574 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007f32b918b5b9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007f32b5e816ba in start_thread (arg=0x7f32967fd700) at pthread_create.c:333
#4  0x00007f32bc1b382d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f3297fff700 (LWP 1763)):
#0  0x00007f32ba06e289 in QAbstractEventDispatcher::aboutToBlock (this=this@entry=0x7f328c0008c0) at .moc/moc_qabstracteventdispatcher.cpp:137
#1  0x00007f32ba019908 in QEventDispatcherUNIX::processEvents (this=0x7f328c0008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:587
#2  0x00007f32b9fc4e4a in QEventLoop::exec (this=this@entry=0x7f3297ffec60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#3  0x00007f32b9ded9e4 in QThread::exec (this=this@entry=0x272c8f0) at thread/qthread.cpp:500
#4  0x00007f32b4fe46b5 in QQmlThreadPrivate::run (this=0x272c8f0) at qml/ftw/qqmlthread.cpp:141
#5  0x00007f32b9df2808 in QThreadPrivate::start (arg=0x272c8f0) at thread/qthread_unix.cpp:341
#6  0x00007f32b5e816ba in start_thread (arg=0x7f3297fff700) at pthread_create.c:333
#7  0x00007f32bc1b382d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f329ecc3700 (LWP 1755)):
#0  0x00007f32bc1a99e3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f32ba017a1f in qt_safe_select (nfds=8, fdread=fdread@entry=0x7f3298000a78, fdwrite=fdwrite@entry=0x7f3298000d08, fdexcept=fdexcept@entry=0x7f3298000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f32ba01945e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3298000f98, writefds=0x7f3298000d08, readfds=0x7f3298000a78, nfds=<optimized out>, this=0x7f32980008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f32980008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f32ba019972 in QEventDispatcherUNIX::processEvents (this=0x7f32980008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f32b9fc4e4a in QEventLoop::exec (this=this@entry=0x7f329ecc2c50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f32b9ded9e4 in QThread::exec (this=this@entry=0x7f32bc84ed40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#7  0x00007f32bc7db515 in QDBusConnectionManager::run (this=0x7f32bc84ed40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#8  0x00007f32b9df2808 in QThreadPrivate::start (arg=0x7f32bc84ed40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#9  0x00007f32b5e816ba in start_thread (arg=0x7f329ecc3700) at pthread_create.c:333
#10 0x00007f32bc1b382d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f32a4aff700 (LWP 1754)):
#0  0x00007f32bc1a7b5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f32bb30cc62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f32bb30e8d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f32a57acd29 in QXcbEventReader::run (this=0x2573be0) at qxcbconnection.cpp:1325
#4  0x00007f32b9df2808 in QThreadPrivate::start (arg=0x2573be0) at thread/qthread_unix.cpp:341
#5  0x00007f32b5e816ba in start_thread (arg=0x7f32a4aff700) at pthread_create.c:333
#6  0x00007f32bc1b382d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f32bc6b7940 (LWP 1698)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f32897c7320) at ../../include/QtQml/5.6.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:372
#7  QQmlBinding::write (this=this@entry=0x38d5c30, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007f32b4fd153a in QQmlBinding::update (this=0x38d5c30, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007f32b4fda84f in QQmlObjectCreator::finalize (this=0x4026240, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#10 0x00007f32b4f6720e in QQmlComponentPrivate::complete (enginePriv=0x36dd690, state=0x3883c60) at qml/qqmlcomponent.cpp:919
#11 0x00007f32b4f672d7 in QQmlComponentPrivate::completeCreate (this=0x3883bc0) at qml/qqmlcomponent.cpp:955
#12 0x00007f32b4f67140 in QQmlComponent::create (this=0x3883e50, context=0x2a10600) at qml/qqmlcomponent.cpp:781
#13 0x00007f329c583047 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#14 0x00007f32bbdb3761 in ?? () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#15 0x00007f32bbc93621 in KWin::Client::createDecoration(QRect const&) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#16 0x00007f32bbc94213 in KWin::Client::updateDecoration(bool, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#17 0x00007f32bbcf3b87 in KWin::Client::manage(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#18 0x00007f32bbc753e4 in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#19 0x00007f32bbce0e8f in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#20 0x00007f32b9fc3fbf in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f32a00020c0, result=result@entry=0x7ffc480f7668) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f32a57b0ca5 in QXcbConnection::handleXcbEvent (this=this@entry=0x2567d20, event=event@entry=0x7f32a00020c0) at qxcbconnection.cpp:1091
#22 0x00007f32a57b1c06 in QXcbConnection::processXcbEvents (this=0x2567d20) at qxcbconnection.cpp:1723
#23 0x00007f32b9ff4569 in QObject::event (this=0x2567d20, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f32ba8fcafc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x2567d20, e=0x7f32a0002da0) at kernel/qapplication.cpp:3804
#25 0x00007f32ba902036 in QApplication::notify (this=0x7ffc480f7ca0, receiver=0x2567d20, e=0x7f32a0002da0) at kernel/qapplication.cpp:3561
#26 0x00007f32b9fc70f8 in QCoreApplication::notifyInternal2 (receiver=0x2567d20, event=event@entry=0x7f32a0002da0) at kernel/qcoreapplication.cpp:1015
#27 0x00007f32b9fc8fba in QCoreApplication::sendEvent (event=0x7f32a0002da0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x254f620) at kernel/qcoreapplication.cpp:1650
#29 0x00007f32ba019852 in QEventDispatcherUNIX::processEvents (this=0x2595b60, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f32a58208fd in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f32b9fc4e4a in QEventLoop::exec (this=this@entry=0x7ffc480f7b90, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f32b9fcd50c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f32bc47f226 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#34 0x00007f32bc0cd830 in __libc_start_main (main=0x400730, argc=1, argv=0x7ffc480f7e28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc480f7e18) at ../csu/libc-start.c:291
#35 0x0000000000400769 in _start ()

Possible duplicates by query: bug 374002, bug 372015, bug 370614, bug 368993, bug 367951.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-12-24 08:52:25 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***