Bug 391531 - No containment shown on given screen in overlapping setup
Summary: No containment shown on given screen in overlapping setup
Status: CONFIRMED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Multi-screen support (show other bugs)
Version: 5.20.3
Platform: Neon Linux
: NOR normal
Target Milestone: 1.0
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-07 17:15 UTC by Karl Stein
Modified: 2022-09-02 00:11 UTC (History)
25 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
output from running plasmashell (11.16 KB, text/x-log)
2018-04-06 00:23 UTC, kafei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Stein 2018-03-07 17:15:37 UTC
Here are the steps to reproduce:

1. Start the computer with KDE Neon 5.12 and two screens (A is on laptop and B is a normal external screen)
2. When on logon screen, by default it seems that the display is kind of cloned, it displays the same logon screen on both screens, but you can move the mouse on one or the other (so it's not really cloned), let's just fill the default screen which is screen A
3. Then KDE plasma loads
4. And the desktop wallpaper is black with nothing on it, when you try to right click there is no menu (maybe a crash)

Now if you restart the computer (not switch session), then use the screen B to connect, it seems that the desktop is loading normally with the wallpaper and stuffs on it..

I can't tell much, but I think it could be related to multi-displays, so it depends on which screen you use to login.

I have this bug since at least 6 months or more.


KDE Plasma: 5.12.2
KDE Frameworks: 5.43.0
Qt: 5.10.0
Linux kernel: 4.13.0.36-generic
OS: KDE Neon 5.12 64-bit
CPU: Intel Core i7-3820QM @2.7Ghz
RAM: 15.6Gio
Comment 1 kafei 2018-04-05 23:15:49 UTC
I've also just started getting this bug in the past week. No wallpaper appears on my primary display and right-click doesn't bring up the context menu, but the panel is still drawn. On my secondary monitor, the wallpaper renders fine and the context menu can still be brought up.

I'm not exactly sure when it started, it might have been after the plasma 5.12.4 update?

System info:
Arch Linux
Plasma 5.12.4
Frameworks 5.44
Qt 5.10.1
Nvidia proprietary driver 390.48
Comment 2 David Edmundson 2018-04-06 00:01:14 UTC
Can you run "xwininfo" and click on the black and paste the results.

Also output of "plasmashell" from a terminal
Comment 3 kafei 2018-04-06 00:22:02 UTC
xwininfo output on the black background:

xwininfo: Window id: 0x1ef (the root window) (has no name)

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 3840
  Height: 1080
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -0+0  -0-0  +0-0
  -geometry 3840x1080+0+0

xwininfo on the desktop with wallpaper:

xwininfo: Window id: 0x1e00016 "Desktop — Plasma"

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1920
  Height: 1080
  Depth: 32
  Visual: 0x7a
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x1e00015 (not installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -1920+0  -1920-0  +0-0
  -geometry 1920x1080+0+0
Comment 4 kafei 2018-04-06 00:23:53 UTC
Created attachment 111867 [details]
output from running plasmashell

After I ran plasmashell in a terminal, my wallpaper is appearing on both monitors again. I've attached the output anyway.
Comment 5 Serhiy Zahoriya 2018-10-22 23:48:59 UTC
I had similar behaviour several times, but not every time on login. In my case external display is bigger than the LVDS one and with the latter being disabled I see black part only on the left of a larger screen with the desktop being moved to the right and only part of it visible.
Comment 6 Justin Zobel 2020-12-03 23:53:08 UTC
I'm getting the same issue on 5.20.3.
Comment 7 Justin Zobel 2020-12-03 23:56:46 UTC
*** Bug 399216 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2021-08-16 21:36:02 UTC
*** Bug 369450 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2021-08-16 21:37:46 UTC
*** Bug 440918 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2021-08-16 21:39:38 UTC
*** Bug 419518 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2021-08-16 21:47:03 UTC
*** Bug 426260 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2021-08-16 21:47:10 UTC
*** Bug 426764 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2021-08-16 21:48:53 UTC
*** Bug 373880 has been marked as a duplicate of this bug. ***
Comment 14 Nate Graham 2021-08-16 21:50:00 UTC
Most likely the same root cause as Bug 370180 and Bug 356225.
Comment 15 Nate Graham 2021-08-16 22:12:22 UTC
*** Bug 417726 has been marked as a duplicate of this bug. ***
Comment 16 Nate Graham 2021-08-16 22:40:00 UTC
*** Bug 440995 has been marked as a duplicate of this bug. ***
Comment 17 Nate Graham 2021-08-16 23:45:28 UTC
*** Bug 382374 has been marked as a duplicate of this bug. ***
Comment 18 Nate Graham 2021-08-16 23:48:26 UTC
*** Bug 427383 has been marked as a duplicate of this bug. ***
Comment 19 Nate Graham 2021-08-17 01:51:29 UTC
*** Bug 371717 has been marked as a duplicate of this bug. ***
Comment 20 Nate Graham 2021-08-17 01:52:18 UTC
*** Bug 381270 has been marked as a duplicate of this bug. ***
Comment 21 Nate Graham 2021-08-23 15:18:37 UTC
*** Bug 440621 has been marked as a duplicate of this bug. ***
Comment 22 Nate Graham 2021-09-16 17:42:19 UTC
*** Bug 442455 has been marked as a duplicate of this bug. ***