Bug 369450 - Multiple monitor desktops & backgrounds are simply black
Summary: Multiple monitor desktops & backgrounds are simply black
Status: RESOLVED DUPLICATE of bug 353975
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-multiscreen (show other bugs)
Version: 5.7.5
Platform: Neon Linux
: NOR major
Target Milestone: 1.0
Assignee: Aleix Pol
Depends on:
Reported: 2016-09-27 21:47 UTC by Tim Bess
Modified: 2022-01-24 19:39 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description Tim Bess 2016-09-27 21:47:31 UTC
I'm sure this is likely a duplicate and someone else running 3 monitors has reported it, but search did not work for me. I run Neon-user with the latest updates as of today, and any monitors that are are on the VGA displays simply appear blank. They do not get desktop backgrounds, there is nothing that appears when I left or right click on them and nothing happens. This is NOT a fatal error. If I send an application to a second or third display -- the application goes there and appears, and it has no issues with multiple desktops working as far as displaying the applications, but those displays any without an application also appears blank -- whether its cube or any other type of switching. Hardware is a core i5 2800, HD6870 on the open source driver as AMD hasn't released a new one - one main monitor on DVI, secondary monitors on VGA to DVI adapter and display port to VGA adapter. They are real actual CRTs if its makes any difference for the secondary displays. I haven't tested this with multiple DVI displays or DVI+HDMI. 

Reproducible: Always

Steps to Reproduce:
1.Plug in VGA monitor as secondary display. (that one is blank with only 2)
2. Plus in VGA monitor as third display. (with 3 -- second two are blank)
3. Boot into actual session (no VM). 

Actual Results:  
Boom, same bug. Applications can be displayed on them, but backgrounds and other functions (such as widgets) cannot be moved to them. The monitors do show up under system settings, and otherwise function as intended. Maybe this is QT bug upstream? Kwin? 

Expected Results:  
Expected similar behavior to plasma 5.6.5 where all displays show. Display bugs like this should be a priority as they make an extremely bad impression on the end user and may terminate someone doing any further testing if they think Neon can't see their displays. 

KDE Neon User
Plasma 5.7.5
Frameworks 5.26.0
QT 5.7.0
Kernel 4.4.0-38
64 bit
Comment 1 Tim Bess 2016-09-28 05:46:30 UTC
Okay from bizarre land -- I couldn't place a widget on those displays without any background. However, I dragged over the network monitor widget onto display 1 and this disappeared. Okay, fine, dragged another one -- a couple flashes and I suddenly have backgrounds that are individually controllable on displays #2 and #3 -- with every widget I attempted to drag over working. I'm sure this triggered some kind of reset in some part of the display system given the brief white flash. Or maybe the two have nothing to do with each other and the white flash was its own reset? Not unhappy with this, but I haven't figured out a way to get it back to its original blank state without reinstalling to duplicate.
Comment 2 Jonathan E. Snow 2016-11-10 17:40:32 UTC
Similar situation:
Comment 3 Christoph Feck 2016-11-11 15:18:57 UTC
No, that's completely unrelated. If no windows can be moved to the second screen, then KWin doesn't even know about it.
Comment 4 Ben 2018-10-12 13:16:50 UTC
I have the same issue on antergos with latest plasma and have had this issue for quite some time. I have two displays connected via displayport and the nonprimary display has no background and can not be rightclicked or have widgets, My solution has been to relog or "kquitapp5 plasmashell && kstart5 plasmashell" this fixes the issue nearly every time on the first try on rare occasion it takes two attempts. Still no clue why.
Comment 5 Cristiano 2019-04-24 21:46:18 UTC
I'm having the same issue but kquitapp/kstart is not a remedy that works for me. I am running Kubuntu and had never before been able to get a background or context menu on my second screen, until last week. Then I had reinstalled kubuntu (latest) from usb and I must've done something wrong, because the installation did not complete normally. I could however, without rebooting, use Plasma immediately and: my second screen automatically was assigned the default shipped background while on my first screen the image I selected before the reinstall (from home partition) appeared. I was happy, were it not that upon the next reboot it became clear that something was critically wrong and my system would not start. I ended up running the install image again, this time I rebooted immediately and it started ok, but I couldn't get a context menu on my black second screen again. I know kde.org is not for Kubuntu, but I figured this might provide a clue perhaps, which I  hope it does.
Comment 6 Nate Graham 2021-08-16 21:36:02 UTC

*** This bug has been marked as a duplicate of bug 391531 ***
Comment 7 Nate Graham 2021-10-06 18:53:41 UTC

*** This bug has been marked as a duplicate of bug 371717 ***
Comment 8 Nate Graham 2022-01-24 19:39:16 UTC

*** This bug has been marked as a duplicate of bug 353975 ***