Bug 389838 - Scroll view speed seems to have two modes, switches between them unpredictably, and neither feels quite right
Summary: Scroll view speed seems to have two modes, switches between them unpredictabl...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.55.0
Platform: Archlinux Linux
: VHI normal with 23 votes (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords:
: 394959 400132 403998 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-03 17:13 UTC by Patrick Silva
Modified: 2019-04-23 20:23 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.58


Attachments
GIF recording of the bug (2.90 MB, image/gif)
2019-03-06 18:42 UTC, Alexey Boltenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-02-03 17:13:07 UTC
click an app category in sidebar
click some app to open its description
scrolling speed of apps list with mouse wheel is intermittent, sometimes faster, sometimes slower
problem occuts under both wayland and x11 sessions
Comment 1 Nate Graham 2018-02-03 21:09:28 UTC
Hmm, can't reproduce with git master in Neon.

Are you using libinput? Does the problem happen with a touchpad, too, or just a mouse wheel?
Comment 2 Patrick Silva 2018-02-03 22:07:38 UTC
I just tested on neon dev unstable (using touchpad and usb mouse)...
under X11 I can reproduce using both devices.
under Wayland the problem only occurs when I scroll using the mouse wheel

My both systems run libinput driver.

The problem is more noticleable on Arch Linux.
On neon not always I can reproduce.
Comment 3 Aleix Pol 2018-02-22 18:47:59 UTC
Do you still have the issue?
Moving to Kirigami where this scrolling code is.
Comment 4 Patrick Silva 2018-02-22 18:49:30 UTC
(In reply to Aleix Pol from comment #3)
> Do you still have the issue?
Yes.
Comment 5 Alexander Mentyu 2018-04-25 12:32:11 UTC
Not sure if this goes into this bug or into other/new one:

Noticed that after selection of some app description - there is a coasting upon scrolling with touchpad - after app description selection and before first stop of app list coasting animation - both on Wayland and X11

There is always coasting on X11 and there is no coasting with touchpad on Wayland

libinput 1.10.5-1
xf86-input-libinput 0.27.1-1
Plasma: 5.12.4
Apps: 18.04.0
Frameworks: 5.45.0
Qt: 5.10.1
Kernel: 4.14.36-1-MANJARO
OS: Netrunner Rolling
Video: Intel 4400
Driver: xf86-video-intel 1:2.99.917+823+gd9bf46e4-1
Screen: 1600x900
wayland-protocols 1.13-1
wayland 1.14.0-1
Comment 6 Patrick Silva 2018-06-14 17:07:19 UTC
*** Bug 394959 has been marked as a duplicate of this bug. ***
Comment 7 Patrick Silva 2018-10-22 10:36:17 UTC
*** Bug 400132 has been marked as a duplicate of this bug. ***
Comment 8 RYDeN 2018-12-15 04:02:32 UTC
IT IS SOLVED!!! Thanks a lot!
Comment 9 Patrick Silva 2019-02-06 20:12:15 UTC
Bug persists at least under X11 when I scroll the apps list using a touchpad (two fingers).

KDE neon Developer Edition
KDE Plasma: 5.15.80
KDE Frameworks: 5.55.0
Qt: 5.12.0
Comment 10 Patrick Silva 2019-02-06 20:12:52 UTC
*** Bug 403998 has been marked as a duplicate of this bug. ***
Comment 11 RYDeN 2019-02-07 01:18:50 UTC
Sorry, but it is not solved :s
Comment 12 Nate Graham 2019-02-10 20:41:04 UTC
This weird behavior drives me crazy in Discover.
Comment 13 RYDeN 2019-02-10 21:48:05 UTC
Yes Nate, it's a small bug, but too annoying!
Comment 14 Björn Feber 2019-02-21 14:53:30 UTC
Still happens and it's quite annoying.
Comment 15 Alexey Boltenko 2019-03-06 18:42:10 UTC
Created attachment 118606 [details]
GIF recording of the bug

The behaviour in the attachment is caused by clicking in "empty" parts of the scrolling view.
Comment 16 Nate Graham 2019-03-06 21:37:54 UTC
(In reply to Alexey Boltenko from comment #15)
> Created attachment 118606 [details]
> GIF recording of the bug
> 
> The behaviour in the attachment is caused by clicking in "empty" parts of
> the scrolling view.

That's a great observation, thanks! I can reproduce this behavior too. Just click on one of the headers in System Settings' sidebar and the scrolling type changes the next time you scroll.