Bug 365159 - Application: Dolphin (dolphin), signal: Segmentation fault
Summary: Application: Dolphin (dolphin), signal: Segmentation fault
Status: RESOLVED DUPLICATE of bug 339502
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.14.2
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-07-06 16:14 UTC by wolfgang wayland
Modified: 2016-12-25 11:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wolfgang wayland 2016-07-06 16:14:21 UTC
Application: dolphin (4.14.2)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.19.0-32-generic x86_64
Distribution: Linux Mint 17.3 Rosa

-- Information about the crash:
- What I was doing when the application crashed:
dolphin crash's when opening folder location from FireFox Download button

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f749ff64800 (LWP 4239))]

Thread 4 (Thread 0x7f747a999700 (LWP 4241)):
#0  0x00007f749f82efdd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7496a85fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7496a860ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f749b89d7be in QEventDispatcherGlib::processEvents (this=0x7f74740008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f749b86f0af in QEventLoop::processEvents (this=this@entry=0x7f747a998da0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f749b86f3a5 in QEventLoop::exec (this=this@entry=0x7f747a998da0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f749b76bc5f in QThread::exec (this=this@entry=0x1d6ee80) at thread/qthread.cpp:537
#7  0x00007f749b850823 in QInotifyFileSystemWatcherEngine::run (this=0x1d6ee80) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f749b76e32f in QThreadPrivate::start (arg=0x1d6ee80) at thread/qthread_unix.cpp:349
#9  0x00007f7496f65184 in start_thread (arg=0x7f747a999700) at pthread_create.c:312
#10 0x00007f749f83c37d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f747a15d700 (LWP 4242)):
#0  0x00007f749f82efdd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7496a85fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7496a860ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f749b89d7be in QEventDispatcherGlib::processEvents (this=0x7f746c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f749b86f0af in QEventLoop::processEvents (this=this@entry=0x7f747a15cde0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f749b86f3a5 in QEventLoop::exec (this=this@entry=0x7f747a15cde0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f749b76bc5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007f749b76e32f in QThreadPrivate::start (arg=0x1b2e6a0) at thread/qthread_unix.cpp:349
#8  0x00007f7496f65184 in start_thread (arg=0x7f747a15d700) at pthread_create.c:312
#9  0x00007f749f83c37d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f74792ad700 (LWP 4243)):
#0  0x00007f7496f687de in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f7470000a80) at pthread_mutex_unlock.c:57
#1  __GI___pthread_mutex_unlock (mutex=0x7f7470000a80) at pthread_mutex_unlock.c:310
#2  0x00007f7496ac79b1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7496a860f6 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f749b89d7be in QEventDispatcherGlib::processEvents (this=0x7f74700008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f749b86f0af in QEventLoop::processEvents (this=this@entry=0x7f74792acda0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f749b86f3a5 in QEventLoop::exec (this=this@entry=0x7f74792acda0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f749b76bc5f in QThread::exec (this=this@entry=0x1d30000) at thread/qthread.cpp:537
#8  0x00007f749b850823 in QInotifyFileSystemWatcherEngine::run (this=0x1d30000) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f749b76e32f in QThreadPrivate::start (arg=0x1d30000) at thread/qthread_unix.cpp:349
#10 0x00007f7496f65184 in start_thread (arg=0x7f74792ad700) at pthread_create.c:312
#11 0x00007f749f83c37d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f749ff64800 (LWP 4239)):
[KCrash Handler]
#6  DolphinViewContainer::setAutoGrabFocus (this=0x0, grab=grab@entry=false) at ../../../dolphin/src/dolphinviewcontainer.cpp:222
#7  0x00007f749fb4d837 in DolphinMainWindow::slotTerminalDirectoryChanged (this=0x1c24540, url=...) at ../../../dolphin/src/dolphinmainwindow.cpp:315
#8  0x00007f749fb4e449 in DolphinMainWindow::qt_static_metacall (_o=0x1c24540, _id=0, _a=0x7ffe3cb6c670, _c=<optimized out>) at ./dolphinmainwindow.moc:197
#9  0x00007f749b88487a in QMetaObject::activate (sender=sender@entry=0x1bc4c30, m=m@entry=0x7f749fda9ba0 <TerminalPanel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffe3cb6c670) at kernel/qobject.cpp:3539
#10 0x00007f749fb876d1 in changeUrl (_t1=..., this=0x1bc4c30) at ./terminalpanel.moc:119
#11 TerminalPanel::slotKonsolePartCurrentDirectoryChanged (this=0x1bc4c30, dir=...) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:193
#12 0x00007f749fb87749 in TerminalPanel::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./terminalpanel.moc:64
#13 0x00007f749b88487a in QMetaObject::activate (sender=0x1ed8650, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffe3cb6c800) at kernel/qobject.cpp:3539
#14 0x00007f74788a8148 in currentDirectoryChanged (_t1=..., this=<optimized out>) at ./Part.moc:191
#15 Konsole::Part::qt_static_metacall (_o=0x0, _id=0, _a=0x7ffe3cb6c670, _c=<optimized out>) at ./Part.moc:95
#16 0x00007f749b88487a in QMetaObject::activate (sender=0x1f06670, m=m@entry=0x7f74788991e0 <Konsole::SessionController::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffe3cb6c930) at kernel/qobject.cpp:3539
#17 0x00007f7478636d85 in Konsole::SessionController::currentDirectoryChanged (this=<optimized out>, _t1=...) at ./SessionController.moc:280
#18 0x00007f747863df49 in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7ffe3cb6c670, _c=<optimized out>) at ./SessionController.moc:156
#19 0x00007f749b88487a in QMetaObject::activate (sender=sender@entry=0x1ee2000, m=m@entry=0x7f7478898da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffe3cb6ca80) at kernel/qobject.cpp:3539
#20 0x00007f747862dab5 in Konsole::Session::currentDirectoryChanged (this=this@entry=0x1ee2000, _t1=...) at ./Session.moc:343
#21 0x00007f747862db0c in Konsole::Session::updateWorkingDirectory (this=this@entry=0x1ee2000) at ../../src/Session.cpp:297
#22 0x00007f747862dd8c in Konsole::Session::getDynamicTitle (this=0x1ee2000) at ../../src/Session.cpp:992
#23 0x00007f7478637f01 in Konsole::SessionController::snapshot (this=0x1f06670) at ../../src/SessionController.cpp:265
#24 0x00007f747863dbbd in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7ffe3cb6c670, _c=<optimized out>) at ./SessionController.moc:204
#25 0x00007f749b88487a in QMetaObject::activate (sender=sender@entry=0x1ee2000, m=m@entry=0x7f7478898da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#26 0x00007f747862d8e0 in Konsole::Session::started (this=this@entry=0x1ee2000) at ./Session.moc:317
#27 0x00007f7478630cc9 in Konsole::Session::run (this=0x1ee2000) at ../../src/Session.cpp:515
#28 0x00007f749fb87880 in TerminalPanel::showEvent (this=0x1bc4c30, event=0x7ffe3cb6d230) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:121
#29 0x00007f749c2b22b5 in QWidget::event (this=0x1bc4c30, event=0x7ffe3cb6d230) at kernel/qwidget.cpp:8594
#30 0x00007f749c262e2c in QApplicationPrivate::notify_helper (this=this@entry=0x18c6db0, receiver=receiver@entry=0x1bc4c30, e=e@entry=0x7ffe3cb6d230) at kernel/qapplication.cpp:4567
#31 0x00007f749c2694a0 in QApplication::notify (this=this@entry=0x7ffe3cb6d5d0, receiver=receiver@entry=0x1bc4c30, e=e@entry=0x7ffe3cb6d230) at kernel/qapplication.cpp:4353
#32 0x00007f749cf6dcca in KApplication::notify (this=0x7ffe3cb6d5d0, receiver=0x1bc4c30, event=0x7ffe3cb6d230) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f749b8704dd in QCoreApplication::notifyInternal (this=0x7ffe3cb6d5d0, receiver=receiver@entry=0x1bc4c30, event=event@entry=0x7ffe3cb6d230) at kernel/qcoreapplication.cpp:953
#34 0x00007f749c2afa1f in sendEvent (event=0x7ffe3cb6d230, receiver=0x1bc4c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QWidgetPrivate::show_helper (this=0x1bf8a90) at kernel/qwidget.cpp:7556
#36 0x00007f749c2af74c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#37 0x00007f749c2af88a in QWidgetPrivate::showChildren (this=this@entry=0x1c6baf0, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#38 0x00007f749c2af91f in QWidgetPrivate::show_helper (this=0x1c6baf0) at kernel/qwidget.cpp:7503
#39 0x00007f749c2af74c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#40 0x00007f749c2af88a in QWidgetPrivate::showChildren (this=this@entry=0x1c23dd0, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#41 0x00007f749c2af91f in QWidgetPrivate::show_helper (this=this@entry=0x1c23dd0) at kernel/qwidget.cpp:7503
#42 0x00007f749c2b16c4 in QWidget::setVisible (this=0x1c24540, visible=<optimized out>) at kernel/qwidget.cpp:7778
#43 0x00007f749fb42f5c in show (this=<optimized out>) at /usr/include/qt4/QtGui/qwidget.h:497
#44 DolphinApplication::DolphinApplication (this=0x7ffe3cb6d5d0) at ../../../dolphin/src/dolphinapplication.cpp:84
#45 0x00007f749fb573ce in kdemain (argc=6, argv=0x7ffe3cb6d708) at ../../../dolphin/src/main.cpp:89
#46 0x00007f749f763f45 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=6, argv=0x7ffe3cb6d708, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe3cb6d6f8) at libc-start.c:287
#47 0x00000000004006fe in _start ()

Possible duplicates by query: bug 349736, bug 349502, bug 345415, bug 344872, bug 340926.

Reported using DrKonqi
Comment 1 Elvis Angelaccio 2016-12-25 11:43:06 UTC
Fixed in Dolphin 4.14.3, please update.

*** This bug has been marked as a duplicate of bug 339502 ***