Bug 345415 - Dolphin crashes when clicking folder from folder widget
Summary: Dolphin crashes when clicking folder from folder widget
Status: RESOLVED DUPLICATE of bug 339502
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.14.2
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-03-22 09:10 UTC by Bartosz Białas
Modified: 2015-03-22 18:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Białas 2015-03-22 09:10:22 UTC
Application: dolphin (4.14.2)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-37-generic x86_64
Distribution: Linux Mint 17.1 Rebecca

-- Information about the crash:
- What I was doing when the application crashed:
Nothing, just logged in and click folder on folder widget.
- Unusual behavior I noticed:
On my desktop I have widget Folder. When I click a folder inside this widget it shows window: "Dolphin has crashed". When I click 'Restart application' it opens, but not in the folder I clicked, but in my home folder.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f09e4d927c0 (LWP 3034))]

Thread 4 (Thread 0x7f09c7bdf700 (LWP 3035)):
#0  0x00007f09dbd87569 in __GI___pthread_mutex_lock (mutex=0x7f09c0000a60) at ../nptl/pthread_mutex_lock.c:125
#1  0x00007f09db8e7981 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f09db8a5699 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f09db8a5f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f09db8a60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f09e06bd7be in QEventDispatcherGlib::processEvents (this=0x7f09c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f09e068f0af in QEventLoop::processEvents (this=this@entry=0x7f09c7bdede0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f09e068f3a5 in QEventLoop::exec (this=this@entry=0x7f09c7bdede0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f09e058bc5f in QThread::exec (this=this@entry=0xce0870) at thread/qthread.cpp:537
#9  0x00007f09e0670823 in QInotifyFileSystemWatcherEngine::run (this=0xce0870) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f09e058e32f in QThreadPrivate::start (arg=0xce0870) at thread/qthread_unix.cpp:349
#11 0x00007f09dbd85182 in start_thread (arg=0x7f09c7bdf700) at pthread_create.c:312
#12 0x00007f09e465c47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f09c7391700 (LWP 3036)):
#0  0x00007f09e464f12d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f09db8a5fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f09db8a60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f09e06bd7be in QEventDispatcherGlib::processEvents (this=0x7f09b80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f09e068f0af in QEventLoop::processEvents (this=this@entry=0x7f09c7390e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f09e068f3a5 in QEventLoop::exec (this=this@entry=0x7f09c7390e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f09e058bc5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007f09e058e32f in QThreadPrivate::start (arg=0xf2fd70) at thread/qthread_unix.cpp:349
#8  0x00007f09dbd85182 in start_thread (arg=0x7f09c7391700) at pthread_create.c:312
#9  0x00007f09e465c47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f09c6518700 (LWP 3037)):
#0  0x00007f09e464f12d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f09db8a5fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f09db8a60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f09e06bd7be in QEventDispatcherGlib::processEvents (this=0x7f09bc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f09e068f0af in QEventLoop::processEvents (this=this@entry=0x7f09c6517de0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f09e068f3a5 in QEventLoop::exec (this=this@entry=0x7f09c6517de0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f09e058bc5f in QThread::exec (this=this@entry=0xf48960) at thread/qthread.cpp:537
#7  0x00007f09e0670823 in QInotifyFileSystemWatcherEngine::run (this=0xf48960) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f09e058e32f in QThreadPrivate::start (arg=0xf48960) at thread/qthread_unix.cpp:349
#9  0x00007f09dbd85182 in start_thread (arg=0x7f09c6518700) at pthread_create.c:312
#10 0x00007f09e465c47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f09e4d927c0 (LWP 3034)):
[KCrash Handler]
#6  DolphinViewContainer::setAutoGrabFocus (this=0x0, grab=grab@entry=false) at ../../../dolphin/src/dolphinviewcontainer.cpp:222
#7  0x00007f09e496d837 in DolphinMainWindow::slotTerminalDirectoryChanged (this=0xb5c120, url=...) at ../../../dolphin/src/dolphinmainwindow.cpp:315
#8  0x00007f09e496e449 in DolphinMainWindow::qt_static_metacall (_o=0xb5c120, _id=0, _a=0x7fff582addd0, _c=<optimized out>) at ./dolphinmainwindow.moc:197
#9  0x00007f09e06a487a in QMetaObject::activate (sender=sender@entry=0xb84460, m=m@entry=0x7f09e4bc9ba0 <TerminalPanel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff582addd0) at kernel/qobject.cpp:3539
#10 0x00007f09e49a76d1 in changeUrl (_t1=..., this=0xb84460) at ./terminalpanel.moc:119
#11 TerminalPanel::slotKonsolePartCurrentDirectoryChanged (this=0xb84460, dir=...) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:193
#12 0x00007f09e49a7749 in TerminalPanel::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./terminalpanel.moc:64
#13 0x00007f09e06a487a in QMetaObject::activate (sender=0x101fb60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff582adf60) at kernel/qobject.cpp:3539
#14 0x00007f09c5b13148 in currentDirectoryChanged (_t1=..., this=<optimized out>) at ./Part.moc:191
#15 Konsole::Part::qt_static_metacall (_o=0x0, _id=0, _a=0x7fff582addd0, _c=<optimized out>) at ./Part.moc:95
#16 0x00007f09e06a487a in QMetaObject::activate (sender=0x107a070, m=m@entry=0x7f09c5b041e0 <Konsole::SessionController::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fff582ae090) at kernel/qobject.cpp:3539
#17 0x00007f09c58a1d85 in Konsole::SessionController::currentDirectoryChanged (this=<optimized out>, _t1=...) at ./SessionController.moc:280
#18 0x00007f09c58a8f49 in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7fff582addd0, _c=<optimized out>) at ./SessionController.moc:156
#19 0x00007f09e06a487a in QMetaObject::activate (sender=sender@entry=0x1030bf0, m=m@entry=0x7f09c5b03da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff582ae1e0) at kernel/qobject.cpp:3539
#20 0x00007f09c5898ab5 in Konsole::Session::currentDirectoryChanged (this=this@entry=0x1030bf0, _t1=...) at ./Session.moc:343
#21 0x00007f09c5898b0c in Konsole::Session::updateWorkingDirectory (this=this@entry=0x1030bf0) at ../../src/Session.cpp:297
#22 0x00007f09c5898d8c in Konsole::Session::getDynamicTitle (this=0x1030bf0) at ../../src/Session.cpp:992
#23 0x00007f09c58a2f01 in Konsole::SessionController::snapshot (this=0x107a070) at ../../src/SessionController.cpp:265
#24 0x00007f09c58a8bbd in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7fff582addd0, _c=<optimized out>) at ./SessionController.moc:204
#25 0x00007f09e06a487a in QMetaObject::activate (sender=sender@entry=0x1030bf0, m=m@entry=0x7f09c5b03da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#26 0x00007f09c58988e0 in Konsole::Session::started (this=this@entry=0x1030bf0) at ./Session.moc:317
#27 0x00007f09c589bcc9 in Konsole::Session::run (this=0x1030bf0) at ../../src/Session.cpp:515
#28 0x00007f09e49a7880 in TerminalPanel::showEvent (this=0xb84460, event=0x7fff582ae990) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:121
#29 0x00007f09e10d22a5 in QWidget::event (this=0xb84460, event=0x7fff582ae990) at kernel/qwidget.cpp:8594
#30 0x00007f09e1082e2c in QApplicationPrivate::notify_helper (this=this@entry=0x9c5480, receiver=receiver@entry=0xb84460, e=e@entry=0x7fff582ae990) at kernel/qapplication.cpp:4567
#31 0x00007f09e10894a0 in QApplication::notify (this=this@entry=0x7fff582aed30, receiver=receiver@entry=0xb84460, e=e@entry=0x7fff582ae990) at kernel/qapplication.cpp:4353
#32 0x00007f09e1d8dcca in KApplication::notify (this=0x7fff582aed30, receiver=0xb84460, event=0x7fff582ae990) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f09e06904dd in QCoreApplication::notifyInternal (this=0x7fff582aed30, receiver=receiver@entry=0xb84460, event=event@entry=0x7fff582ae990) at kernel/qcoreapplication.cpp:953
#34 0x00007f09e10cfa0f in sendEvent (event=0x7fff582ae990, receiver=0xb84460) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QWidgetPrivate::show_helper (this=0xa67390) at kernel/qwidget.cpp:7556
#36 0x00007f09e10cf73c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#37 0x00007f09e10cf87a in QWidgetPrivate::showChildren (this=this@entry=0xb91d80, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#38 0x00007f09e10cf90f in QWidgetPrivate::show_helper (this=0xb91d80) at kernel/qwidget.cpp:7503
#39 0x00007f09e10cf73c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#40 0x00007f09e10cf87a in QWidgetPrivate::showChildren (this=this@entry=0xb5eb20, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#41 0x00007f09e10cf90f in QWidgetPrivate::show_helper (this=this@entry=0xb5eb20) at kernel/qwidget.cpp:7503
#42 0x00007f09e10d16b4 in QWidget::setVisible (this=0xb5c120, visible=<optimized out>) at kernel/qwidget.cpp:7778
#43 0x00007f09e4962f5c in show (this=<optimized out>) at /usr/include/qt4/QtGui/qwidget.h:497
#44 DolphinApplication::DolphinApplication (this=0x7fff582aed30) at ../../../dolphin/src/dolphinapplication.cpp:84
#45 0x00007f09e49773ce in kdemain (argc=6, argv=0x7fff582aee68) at ../../../dolphin/src/main.cpp:89
#46 0x00007f09e4583ec5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=6, argv=0x7fff582aee68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff582aee58) at libc-start.c:287
#47 0x00000000004006fe in _start ()

Possible duplicates by query: bug 344872, bug 340926, bug 339502.

Reported using DrKonqi
Comment 1 Emmanuel Pescosta 2015-03-22 18:11:05 UTC
Thanks for the bug report! This crash is fixed in Dolphin 4.14.3 and later.

*** This bug has been marked as a duplicate of bug 339502 ***