Bug 349502 - Dolphin crashes when opening an external device (usbkey) with it or when an application tries to open a folder with it
Summary: Dolphin crashes when opening an external device (usbkey) with it or when an a...
Status: RESOLVED DUPLICATE of bug 339502
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.14.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-22 17:08 UTC by Paolo
Modified: 2015-06-24 19:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo 2015-06-22 17:08:32 UTC
Application: dolphin (4.14.2)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-55-generic x86_64
Distribution: Ubuntu 14.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I clicked on the Device Notifier in the tray to open the root of a usbkey.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f99ea0e37c0 (LWP 13999))]

Thread 4 (Thread 0x7f99ccc29700 (LWP 14070)):
#0  0x00007f99e0c4161d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f99e0c41979 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f99e0bff1f8 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f99e0bfff91 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f99e0c000ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f99e5a177be in QEventDispatcherGlib::processEvents (this=0x7f99c80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f99e59e90af in QEventLoop::processEvents (this=this@entry=0x7f99ccc28de0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f99e59e93a5 in QEventLoop::exec (this=this@entry=0x7f99ccc28de0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f99e58e5c5f in QThread::exec (this=this@entry=0x11440c0) at thread/qthread.cpp:537
#9  0x00007f99e59ca823 in QInotifyFileSystemWatcherEngine::run (this=0x11440c0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f99e58e832f in QThreadPrivate::start (arg=0x11440c0) at thread/qthread_unix.cpp:349
#11 0x00007f99e10df182 in start_thread (arg=0x7f99ccc29700) at pthread_create.c:312
#12 0x00007f99e99b647d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f99c7fff700 (LWP 14076)):
#0  0x00007f99e10e27ee in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f99c0000a60) at pthread_mutex_unlock.c:57
#1  __GI___pthread_mutex_unlock (mutex=0x7f99c0000a60) at pthread_mutex_unlock.c:310
#2  0x00007f99e0c419b1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f99e0bfffd9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f99e0c000ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f99e5a177be in QEventDispatcherGlib::processEvents (this=0x7f99c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f99e59e90af in QEventLoop::processEvents (this=this@entry=0x7f99c7ffee20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f99e59e93a5 in QEventLoop::exec (this=this@entry=0x7f99c7ffee20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f99e58e5c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9  0x00007f99e58e832f in QThreadPrivate::start (arg=0xc35750) at thread/qthread_unix.cpp:349
#10 0x00007f99e10df182 in start_thread (arg=0x7f99c7fff700) at pthread_create.c:312
#11 0x00007f99e99b647d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f99c738d700 (LWP 14077)):
#0  0x00007f99e0c4161a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f99e0c41979 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f99e0bff0b0 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f99e0bffea5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f99e0c000ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f99e5a177be in QEventDispatcherGlib::processEvents (this=0x7f99b80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f99e59e90af in QEventLoop::processEvents (this=this@entry=0x7f99c738cde0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f99e59e93a5 in QEventLoop::exec (this=this@entry=0x7f99c738cde0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f99e58e5c5f in QThread::exec (this=this@entry=0x1348b60) at thread/qthread.cpp:537
#9  0x00007f99e59ca823 in QInotifyFileSystemWatcherEngine::run (this=0x1348b60) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f99e58e832f in QThreadPrivate::start (arg=0x1348b60) at thread/qthread_unix.cpp:349
#11 0x00007f99e10df182 in start_thread (arg=0x7f99c738d700) at pthread_create.c:312
#12 0x00007f99e99b647d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f99ea0e37c0 (LWP 13999)):
[KCrash Handler]
#6  DolphinViewContainer::setAutoGrabFocus (this=0x0, grab=grab@entry=false) at ../../../dolphin/src/dolphinviewcontainer.cpp:222
#7  0x00007f99e9cc7837 in DolphinMainWindow::slotTerminalDirectoryChanged (this=0xcbf4d0, url=...) at ../../../dolphin/src/dolphinmainwindow.cpp:315
#8  0x00007f99e9cc8449 in DolphinMainWindow::qt_static_metacall (_o=0xcbf4d0, _id=0, _a=0x7ffdf95544d0, _c=<optimized out>) at ./dolphinmainwindow.moc:197
#9  0x00007f99e59fe87a in QMetaObject::activate (sender=sender@entry=0xc35f00, m=m@entry=0x7f99e9f23ba0 <TerminalPanel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffdf95544d0) at kernel/qobject.cpp:3539
#10 0x00007f99e9d016d1 in changeUrl (_t1=..., this=0xc35f00) at ./terminalpanel.moc:119
#11 TerminalPanel::slotKonsolePartCurrentDirectoryChanged (this=0xc35f00, dir=...) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:193
#12 0x00007f99e9d01749 in TerminalPanel::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./terminalpanel.moc:64
#13 0x00007f99e59fe87a in QMetaObject::activate (sender=0x15a33d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffdf9554660) at kernel/qobject.cpp:3539
#14 0x00007f99c6366148 in currentDirectoryChanged (_t1=..., this=<optimized out>) at ./Part.moc:191
#15 Konsole::Part::qt_static_metacall (_o=0x0, _id=0, _a=0x7ffdf95544d0, _c=<optimized out>) at ./Part.moc:95
#16 0x00007f99e59fe87a in QMetaObject::activate (sender=0x15e43e0, m=m@entry=0x7f99c63571e0 <Konsole::SessionController::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffdf9554790) at kernel/qobject.cpp:3539
#17 0x00007f99c60f4d85 in Konsole::SessionController::currentDirectoryChanged (this=<optimized out>, _t1=...) at ./SessionController.moc:280
#18 0x00007f99c60fbf49 in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7ffdf95544d0, _c=<optimized out>) at ./SessionController.moc:156
#19 0x00007f99e59fe87a in QMetaObject::activate (sender=sender@entry=0x15a6430, m=m@entry=0x7f99c6356da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffdf95548e0) at kernel/qobject.cpp:3539
#20 0x00007f99c60ebab5 in Konsole::Session::currentDirectoryChanged (this=this@entry=0x15a6430, _t1=...) at ./Session.moc:343
#21 0x00007f99c60ebb0c in Konsole::Session::updateWorkingDirectory (this=this@entry=0x15a6430) at ../../src/Session.cpp:297
#22 0x00007f99c60ebd8c in Konsole::Session::getDynamicTitle (this=0x15a6430) at ../../src/Session.cpp:992
#23 0x00007f99c60f5f01 in Konsole::SessionController::snapshot (this=0x15e43e0) at ../../src/SessionController.cpp:265
#24 0x00007f99c60fbbbd in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7ffdf95544d0, _c=<optimized out>) at ./SessionController.moc:204
#25 0x00007f99e59fe87a in QMetaObject::activate (sender=sender@entry=0x15a6430, m=m@entry=0x7f99c6356da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#26 0x00007f99c60eb8e0 in Konsole::Session::started (this=this@entry=0x15a6430) at ./Session.moc:317
#27 0x00007f99c60eecc9 in Konsole::Session::run (this=0x15a6430) at ../../src/Session.cpp:515
#28 0x00007f99e9d01880 in TerminalPanel::showEvent (this=0xc35f00, event=0x7ffdf9555090) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:121
#29 0x00007f99e642c2b5 in QWidget::event (this=0xc35f00, event=0x7ffdf9555090) at kernel/qwidget.cpp:8594
#30 0x00007f99e63dce2c in QApplicationPrivate::notify_helper (this=this@entry=0xb90e50, receiver=receiver@entry=0xc35f00, e=e@entry=0x7ffdf9555090) at kernel/qapplication.cpp:4567
#31 0x00007f99e63e34a0 in QApplication::notify (this=this@entry=0x7ffdf9555430, receiver=receiver@entry=0xc35f00, e=e@entry=0x7ffdf9555090) at kernel/qapplication.cpp:4353
#32 0x00007f99e70e7cca in KApplication::notify (this=0x7ffdf9555430, receiver=0xc35f00, event=0x7ffdf9555090) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f99e59ea4dd in QCoreApplication::notifyInternal (this=0x7ffdf9555430, receiver=receiver@entry=0xc35f00, event=event@entry=0x7ffdf9555090) at kernel/qcoreapplication.cpp:953
#34 0x00007f99e6429a1f in sendEvent (event=0x7ffdf9555090, receiver=0xc35f00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QWidgetPrivate::show_helper (this=0xd2a550) at kernel/qwidget.cpp:7556
#36 0x00007f99e642974c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#37 0x00007f99e642988a in QWidgetPrivate::showChildren (this=this@entry=0xd85820, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#38 0x00007f99e642991f in QWidgetPrivate::show_helper (this=0xd85820) at kernel/qwidget.cpp:7503
#39 0x00007f99e642974c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#40 0x00007f99e642988a in QWidgetPrivate::showChildren (this=this@entry=0xcc08f0, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#41 0x00007f99e642991f in QWidgetPrivate::show_helper (this=this@entry=0xcc08f0) at kernel/qwidget.cpp:7503
#42 0x00007f99e642b6c4 in QWidget::setVisible (this=0xcbf4d0, visible=<optimized out>) at kernel/qwidget.cpp:7778
#43 0x00007f99e9cbcf5c in show (this=<optimized out>) at /usr/include/qt4/QtGui/qwidget.h:497
#44 DolphinApplication::DolphinApplication (this=0x7ffdf9555430) at ../../../dolphin/src/dolphinapplication.cpp:84
#45 0x00007f99e9cd13ce in kdemain (argc=6, argv=0x7ffdf9555568) at ../../../dolphin/src/main.cpp:89
#46 0x00007f99e98ddec5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=6, argv=0x7ffdf9555568, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdf9555558) at libc-start.c:287
#47 0x00000000004006fe in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 339502.

Possible duplicates by query: bug 345415, bug 344872, bug 340926, bug 339502.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2015-06-24 19:27:52 UTC
Thanks for the bug report! Please upgrade to Dolphin 4.14.3 or later.

*** This bug has been marked as a duplicate of bug 339502 ***