Bug 349736 - Dolphin crashes when called by an application or from the desktop.
Summary: Dolphin crashes when called by an application or from the desktop.
Status: RESOLVED DUPLICATE of bug 339502
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.14.2
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-30 06:34 UTC by Lildirt
Modified: 2015-07-07 19:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lildirt 2015-06-30 06:34:16 UTC
Application: dolphin (4.14.2)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-37-generic x86_64
Distribution: Linux Mint 17.1 Rebecca

-- Information about the crash:
- What I was doing when the application crashed:

I simply tried opening something in the directory "~/VirtualDesktops/Desktop/Desktop_right". Each folder in "~/VirtualDesktops/Desktop" is a desktop for each monitor. I have three monitors, so hence I have Desktop_left, Desktop_middle, and Desktop_right which host files that are then displayed on my desktop (using the Folder desktop setting). Note that I have set all of the monitors to the "Desktop" folder and I still get this issue. It is not a link of any kind, either.

Each time I attempt to open a folder in any of my "Desktop_x" folders via the desktop itself, this error occurs. As well, it seems that whenever an application (in my case: "skype-call-recorder", which has an option to open a folder; "owncloud-client" which has an option to open a folder) tries to open a folder directly (as in I hit a button and a folder pops up), it crashes as well with the exact same error.

I hope I provided enough information here.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9e8eb4f7c0 (LWP 28946))]

Thread 4 (Thread 0x7f9e71ae4700 (LWP 28947)):
#0  0x00007f9e8e40d12d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9e85663fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e856640ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e8a47b7be in QEventDispatcherGlib::processEvents (this=0x7f9e6c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f9e8a44d0af in QEventLoop::processEvents (this=this@entry=0x7f9e71ae3de0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e8a44d3a5 in QEventLoop::exec (this=this@entry=0x7f9e71ae3de0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9e8a349c5f in QThread::exec (this=this@entry=0xc89870) at thread/qthread.cpp:537
#7  0x00007f9e8a42e823 in QInotifyFileSystemWatcherEngine::run (this=0xc89870) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f9e8a34c32f in QThreadPrivate::start (arg=0xc89870) at thread/qthread_unix.cpp:349
#9  0x00007f9e85b43182 in start_thread (arg=0x7f9e71ae4700) at pthread_create.c:312
#10 0x00007f9e8e41a47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f9e712e3700 (LWP 28948)):
#0  0x00007f9e85663680 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9e85663f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e856640ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e8a47b7be in QEventDispatcherGlib::processEvents (this=0x7f9e640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f9e8a44d0af in QEventLoop::processEvents (this=this@entry=0x7f9e712e2e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e8a44d3a5 in QEventLoop::exec (this=this@entry=0x7f9e712e2e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9e8a349c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007f9e8a34c32f in QThreadPrivate::start (arg=0xee6010) at thread/qthread_unix.cpp:349
#8  0x00007f9e85b43182 in start_thread (arg=0x7f9e712e3700) at pthread_create.c:312
#9  0x00007f9e8e41a47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f9e6bfff700 (LWP 28949)):
#0  0x00007f9e85b467ee in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f9e60000a60) at pthread_mutex_unlock.c:57
#1  __GI___pthread_mutex_unlock (mutex=0x7f9e60000a60) at pthread_mutex_unlock.c:310
#2  0x00007f9e856a59b1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e85663bda in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9e85664048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9e856640ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f9e8a47b7be in QEventDispatcherGlib::processEvents (this=0x7f9e600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#7  0x00007f9e8a44d0af in QEventLoop::processEvents (this=this@entry=0x7f9e6bffede0, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f9e8a44d3a5 in QEventLoop::exec (this=this@entry=0x7f9e6bffede0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f9e8a349c5f in QThread::exec (this=this@entry=0x1016b20) at thread/qthread.cpp:537
#10 0x00007f9e8a42e823 in QInotifyFileSystemWatcherEngine::run (this=0x1016b20) at io/qfilesystemwatcher_inotify.cpp:265
#11 0x00007f9e8a34c32f in QThreadPrivate::start (arg=0x1016b20) at thread/qthread_unix.cpp:349
#12 0x00007f9e85b43182 in start_thread (arg=0x7f9e6bfff700) at pthread_create.c:312
#13 0x00007f9e8e41a47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f9e8eb4f7c0 (LWP 28946)):
[KCrash Handler]
#6  DolphinViewContainer::setAutoGrabFocus (this=0x0, grab=grab@entry=false) at ../../../dolphin/src/dolphinviewcontainer.cpp:222
#7  0x00007f9e8e72b837 in DolphinMainWindow::slotTerminalDirectoryChanged (this=0xad8c50, url=...) at ../../../dolphin/src/dolphinmainwindow.cpp:315
#8  0x00007f9e8e72c449 in DolphinMainWindow::qt_static_metacall (_o=0xad8c50, _id=0, _a=0x7fff0e4c92b0, _c=<optimized out>) at ./dolphinmainwindow.moc:197
#9  0x00007f9e8a46287a in QMetaObject::activate (sender=sender@entry=0xa0f000, m=m@entry=0x7f9e8e987ba0 <TerminalPanel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff0e4c92b0) at kernel/qobject.cpp:3539
#10 0x00007f9e8e7656d1 in changeUrl (_t1=..., this=0xa0f000) at ./terminalpanel.moc:119
#11 TerminalPanel::slotKonsolePartCurrentDirectoryChanged (this=0xa0f000, dir=...) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:193
#12 0x00007f9e8e765749 in TerminalPanel::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./terminalpanel.moc:64
#13 0x00007f9e8a46287a in QMetaObject::activate (sender=0x10da220, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0e4c9440) at kernel/qobject.cpp:3539
#14 0x00007f9e70266148 in currentDirectoryChanged (_t1=..., this=<optimized out>) at ./Part.moc:191
#15 Konsole::Part::qt_static_metacall (_o=0x0, _id=0, _a=0x7fff0e4c92b0, _c=<optimized out>) at ./Part.moc:95
#16 0x00007f9e8a46287a in QMetaObject::activate (sender=0x11359c0, m=m@entry=0x7f9e6b7f71e0 <Konsole::SessionController::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fff0e4c9570) at kernel/qobject.cpp:3539
#17 0x00007f9e6b594d85 in Konsole::SessionController::currentDirectoryChanged (this=<optimized out>, _t1=...) at ./SessionController.moc:280
#18 0x00007f9e6b59bf49 in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7fff0e4c92b0, _c=<optimized out>) at ./SessionController.moc:156
#19 0x00007f9e8a46287a in QMetaObject::activate (sender=sender@entry=0x10eb7c0, m=m@entry=0x7f9e6b7f6da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff0e4c96c0) at kernel/qobject.cpp:3539
#20 0x00007f9e6b58bab5 in Konsole::Session::currentDirectoryChanged (this=this@entry=0x10eb7c0, _t1=...) at ./Session.moc:343
#21 0x00007f9e6b58bb0c in Konsole::Session::updateWorkingDirectory (this=this@entry=0x10eb7c0) at ../../src/Session.cpp:297
#22 0x00007f9e6b58bd8c in Konsole::Session::getDynamicTitle (this=0x10eb7c0) at ../../src/Session.cpp:992
#23 0x00007f9e6b595f01 in Konsole::SessionController::snapshot (this=0x11359c0) at ../../src/SessionController.cpp:265
#24 0x00007f9e6b59bbbd in Konsole::SessionController::qt_static_metacall (_o=0x0, _id=0, _a=0x7fff0e4c92b0, _c=<optimized out>) at ./SessionController.moc:204
#25 0x00007f9e8a46287a in QMetaObject::activate (sender=sender@entry=0x10eb7c0, m=m@entry=0x7f9e6b7f6da0 <Konsole::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#26 0x00007f9e6b58b8e0 in Konsole::Session::started (this=this@entry=0x10eb7c0) at ./Session.moc:317
#27 0x00007f9e6b58ecc9 in Konsole::Session::run (this=0x10eb7c0) at ../../src/Session.cpp:515
#28 0x00007f9e8e765880 in TerminalPanel::showEvent (this=0xa0f000, event=0x7fff0e4c9e70) at ../../../dolphin/src/panels/terminal/terminalpanel.cpp:121
#29 0x00007f9e8ae902b5 in QWidget::event (this=0xa0f000, event=0x7fff0e4c9e70) at kernel/qwidget.cpp:8594
#30 0x00007f9e8ae40e2c in QApplicationPrivate::notify_helper (this=this@entry=0x9745f0, receiver=receiver@entry=0xa0f000, e=e@entry=0x7fff0e4c9e70) at kernel/qapplication.cpp:4567
#31 0x00007f9e8ae474a0 in QApplication::notify (this=this@entry=0x7fff0e4ca210, receiver=receiver@entry=0xa0f000, e=e@entry=0x7fff0e4c9e70) at kernel/qapplication.cpp:4353
#32 0x00007f9e8bb4bcca in KApplication::notify (this=0x7fff0e4ca210, receiver=0xa0f000, event=0x7fff0e4c9e70) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f9e8a44e4dd in QCoreApplication::notifyInternal (this=0x7fff0e4ca210, receiver=receiver@entry=0xa0f000, event=event@entry=0x7fff0e4c9e70) at kernel/qcoreapplication.cpp:953
#34 0x00007f9e8ae8da1f in sendEvent (event=0x7fff0e4c9e70, receiver=0xa0f000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QWidgetPrivate::show_helper (this=0xb21bc0) at kernel/qwidget.cpp:7556
#36 0x00007f9e8ae8d74c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#37 0x00007f9e8ae8d88a in QWidgetPrivate::showChildren (this=this@entry=0xa12d10, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#38 0x00007f9e8ae8d91f in QWidgetPrivate::show_helper (this=0xa12d10) at kernel/qwidget.cpp:7503
#39 0x00007f9e8ae8d74c in QWidgetPrivate::show_recursive (this=<optimized out>) at kernel/qwidget.cpp:7427
#40 0x00007f9e8ae8d88a in QWidgetPrivate::showChildren (this=this@entry=0xaf41d0, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7864
#41 0x00007f9e8ae8d91f in QWidgetPrivate::show_helper (this=this@entry=0xaf41d0) at kernel/qwidget.cpp:7503
#42 0x00007f9e8ae8f6c4 in QWidget::setVisible (this=0xad8c50, visible=<optimized out>) at kernel/qwidget.cpp:7778
#43 0x00007f9e8e720f5c in show (this=<optimized out>) at /usr/include/qt4/QtGui/qwidget.h:497
#44 DolphinApplication::DolphinApplication (this=0x7fff0e4ca210) at ../../../dolphin/src/dolphinapplication.cpp:84
#45 0x00007f9e8e7353ce in kdemain (argc=6, argv=0x7fff0e4ca348) at ../../../dolphin/src/main.cpp:89
#46 0x00007f9e8e341ec5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=6, argv=0x7fff0e4ca348, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0e4ca338) at libc-start.c:287
#47 0x00000000004006fe in _start ()

Possible duplicates by query: bug 349502, bug 345415, bug 344872, bug 340926, bug 339502.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2015-07-07 19:10:53 UTC
Thanks for the bug report. This crash has been fixed already - please upgrade to Dolphin 4.14.3 or later.

*** This bug has been marked as a duplicate of bug 339502 ***