Bug 345833 - crash akonadi_imap_resource after wakeup from standby
Summary: crash akonadi_imap_resource after wakeup from standby
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-03 17:30 UTC by immanuel
Modified: 2017-01-07 12:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description immanuel 2015-04-03 17:30:31 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.0-4-amd64 x86_64
Distribution: Debian GNU/Linux 8.0 (jessie)

-- Information about the crash:
- What I was doing when the application crashed:

IMAP Akonadi ressource crashes after system resume from standby
plain Debian jessie

The crash can be reproduced every time.

-- Backtrace:
Application: GMX Eva vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa0bf7d3780 (LWP 2338))]

Thread 5 (Thread 0x7fa0aa544700 (LWP 4537)):
#0  0x00007fa0bb01450d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa0b9fa1ee4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa0b9fa1ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa0bedecd37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fa0bedbc271 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fa0bedbc5d5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fa0becb0e99 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fa0becb370f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fa0ba68e0a4 in start_thread (arg=0x7fa0aa544700) at pthread_create.c:309
#9  0x00007fa0bb01d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7fa0a37fe700 (LWP 5436)):
#0  0x00007ffd7f3abe5e in clock_gettime ()
#1  0x00007fa0bb029c9d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fa0bed0aa05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007fa0bededb85 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fa0bedec46c in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fa0bedec535 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fa0b9fa145d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fa0b9fa1e0b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fa0b9fa1ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fa0bedecd37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fa0bedbc271 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007fa0bedbc5d5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#12 0x00007fa0becb0e99 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007fa0becb370f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007fa0ba68e0a4 in start_thread (arg=0x7fa0a37fe700) at pthread_create.c:309
#15 0x00007fa0bb01d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fa0a2ffd700 (LWP 14108)):
#0  0x00007ffd7f3abe5e in clock_gettime ()
#1  0x00007fa0bb029c9d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fa0bed0aa05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007fa0bededb85 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fa0bedec46c in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fa0bedec535 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fa0b9fa145d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fa0b9fa1e0b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fa0b9fa1ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fa0bedecd37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fa0bedbc271 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007fa0bedbc5d5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#12 0x00007fa0becb0e99 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007fa0becb370f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007fa0ba68e0a4 in start_thread (arg=0x7fa0a2ffd700) at pthread_create.c:309
#15 0x00007fa0bb01d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fa0aad45700 (LWP 14707)):
#0  0x00007fa0bb0105dd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa0b9fe4f40 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa0b9fa196c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa0b9fa1e83 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa0b9fa1ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa0bedecd37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fa0bedbc271 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fa0bedbc5d5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fa0becb0e99 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fa0becb370f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fa0ba68e0a4 in start_thread (arg=0x7fa0aad45700) at pthread_create.c:309
#11 0x00007fa0bb01d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fa0bf7d3780 (LWP 2338)):
[KCrash Handler]
#6  0x000000000000002f in ?? ()
#7  0x00007fa0bedd17b7 in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x0000000000456845 in SessionPool::killSession (this=this@entry=0x1c3d6e0, session=0x1d3fc10, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:182
#9  0x0000000000456c15 in SessionPool::disconnect (this=0x1c3d6e0, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:115
#10 0x000000000042a94b in ImapResourceBase::startConnect (this=0x1b7ddb0) at ../../../resources/imap/imapresourcebase.cpp:246
#11 0x000000000046ded9 in ImapResourceBase::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_imapresourcebase.cpp:122
#12 0x00007fa0bedc5f5c in QMetaMethod::invoke(QObject*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) const () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007fa0bedc847e in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007fa0bf2cdb9e in ?? () from /usr/lib/libakonadi-kde.so.4
#15 0x00007fa0bf2ce74d in ?? () from /usr/lib/libakonadi-kde.so.4
#16 0x00007fa0bedd6e11 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007fa0be10e48c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#18 0x00007fa0be114fa8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#19 0x00007fa0bc1bc1aa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#20 0x00007fa0bedbd71d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007fa0bedc0fc1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#22 0x00007fa0bedecbd3 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#23 0x00007fa0b9fa1c5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fa0b9fa1f48 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fa0b9fa1ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fa0bedecd1d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007fa0be1b2f96 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#28 0x00007fa0bedbc271 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#29 0x00007fa0bedbc5d5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#30 0x00007fa0bedc2059 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#31 0x00007fa0bf2b9b0c in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#32 0x00000000004189ce in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:193
#33 0x00007fa0baf58b45 in __libc_start_main (main=0x418300 <main(int, char**)>, argc=3, argv=0x7ffd7f34ccb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd7f34cca8) at libc-start.c:287
#34 0x0000000000418874 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 319776, bug 344791.

Possible duplicates by query: bug 344791, bug 340942, bug 340740, bug 335354.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2017-01-07 12:49:49 UTC

*** This bug has been marked as a duplicate of bug 319776 ***