Bug 340942 - Resource crashed after boot
Summary: Resource crashed after boot
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-11-14 00:55 UTC by Shawn Cook
Modified: 2017-01-07 12:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Cook 2014-11-14 00:55:48 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.17.2-200.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
- What I was doing when the application crashed:
Nothing, hadn't even resumed using the computer after signing in.

-- Backtrace:
Application: MGN of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f608f20f8c0 (LWP 2055))]

Thread 2 (Thread 0x7f608389e700 (LWP 2494)):
#0  g_mutex_get_impl (mutex=0x7f607c3e93d0) at gthread-posix.c:126
#1  0x0000003d34c8a599 in g_mutex_lock (mutex=mutex@entry=0x7f607c3e93d0) at gthread-posix.c:213
#2  0x0000003d34c496c8 in g_main_context_iteration (context=0x7f607c3e93d0, may_block=1) at gmain.c:3773
#3  0x0000003d3d5b543e in QEventDispatcherGlib::processEvents (this=0x7f607c010db0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x0000003d3d58538f in QEventLoop::processEvents (this=this@entry=0x7f608389dd10, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003d3d5856dd in QEventLoop::exec (this=this@entry=0x7f608389dd10, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003d3d479e5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#7  0x0000003d3d47c69f in QThreadPrivate::start (arg=0x1d56b40) at thread/qthread_unix.cpp:349
#8  0x0000003d32c07ee5 in start_thread (arg=0x7f608389e700) at pthread_create.c:309
#9  0x0000003d320f4b8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f608f20f8c0 (LWP 2055)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x0000003d3d59a47b in QObject::disconnect (sender=0x1e8ca60, signal=0x1e62479 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x47e548 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0x1e3d9b0, method=0x1e09909 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x47e500 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2911
#8  0x0000000000451515 in SessionPool::killSession (this=this@entry=0x1e3d9b0, session=0x1e8ca60, termination=termination@entry=SessionPool::LogoutSession) at /usr/src/debug/kdepim-runtime-4.14.2/resources/imap/sessionpool.cpp:182
#9  0x00000000004518e5 in SessionPool::disconnect (this=0x1e3d9b0, termination=termination@entry=SessionPool::LogoutSession) at /usr/src/debug/kdepim-runtime-4.14.2/resources/imap/sessionpool.cpp:115
#10 0x0000000000428bdb in ImapResourceBase::startConnect (this=0x1e01a40) at /usr/src/debug/kdepim-runtime-4.14.2/resources/imap/imapresourcebase.cpp:246
#11 0x0000000000466b89 in ImapResourceBase::qt_static_metacall (_o=_o@entry=0x1e01a40, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=14, _a=_a@entry=0x7fffb60f9380) at /usr/src/debug/kdepim-runtime-4.14.2/x86_64-redhat-linux-gnu/resources/imap/moc_imapresourcebase.cpp:122
#12 0x0000003d3d58ec58 in QMetaMethod::invoke (this=this@entry=0x7fffb60f9570, object=object@entry=0x1e01a40, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#13 0x0000003d3d591362 in QMetaObject::invokeMethod (obj=0x1e01a40, member=<optimized out>, type=type@entry=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#14 0x00000032f939bdcf in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=<optimized out>, obj=<optimized out>) at /usr/include/QtCore/qobjectdefs.h:434
#15 Akonadi::ResourceScheduler::executeNext (this=0x1e3c3c0) at /usr/src/debug/kdepimlibs-4.14.2/akonadi/resourcescheduler.cpp:348
#16 0x00000032f939c97d in Akonadi::ResourceScheduler::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepimlibs-4.14.2/x86_64-redhat-linux-gnu/akonadi/moc_resourcescheduler_p.cpp:101
#17 0x0000003d3d59f90e in QObject::event (this=0x1e3c3c0, e=<optimized out>) at kernel/qobject.cpp:1222
#18 0x0000003c9adcae5c in QApplicationPrivate::notify_helper (this=this@entry=0x1c70010, receiver=receiver@entry=0x1e3c3c0, e=e@entry=0x1e328c0) at kernel/qapplication.cpp:4565
#19 0x0000003c9add17b5 in QApplication::notify (this=this@entry=0x7fffb60fa1d0, receiver=receiver@entry=0x1e3c3c0, e=e@entry=0x1e328c0) at kernel/qapplication.cpp:4351
#20 0x0000003f7664a53a in KApplication::notify (this=0x7fffb60fa1d0, receiver=0x1e3c3c0, event=0x1e328c0) at /usr/src/debug/kdelibs-4.14.2/kdeui/kernel/kapplication.cpp:311
#21 0x0000003d3d5868fd in QCoreApplication::notifyInternal (this=0x7fffb60fa1d0, receiver=receiver@entry=0x1e3c3c0, event=event@entry=0x1e328c0) at kernel/qcoreapplication.cpp:953
#22 0x0000003d3d589ae5 in sendEvent (event=0x1e328c0, receiver=0x1e3c3c0) at kernel/qcoreapplication.h:231
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1c2f7e0) at kernel/qcoreapplication.cpp:1577
#24 0x0000003d3d589f83 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#25 0x0000003d3d5b5c9e in sendPostedEvents () at kernel/qcoreapplication.h:236
#26 postEventSourceDispatch (s=s@entry=0x1c5ee40) at kernel/qeventdispatcher_glib.cpp:300
#27 0x0000003d34c492a6 in g_main_dispatch (context=0x1c616a0) at gmain.c:3066
#28 g_main_context_dispatch (context=context@entry=0x1c616a0) at gmain.c:3642
#29 0x0000003d34c49628 in g_main_context_iterate (context=context@entry=0x1c616a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
#30 0x0000003d34c496dc in g_main_context_iteration (context=0x1c616a0, may_block=1) at gmain.c:3774
#31 0x0000003d3d5b541e in QEventDispatcherGlib::processEvents (this=0x1c31060, flags=...) at kernel/qeventdispatcher_glib.cpp:450
#32 0x0000003c9ae6cc46 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#33 0x0000003d3d58538f in QEventLoop::processEvents (this=this@entry=0x7fffb60fa140, flags=...) at kernel/qeventloop.cpp:149
#34 0x0000003d3d5856dd in QEventLoop::exec (this=this@entry=0x7fffb60fa140, flags=...) at kernel/qeventloop.cpp:204
#35 0x0000003d3d58ada9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#36 0x0000003c9adc94dc in QApplication::exec () at kernel/qapplication.cpp:3823
#37 0x00000032f938aa8c in Akonadi::ResourceBase::init (r=r@entry=0x1e01a40) at /usr/src/debug/kdepimlibs-4.14.2/akonadi/resourcebase.cpp:579
#38 0x0000000000418a53 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/kde4/akonadi/resourcebase.h:193
#39 0x0000003d32021d65 in __libc_start_main (main=0x418390 <main(int, char**)>, argc=3, argv=0x7fffb60fa2e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb60fa2d8) at libc-start.c:285
#40 0x0000000000418905 in _start ()

Possible duplicates by query: bug 340740, bug 335354.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2017-01-07 12:49:55 UTC

*** This bug has been marked as a duplicate of bug 319776 ***