Bug 344791 - Crash after wake up
Summary: Crash after wake up
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-03 17:57 UTC by ali.sherif10
Modified: 2017-01-07 12:50 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of crash (23.01 KB, text/plain)
2015-03-19 17:13 UTC, Anssi Saari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ali.sherif10 2015-03-03 17:57:09 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.1
Qt Version: 4.8.6
Operating System: Linux 3.16.0-31-generic x86_64
Distribution: Ubuntu 14.10

-- Information about the crash:
- What I was doing when the application crashed:
I waked it up from sleep and continued using Firefox.

-- Backtrace:
Application: Yahoo! Mail (ali.sherif10) of type  (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa546c528c0 (LWP 4330))]

Thread 2 (Thread 0x7fa52bfff700 (LWP 5643)):
#0  0x00007fa54252384d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa54149fee4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa54149fffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa54626504e in QEventDispatcherGlib::processEvents (this=0x7fa5200116f0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007fa5462364f1 in QEventLoop::processEvents (this=this@entry=0x7fa52bffed20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa546236805 in QEventLoop::exec (this=this@entry=0x7fa52bffed20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa546134c39 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#7  0x00007fa54613739f in QThreadPrivate::start (arg=0xd2d460) at thread/qthread_unix.cpp:349
#8  0x00007fa541b8a0a5 in start_thread (arg=0x7fa52bfff700) at pthread_create.c:309
#9  0x00007fa54252dcfd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fa546c528c0 (LWP 4330)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fa54624ab35 in QObject::disconnect (sender=0xb4ce50, signal=0xc1cde9 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x489088 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0xcdfa80, method=0xcdb149 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x489040 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2911
#8  0x0000000000457615 in SessionPool::killSession (this=this@entry=0xcdfa80, session=0xb4ce50, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:182
#9  0x00000000004579e5 in SessionPool::disconnect (this=0xcdfa80, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:115
#10 0x000000000043406b in ImapResourceBase::doSetOnline (this=0xc762e0, online=<optimized out>) at ../../../resources/imap/imapresourcebase.cpp:575
#11 0x00007fa546631407 in Akonadi::AgentBase::setOnlineInternal(bool) () from /usr/lib/libakonadi-kde.so.4
#12 0x00007fa54663160d in Akonadi::AgentBase::setTemporaryOffline(int) () from /usr/lib/libakonadi-kde.so.4
#13 0x000000000043168e in ImapResourceBase::onConnectDone (this=0xc762e0, errorCode=<optimized out>, errorString=...) at ../../../resources/imap/imapresourcebase.cpp:314
#14 0x000000000046eb07 in ImapResourceBase::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_imapresourcebase.cpp:123
#15 0x00007fa54624ba7a in QMetaObject::activate (sender=sender@entry=0xcdfa80, m=m@entry=0x4901c0 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff540e5510) at kernel/qobject.cpp:3567
#16 0x000000000046f064 in SessionPool::connectDone (this=this@entry=0xcdfa80, _t1=_t1@entry=8, _t2=...) at moc_sessionpool.cpp:160
#17 0x00000000004586fe in SessionPool::cancelSessionCreation (this=this@entry=0xcdfa80, session=<optimized out>, errorCode=errorCode@entry=8, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:247
#18 0x0000000000458b58 in SessionPool::onLoginDone (this=0xcdfa80, job=0xd4fb40) at ../../../resources/imap/sessionpool.cpp:372
#19 0x000000000046f13c in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_sessionpool.cpp:94
#20 0x00007fa54624ba7a in QMetaObject::activate (sender=sender@entry=0xd4fb40, m=m@entry=0x7fa543466f20 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff540e5830) at kernel/qobject.cpp:3567
#21 0x00007fa5430c6442 in KJob::result (this=this@entry=0xd4fb40, _t1=_t1@entry=0xd4fb40) at ./kjob.moc:207
#22 0x00007fa5430c6490 in KJob::emitResult (this=0xd4fb40) at ../../kdecore/jobs/kjob.cpp:318
#23 0x00007fa543e649df in KIMAP::LoginJob::connectionLost() () from /usr/lib/libkimap.so.4
#24 0x00007fa543e7140a in KIMAP::SessionPrivate::clearJobQueue() () from /usr/lib/libkimap.so.4
#25 0x00007fa54624ff41 in QObject::event (this=0xcba000, e=<optimized out>) at kernel/qobject.cpp:1222
#26 0x00007fa5455c411c in QApplicationPrivate::notify_helper (this=this@entry=0xb4b2d0, receiver=receiver@entry=0xcba000, e=e@entry=0x7fa520011340) at kernel/qapplication.cpp:4570
#27 0x00007fa5455ca870 in QApplication::notify (this=this@entry=0x7fff540e5f00, receiver=receiver@entry=0xcba000, e=e@entry=0x7fa520011340) at kernel/qapplication.cpp:4356
#28 0x00007fa5436a457a in KApplication::notify (this=0x7fff540e5f00, receiver=0xcba000, event=0x7fa520011340) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fa54623786d in QCoreApplication::notifyInternal (this=0x7fff540e5f00, receiver=receiver@entry=0xcba000, event=event@entry=0x7fa520011340) at kernel/qcoreapplication.cpp:953
#30 0x00007fa54623af41 in sendEvent (event=0x7fa520011340, receiver=0xcba000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xb1d0c0) at kernel/qcoreapplication.cpp:1577
#32 0x00007fa54623b3d3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#33 0x00007fa546264ed3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 postEventSourceDispatch (s=0xb49770) at kernel/qeventdispatcher_glib.cpp:287
#35 0x00007fa54149fc5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007fa54149ff48 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fa54149fffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007fa54626504e in QEventDispatcherGlib::processEvents (this=0xb4e670, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#39 0x00007fa5456674e6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fa5462364f1 in QEventLoop::processEvents (this=this@entry=0x7fff540e5e90, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007fa546236805 in QEventLoop::exec (this=this@entry=0x7fff540e5e90, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007fa54623bf67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#43 0x00007fa54672929c in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#44 0x00000000004189fe in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:193
#45 0x00007fa542455ec5 in __libc_start_main (main=0x418300 <main(int, char**)>, argc=3, argv=0x7fff540e6018, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff540e6008) at libc-start.c:287
#46 0x00000000004188a4 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 340942.

Possible duplicates by query: bug 340942, bug 340740, bug 335354.

Reproducible: Didn't try




There is a problem with Kubuntu 14.10, which prevents login in the reporter to report bugs, so I made this report.
Comment 1 ali.sherif10 2015-03-11 21:52:49 UTC
It may be a duplicate of bug 345032.

*** This bug has been marked as a duplicate of bug 345032 ***
Comment 2 Daniel Vrátil 2015-03-18 10:47:22 UTC
Not a duplicate by any chance ;) IMAP resources does not talk to KScreen at all.
Comment 3 Anssi Saari 2015-03-19 17:13:28 UTC
Created attachment 91642 [details]
Backtrace of crash
Comment 4 Anssi Saari 2015-03-19 17:15:00 UTC
It seems I had the same or at least a very similar crash on an IMAP account this morning. Just waking up from suspend to ram. Other three IMAP accounts kept going, just one of them crashed. I attached a backtrace which incidentally proposes this bug as a duplicate... Also 340942, 340740, 335354.
Comment 5 Daniel Vrátil 2017-01-07 12:50:07 UTC

*** This bug has been marked as a duplicate of bug 319776 ***