Bug 335225 - akonadi crash
Summary: akonadi crash
Status: RESOLVED DUPLICATE of bug 322518
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-22 21:46 UTC by ericfalcon
Modified: 2014-05-22 22:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ericfalcon 2014-05-22 21:46:50 UTC
Application: nepomukbaloomigrator (1.0)
KDE Platform Version: 4.13.0
Qt Version: 4.8.6
Operating System: Linux 3.13.0-24-generic i686
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
When i want to start the system, akonadi, kcminit and an other soft bug, when i restart it the same

The crash can be reproduced every time.

-- Backtrace:
Application: NepomukBalooMigrator (nepomukbaloomigrator), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#7  0xb77c1424 in __kernel_vsyscall ()
#8  0xb5e43827 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb5e46c53 in __GI_abort () at abort.c:89
#10 0xb5e7e993 in __libc_message (do_abort=do_abort@entry=1, fmt=fmt@entry=0xb5f7ba5c "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
#11 0xb5e88e7a in malloc_printerr (action=<optimized out>, str=0xb5f7756d "free(): invalid pointer", ptr=0x8050340 <QString::shared_null>) at malloc.c:4996
#12 0xb5e89aed in _int_free (av=0xb5fc0420 <main_arena>, p=<optimized out>, have_lock=0) at malloc.c:3840
#13 0xb610c86b in qFree (ptr=ptr@entry=0x8050340 <QString::shared_null>) at global/qmalloc.cpp:60
#14 0xb6161af8 in QString::free (d=0x8050340 <QString::shared_null>) at tools/qstring.cpp:1235
#15 0xb751117f in ~QString (this=0x84c06a4, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qstring.h:880
#16 ~PixmapWithPath (this=0x84c0698, __in_chrg=<optimized out>) at ../../kdeui/icons/kiconloader.cpp:84
#17 clear (this=<optimized out>) at /usr/include/qt4/QtCore/qcache.h:139
#18 ~QCache (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qcache.h:103
#19 ~KIconLoaderPrivate (this=0x8445a50, __in_chrg=<optimized out>) at ../../kdeui/icons/kiconloader.cpp:168
#20 KIconLoader::~KIconLoader (this=0x8445bf8, __in_chrg=<optimized out>) at ../../kdeui/icons/kiconloader.cpp:558
#21 0xb75112cc in KIconLoader::~KIconLoader (this=0x8445bf8, __in_chrg=<optimized out>) at ../../kdeui/icons/kiconloader.cpp:559
#22 0xb750a6f2 in destroy () at ../../kdeui/icons/kiconloader.cpp:1625
#23 0xb74aca39 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0xb77a02a8 <._203::operator->()::cleanUpObject>, __in_chrg=<optimized out>) at ../../kdecore/kernel/kglobal.h:62
#24 0xb5e483d1 in __run_exit_handlers (status=status@entry=0, listp=0xb5fc03c4 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#25 0xb5e4842d in __GI_exit (status=0) at exit.c:104
#26 0xb5e2ea8b in __libc_start_main (main=0x804ac90 <main(int, char**)>, argc=1, argv=0xbff291d4, init=0x804d850 <__libc_csu_init>, fini=0x804d8c0 <__libc_csu_fini>, rtld_fini=0xb77d1180 <_dl_fini>, stack_end=0xbff291cc) at libc-start.c:321
#27 0x0804af80 in _start ()

Possible duplicates by query: bug 335224, bug 333332, bug 333327, bug 333253, bug 328917.

Reported using DrKonqi
Comment 1 Christoph Feck 2014-05-22 22:32:56 UTC

*** This bug has been marked as a duplicate of bug 322518 ***