Bug 333253 - kwallet crash
Summary: kwallet crash
Status: RESOLVED DUPLICATE of bug 333332
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kwallet (show other bugs)
Version: 0.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-04-09 23:49 UTC by rvdwel
Modified: 2014-04-13 08:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rvdwel 2014-04-09 23:49:54 UTC
Application: kwalletd (0.2)
KDE Platform Version: 4.12.97 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 3.11.0-20-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
- Unusual behavior I noticed:wifi asked for key and the key was in the wallet but after update wallet keep crashing

- Custom settings of the application:

-- Backtrace:
Application: KWallet portefeuilledienst (kwalletd), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#7  0xb77d9424 in __kernel_vsyscall ()
#8  0xb7602aff in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb7606083 in __GI_abort () at abort.c:90
#10 0xb763fa95 in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0xb77430d0 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:199
#11 0xb764a7c2 in malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x9caa4a0) at malloc.c:4923
#12 0xb764b510 in _int_free (av=0xb7784440 <main_arena>, p=0x9caa498, have_lock=0) at malloc.c:3779
#13 0xb6b8684b in qFree (ptr=ptr@entry=0x9caa4a0) at global/qmalloc.cpp:60
#14 0xb6bdbae8 in QString::free (d=0x9caa4a0) at tools/qstring.cpp:1235
#15 0xb6e358c8 in ~QString (this=0x9cadeb8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qstring.h:880
#16 ~QHashNode (this=0x9cadeb0, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:216
#17 QHash<QString, QDBusSlotCache::Data>::deleteNode2 (node=0x9cadeb0) at ../../include/QtCore/../../src/corelib/tools/qhash.h:521
#18 0xb6baaecc in QHashData::free_helper (this=0x9cadd78, node_delete=node_delete@entry=0xb6e35890 <QHash<QString, QDBusSlotCache::Data>::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:275
#19 0xb6e3537c in freeData (this=<optimized out>, x=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:570
#20 ~QHash (this=0x9caa398, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:283
#21 ~QMultiHash (this=0x9caa398, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:924
#22 ~QDBusSlotCache (this=0x9caa398, __in_chrg=<optimized out>) at qdbusintegrator_p.h:81
#23 qMetaTypeDeleteHelper<QDBusSlotCache> (t=t@entry=0x9caa398) at ../../include/QtCore/../../src/corelib/kernel/qmetatype.h:134
#24 0xb6cac921 in QMetaType::destroy (type=281, data=0x9caa398) at kernel/qmetatype.cpp:1397
#25 0xb6cc5960 in clear (d=0x9cc74a8) at kernel/qvariant.cpp:290
#26 0xb61ec473 in clear (d=0x9cc74a8) at kernel/qguivariant.cpp:280
#27 0xb6cc2faa in QVariant::clear (this=this@entry=0x9cc74a8) at kernel/qvariant.cpp:1876
#28 0xb6cc4596 in QVariant::operator= (this=0x9cc74a8, variant=...) at kernel/qvariant.cpp:1809
#29 0xb6cbb0d9 in QObject::setProperty (this=this@entry=0x9c953e8, name=name@entry=0xb6e6f342 <QDBusConnectionPrivate::activateCall(QObject*, int, QDBusMessage const&)::cachePropertyName> "_qdbus_slotCache", value=...) at kernel/qobject.cpp:3713
#30 0xb6e2f458 in QDBusConnectionPrivate::activateCall (this=0x9ba9f58, object=0x9c953e8, flags=273, msg=...) at qdbusintegrator.cpp:853
#31 0xb6e2fb97 in QDBusConnectionPrivate::activateObject (this=0x9ba9f58, node=..., msg=..., pathStartPos=17) at qdbusintegrator.cpp:1427
#32 0xb6e2ff78 in QDBusActivateObjectEvent::placeMetaCall (this=0x9cac578) at qdbusintegrator.cpp:1541
#33 0xb6cb96eb in QObject::event (this=0xbfd1f3f8, e=0x9cac578) at kernel/qobject.cpp:1194
#34 0xb61ac7f4 in QApplicationPrivate::notify_helper (this=0x9bb1278, receiver=0xbfd1f3f8, e=0x9cac578) at kernel/qapplication.cpp:4567
#35 0xb61b32d3 in QApplication::notify (this=0xbfd1f3e8, receiver=receiver@entry=0xbfd1f3f8, e=e@entry=0x9cac578) at kernel/qapplication.cpp:4353
#36 0xb73951e4 in KApplication::notify (this=0xbfd1f3e8, receiver=0xbfd1f3f8, event=0x9cac578) at ../../kdeui/kernel/kapplication.cpp:311
#37 0xb6c9fe3a in QCoreApplication::notifyInternal (this=0xbfd1f3e8, receiver=receiver@entry=0xbfd1f3f8, event=event@entry=0x9cac578) at kernel/qcoreapplication.cpp:953
#38 0xb6ca36fd in sendEvent (event=0x9cac578, receiver=0xbfd1f3f8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x9b87fa0) at kernel/qcoreapplication.cpp:1577
#40 0xb6ca3c0c in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#41 0xb6cd01de in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#42 postEventSourceDispatch (s=0x9bb0eb0) at kernel/qeventdispatcher_glib.cpp:280
#43 0xb58b383e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#44 0xb58b3be8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#45 0xb58b3ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0xb6ccf9cf in QEventDispatcherGlib::processEvents (this=this@entry=0x9b88b38, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#47 0xb62615fe in QGuiEventDispatcherGlib::processEvents (this=0x9b88b38, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0xb6c9e813 in QEventLoop::processEvents (this=this@entry=0xbfd1f318, flags=...) at kernel/qeventloop.cpp:149
#49 0xb6c9eb39 in QEventLoop::exec (this=this@entry=0xbfd1f318, flags=...) at kernel/qeventloop.cpp:204
#50 0xb6ca48ee in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#51 0xb61aaa24 in QApplication::exec () at kernel/qapplication.cpp:3828
#52 0xb77b10a9 in kdemain (argc=1, argv=0xbfd1f534) at ../../kwalletd/main.cpp:191
#53 0x0804855b in main (argc=1, argv=0xbfd1f534) at kwalletd_dummy.cpp:3

Possible duplicates by query: bug 328917, bug 322518, bug 321465, bug 320526, bug 320128.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-04-13 08:18:23 UTC

*** This bug has been marked as a duplicate of bug 333332 ***