Bug 333332 - Kwallet crashes when used
Summary: Kwallet crashes when used
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kwallet (show other bugs)
Version: 0.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords: drkonqi
: 333253 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-11 18:59 UTC by Alan Dacey Sr.
Modified: 2014-04-22 19:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Dacey Sr. 2014-04-11 18:59:00 UTC
Application: kwalletd (0.2)
KDE Platform Version: 4.12.97
Qt Version: 4.8.4
Operating System: Linux 3.11.0-20-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: 
  Booted my machine, Kontact auto starts and needs kwallet for my passwords.
-Other information:
  Starting kwalletmanager from the terminal right after crash brings up an empty kwallet window.
  Manually killing kwalletd then starting kwalletmanager shows my wallets and I can use them.  When this is open and the wallet is read by Kontact, kwalletd crashes for every password fetched.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Wallet Service (kwalletd), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fe362c02f77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fe362c065e8 in __GI_abort () at abort.c:90
#8  0x00007fe362c404fb in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7fe362d54240 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:199
#9  0x00007fe362c4c996 in malloc_printerr (ptr=0x2656ac0, str=0x7fe362d50205 "free(): invalid pointer", action=3) at malloc.c:4923
#10 _int_free (av=<optimized out>, p=0x2656ab0, have_lock=0) at malloc.c:3779
#11 0x00007fe3617dddc4 in node_destruct (this=<optimized out>, to=<optimized out>, from=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:431
#12 free (this=<optimized out>, data=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:757
#13 QList<QVariant>::~QList (this=0x108d, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:732
#14 0x00007fe3617f20bf in QDBusMessage::~QDBusMessage (this=0x108d, __in_chrg=<optimized out>) at qdbusmessage.cpp:537
#15 0x00007fe362fae740 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwalletd.so
#16 0x00007fe362faf375 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwalletd.so
#17 0x00007fe361475dce in QObject::event (this=0x7fff745edbc0, e=<optimized out>) at kernel/qobject.cpp:1194
#18 0x00007fe3607fadfc in QApplicationPrivate::notify_helper (this=this@entry=0x25482c0, receiver=receiver@entry=0x7fff745edbc0, e=e@entry=0x2615350) at kernel/qapplication.cpp:4567
#19 0x00007fe360801470 in QApplication::notify (this=this@entry=0x7fff745edba0, receiver=receiver@entry=0x7fff745edbc0, e=e@entry=0x2615350) at kernel/qapplication.cpp:4353
#20 0x00007fe3627a6d5a in KApplication::notify (this=0x7fff745edba0, receiver=0x7fff745edbc0, event=0x2615350) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007fe36145d8bd in QCoreApplication::notifyInternal (this=0x7fff745edba0, receiver=receiver@entry=0x7fff745edbc0, event=event@entry=0x2615350) at kernel/qcoreapplication.cpp:946
#22 0x00007fe361460e1f in sendEvent (event=0x2615350, receiver=0x7fff745edbc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x25051d0) at kernel/qcoreapplication.cpp:1570
#24 0x00007fe3614612c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#25 0x00007fe36148b093 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#26 postEventSourceDispatch (s=0x2530fc0) at kernel/qeventdispatcher_glib.cpp:286
#27 0x00007fe35d1b03b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe35d1b0708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fe35d1b07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fe36148a9d1 in QEventDispatcherGlib::processEvents (this=0x2506690, flags=...) at kernel/qeventdispatcher_glib.cpp:433
#31 0x00007fe36089c9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007fe36145c5ef in QEventLoop::processEvents (this=this@entry=0x7fff745eda70, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fe36145c8e5 in QEventLoop::exec (this=this@entry=0x7fff745eda70, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fe361461e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#35 0x00007fe362fa4486 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwalletd.so
#36 0x00007fe362bedde5 in __libc_start_main (main=0x4006d0, argc=1, ubp_av=0x7fff745edd98, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff745edd88) at libc-start.c:260
#37 0x00000000004006fe in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 333253.

Possible duplicates by query: bug 333327, bug 333253, bug 328917, bug 322518, bug 321465.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-04-13 08:18:23 UTC
*** Bug 333253 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2014-04-20 12:31:23 UTC
Could you please check if this still happens with the Ubuntu 14.04 release or KDE SC 4.13.0?
Comment 3 Alan Dacey Sr. 2014-04-21 22:08:36 UTC
I just upgraded to Kubuntu 14.04, KDE 4.13, and I do not yet see the same bug.

The wallet daemon problem didn't always happen every time, all the time on different reboots though - just enough to make using kmail and such difficult.  Killing all instances of the daemon via the command line made it usable.

I will update if I run into the bug again.


--
Alan

On Sunday, April 20, 2014 12:31:23 PM you wrote:
> https://bugs.kde.org/show_bug.cgi?id=333332
> 
> Christoph Feck <christoph@maxiom.de> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |christoph@maxiom.de
> 
> --- Comment #2 from Christoph Feck <christoph@maxiom.de> ---
> Could you please check if this still happens with the Ubuntu 14.04 release or
> KDE SC 4.13.0?
> 
>
Comment 4 rvdwel 2014-04-21 22:22:00 UTC
For me the problem is gone with the upgrade to 14.04, KDE 4.13
Comment 5 Christoph Feck 2014-04-22 19:24:42 UTC
Thanks for the update. Closing.