Bug 334847 - When reaching the last image and trying to view next, an unergonomic menu is shown
Summary: When reaching the last image and trying to view next, an unergonomic menu is ...
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.13.0
Platform: unspecified Linux
: HI normal with 65 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
: 337365 366748 416367 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-15 22:58 UTC by Alexandre Bonneau
Modified: 2021-06-03 14:16 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.08


Attachments
Remove the annoying useless modal dialog that's displayed when navigating past a folder; instead, just wrap. (1.35 KB, patch)
2015-03-06 06:57 UTC, FeepingCreature
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Bonneau 2014-05-15 22:58:01 UTC
Using 4.13, Gwenview has a regression ;
1) Browse a folder with some images with the keyboard (I assigned 'next' to 'right arrow' and 'previous' to 'left arrow'),
2) when reaching the last image, try to view next by using the keyboard shortcut,
3) an unergonomic and obstrusive half-transparent black menu is shown in the middle of the screen "You reached the last document, what do you want to do?" with 3 buttons :
- "Stay here"
- "Go to the first document"
- "Go back to the document list"
...and no way to access those buttons with the keyboard and `tab` ; you _must_ use the mouse..

This is a really badly-designed feature (ergonomicaly speaking).

My point of view is for each of those 3 buttons :
- Stay here : this is totally useless, if you want to 'stay here' you should be able to cancel that modal menu with 'Escape' for instance
- Go to the first document : this was the default behavior, which was way better (more on this later)
- Go back to the document list : useless again ; Gwenview should add a default shortcut to go to the navigation list (I binded 'Esc' which works well and is logical)

So, when you arrive at the end of a folder, you should either :
- Jump to the first image like before with a message telling you this is what just happened (and of course, if that was a mistake from the user, he could still logically use the 'Previous' shortcut to go back to where he was seconds ago (or use the timed non-modal and non-obstrusive message "Go back to the previous document" shown in the last version of Gwenview))
OR
- Stay stuck on the last image of that folder (with a timed non-modal and non-obstrusive message saying "You have reached the last document").
Either way is good, and should be configurable (eg: [x] Loop in the current directory when reaching the end of the image list), with looping activated by default.
Also, Gwenview should also add some default shortcuts to make the user's like easier :
- Next : Left arrow
- Previous : Right arrow
- Browse : Escape
- Zoom to fit : Space

Reproducible: Always
Comment 1 Syam 2014-10-29 01:28:50 UTC
I agree with the report. This 'options list' is only an annoyance and does not add any real value. It is inconvenient (see bug #337365), difficult to manipulate and cannot be dismissed with an 'Esc'.

The simplest thing would have been either staying there or looping over with a configurable setting.
Comment 2 FeepingCreature 2015-03-06 04:45:48 UTC
I concur. Please make this optional.

In the meantime, anybody know how to patch it out?
Comment 3 FeepingCreature 2015-03-06 06:57:20 UTC
Created attachment 91445 [details]
Remove the annoying useless modal dialog that's displayed when navigating past a folder; instead, just wrap.

I made one!
Comment 4 Alexandre Bonneau 2015-03-27 10:59:31 UTC
Nice workaround !

Let's hope this issue gets some traction to make users' life easier :)
Comment 5 Shriramana Sharma 2015-06-28 11:48:30 UTC
Hmmm. A little history:

1) Wrapping was first introduced as requested in bug #211892.

2) Somebody wanted to know how to turn it off: https://forum.kde.org/viewtopic.php?f=213&t=119049 since they didn't like it. Developer concurs that he didn't like it personally. Not much thought seems to have been given to whether others like it or not, such as for example the reporter of bug #211892 upon whose request the wrap was introduced in the first place by the same developer.

3) So developer apparently just turned it off or something: https://git.reviewboard.kde.org/r/115020/.

4) But now it is showing a dialog *everytime* which is furthermore unergonomic and multiply stacked as others have pointed out.

IMHO asking the user every time what they want to do (*and* doing that unergonomically), or hard-coding either kind of behaviour (to wrap or not to wrap) is totally against KDE experience of making choices available and remembering them. Make an entry available in the Configure Gwenview window letting users set the preference to whether wrap or not as per their individual taste/requirement. That's all.

My sincere thanks to the developers for their hard work on this software! I just want to see it be even better.
Comment 6 Nate Graham 2017-09-08 20:01:47 UTC
*** Bug 337365 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2017-09-08 20:01:59 UTC
*** Bug 366748 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2017-09-08 20:04:04 UTC
Wrap seems to have been removed entirely as of Gwenview 16.x, so I guess this is "fixed"?
 If folks want wrap back--without the unergonomic menu--a new bug would be desirable, along with the patch from this one.
Comment 9 FeepingCreature 2017-09-09 08:05:17 UTC
Wrap code is still in Github. Maybe whatever distro you are using patches it out?

https://github.com/KDE/gwenview/blob/master/app/mainwindow.cpp#L1617
Comment 10 Nate Graham 2017-09-09 13:15:36 UTC
Hmm, I also tested in up-to-date KDE Neon. Can you or anyone else reproduce there?
Comment 11 Nate Graham 2017-11-28 05:07:42 UTC
Found it. You need to hit the space bar on the last image. The arrow keys don't activate wrap. That's another issue: https://bugs.kde.org/show_bug.cgi?id=387380
Comment 12 Nate Graham 2017-11-28 19:40:29 UTC
I've submitted a patch that fixes this: https://phabricator.kde.org/D9039
Comment 13 Syam 2019-02-06 00:51:58 UTC
This problem is still there with Gwenview v18.04.3.
KDE Frameworks 5.54.0
Qt 5.11.3 (built against 5.11.3)
Comment 14 Nate Graham 2020-01-17 20:37:19 UTC
*** Bug 416367 has been marked as a duplicate of this bug. ***
Comment 15 ferweer 2020-01-18 03:33:57 UTC
I apologize for posting the duplicate first, sorry. Bug 416367 was added as a duplicate. 
This continues to happen on both Kubuntu 19.04 and 19.10, and it's surprising that this has happened for solong.
I will commend those who are working on fixing this. I don't know why the fix https://phabricator.kde.org/D9039 for this is not yet added to gwenview.
However, a bug ticket may occur until the option is added. I hope that the fix will be added quickly for those who do this.
Comment 16 FeepingCreature 2020-01-18 13:44:26 UTC
Just saw the comment on phabricator that this is necessary to hint to users how to exit fullscreen. Apropos of nothing, and since I seem to have lost my identity login somehow, let me note that I run gwenview with two patches: first, one that disables the menu in favor of always wrapping, and second one that switches to image view when fullscreening and list view when unfullscreening.

I cannot imagine using gwenview without these patches. It would be near useless to me.
Comment 17 ferweer 2020-02-01 06:27:21 UTC
The problem is that you can't apply this fix except by applying a patch.
Regular users will not post bugs to the bug tracker.
Also, even if you can post it, you may not know how to apply the patch.
Then, this is just a recognition that ordinary users are just Image viewer that keep displaying difficult-to-use dialogs.
Comment 18 Nate Graham 2021-06-03 14:16:45 UTC
Fixed by Marco Martin with https://invent.kde.org/graphics/gwenview/-/commit/736ef0445944ab87c22958f1fdfbfd70f5268884. You can now disable the menu entirely if you want, and by default it only appears in slideshows. And even when visible, you can press the arrow key to wrap anyway, totally ignoring it.