Bug 366748 - The "You reached the first/last picture" overlay cannot be closed with the keyboard
Summary: The "You reached the first/last picture" overlay cannot be closed with the ke...
Status: RESOLVED DUPLICATE of bug 334847
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 5.0.0
Platform: Gentoo Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-14 10:20 UTC by Frank Steinmetzger
Modified: 2017-09-08 20:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2016-08-14 10:20:05 UTC
When walking through the images in a directory in view mode, Gwenview shows an overlay popup which tells me that I reached it and offers me 3 actions to click. But I cannot close it with the keyboard. When I press Esc out of reflex, I close the image right away.

I could even live without the overlay entirely. An option to not show it would be nice. :)

Reproducible: Always

Steps to Reproduce:
View the last image in a directory. Press the key to move to the next image. The overlay is shown. Now I simply want it to go away, but stay with the image view.

Actual Results:  
I must move my hand to the mouse in order to close the overlay. Any keyboard solution I know of involves leaving the image and coming back to it in a second step.

Expected Results:  
Even though it is not technically a popup, because it doesn't use standard dialog widgets, it still behaves like on by popping up automatically. It should therefore react to input like a normal popup.

Gwenview 4 has also been affected for a long time (well, since the beginning I suppose). But I assume it won't be fixed anymore, right?

BTW: The overlay is repainted every time I repeat the action which causes it. I.o.w., when I am at the last image, the overlay is drawn every time I press the Next image key, causing the semi-transparent background of the overlay to become more and more opaque.
Comment 1 Nate Graham 2017-09-08 20:01:59 UTC

*** This bug has been marked as a duplicate of bug 334847 ***