Bug 33372 - make GnuPG/PGP non-blocking
Summary: make GnuPG/PGP non-blocking
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.3.2
Platform: Debian testing Linux
: NOR wishlist with 86 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 30269 55412 58501 75030 81205 93843 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-10-06 15:03 UTC by Eray Ozkural
Modified: 2009-08-20 00:49 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Mail on which KMail blocks (5.19 KB, text/plain)
2007-02-17 22:45 UTC, Marcin Juszkiewicz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eray Ozkural 2001-10-06 14:48:06 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           1.3.2 (using KDE 2.2.1 )
Severity:          normal
Installed from:    Debian Package 4:2.2.1-5 (testing/unstable)
Compiler:          gcc version 2.95.4 20010902 (Debian prerelease)
OS:                Linux (i686) release 2.4.7
OS/Compiler notes: 

When the following message arrived in my mail box kmail stalled and remained like that. When I disabled using GPG as an encryption tool  (no encryption tool option) the problem went away.

I've seen that a similar bug (signed mail hangs kmail) has been reported and marked done however the bug may have resurfaced in a different form.

I've tried to verify the signature outside the kmail program with the standalone message in a file. The problem is that my GPG settings were such that requesting that key from my keyserver would hang the gpg process.

Solution: GPG or PGP may hang but that should not cause KMail to hang. A user interface to cancel the gpg message checking process should be presented to the user. That way the user can proceed to debug his encryption tool and the way it works with that particular message. This should be done since when the child process crashes there doesn't seem to be any way to abort.

FYI: I have been using search.keyserver.net which stalls GPG with this key from weasel@debian.org! When I use pgp.mit.edu it would work all right. However I can verify other emails with search.keyserver.net which I think makes it important to introduce a "cancel" button since such things cannot be predicted in advance.

--------------- CUT FROM HERE
Received: from master.debian.org (mail@master.debian.org [216.234.231.130])
by gordion.cs.bilkent.edu.tr (8.11.2/8.11.2) with ESMTP id f945sL414178
for <erayo@cs.bilkent.edu.tr>; Thu 4 Oct 2001 08:54:22 +0300 (EET DST)
Received: from debbugs by master.debian.org with local (Exim 3.12 1 (Debian))
id 15p18D-0000ne-00; Thu 04 Oct 2001 00:33:13 -0500
From: owner@bugs.debian.org (Debian Bug Tracking System)
To: "Eray Ozkural (exa)" <erayo@cs.bilkent.edu.tr>
Subject: Bug#110517 acknowledged by developer
         (Bug#110517: fixed in lincvs 0.4.0-1)
Message-ID: <handler.110517.D110517.100217316927077.notifdone@bugs.debian.org>
In-Reply-To: <E15c29q-0000HZ-00@orion.exa.homeip.net>
References: <E15p0QA-0003RN-00@auric.debian.org> <E15c29q-0000HZ-00@orion.exa.homeip.net>
X-Debian-PR-Message: they-closed 110517
Reply-To: 110517@bugs.debian.org
Sender: Debian BTS <debbugs@master.debian.org>
Date: Thu 04 Oct 2001 00:33:13 -0500
X-UIDL: g'U!!J+I!!RLm!!HY]!!
Status: R 
X-Status: N

This is an automatic notification regarding your Bug report
#110517: please add an icon for lincvs
which was filed against the lincvs package.

It has been closed by one of the developers namely
Peter Palfrader <weasel@debian.org>.

Their explanation is attached below.  If this explanation is
unsatisfactory and you have not received a better one in a separate
message then please contact the developer by replying to this email.

Darren Benham
(administrator Debian Bugs database)

Received: (at 110517-close) by bugs.debian.org; 4 Oct 2001 05:26:09 +0000
From troup@auric.debian.org Thu Oct 04 00:26:09 2001
Return-path: <troup@auric.debian.org>
Received: from auric.debian.org [206.246.226.45] (mail)
by master.debian.org with esmtp (Exim 3.12 1 (Debian))
id 15p11N-00072P-00; Thu 04 Oct 2001 00:26:09 -0500
Received: from troup by auric.debian.org with local (Exim 3.12 1 (Debian))
id 15p0QA-0003RN-00; Thu 04 Oct 2001 00:47:42 -0400
From: Peter Palfrader <weasel@debian.org>
To: 110517-close@bugs.debian.org
X-Katie: $Revision: 1.59 $
Subject: Bug#110517: fixed in lincvs 0.4.0-1
Message-Id: <E15p0QA-0003RN-00@auric.debian.org>
Sender: James Troup <troup@auric.debian.org>
Date: Thu 04 Oct 2001 00:47:42 -0400
Delivered-To: 110517-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
lincvs which has been installed in the Debian FTP archive:

lincvs_0.4.0-1_i386.deb
  to pool/main/l/lincvs/lincvs_0.4.0-1_i386.deb
lincvs_0.4.0-1.diff.gz
  to pool/main/l/lincvs/lincvs_0.4.0-1.diff.gz
lincvs_0.4.0.orig.tar.gz
  to pool/main/l/lincvs/lincvs_0.4.0.orig.tar.gz
lincvs_0.4.0-1.dsc
  to pool/main/l/lincvs/lincvs_0.4.0-1.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug which will now be closed.  If you
have further comments please address them to 110517@bugs.debian.org
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Peter Palfrader <weasel@debian.org> (supplier of updated lincvs package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue  2 Oct 2001 03:54:37 +0200
Source: lincvs
Binary: lincvs
Architecture: source i386
Version: 0.4.0-1
Distribution: unstable
Urgency: low
Maintainer: Peter Palfrader <weasel@debian.org>
Changed-By: Peter Palfrader <weasel@debian.org>
Description: 
 lincvs     - graphical CVS frontend
Closes: 110517 114120
Changes: 
 lincvs (0.4.0-1) unstable; urgency=low
 .
   * New upstream version (closes: #114120).
   * Debian version repackaged.
   * Menu entry now has an icon (closes: #110517).
Files: 
 a35e8eb3c8b15dae345b5484ed9e2bcf 616 devel optional lincvs_0.4.0-1.dsc
 6f7f1209b0c623f2339012053a2308a4 446356 devel optional lincvs_0.4.0.orig.tar.gz
 2acd14805740d63ed903ffe3c5e8f5cb 4162 devel optional lincvs_0.4.0-1.diff.gz
 8c0ca7741b12c2ae55fbbf5691789893 450832 devel optional lincvs_0.4.0-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE7ukk43nqvbpTAnH8RApDWAKDWRI4MtUcXu0OIKxaH+wyRqCCxjQCg18yM
wpoHovb2WiqOJGTZKM5coHk=
=5lAg
-----END PGP SIGNATURE-----


(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Ingo Kl 2001-10-06 18:37:58 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Saturday 06 October 2001 16:48 erayo@bilkent.edu.tr wrote:
> Solution: GPG or PGP may hang but that should not cause KMail to
> hang. A user interface to cancel the gpg message checking process
> should be presented to the user. That way the user can proceed to
> debug his encryption tool and the way it works with that particular
> message. This should be done since when the child process crashes
> there doesn't seem to be any way to abort.

I'm working on making the GnuPG/PGP usage non-blocking.

BTW if you kill the hanging GnuPG/PGP process you should be able to=20=20
continue working with KMail.

Regards
Ingo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE7v0+JGnR+RTDgudgRAhFVAKDe0Tccd+cBsLyp0IRmSAfhXcFp5QCgiUIv
oja7q5fzQpCsrdZAH8iUzbk=3D
=3DzcNg
-----END PGP SIGNATURE-----
Comment 2 Martijn Klingens 2003-05-15 19:46:33 UTC
*** Bug 58501 has been marked as a duplicate of this bug. ***
Comment 3 Marc Mutz 2003-10-05 04:42:52 UTC
*** Bug 30269 has been marked as a duplicate of this bug. ***
Comment 4 Ingo Klöcker 2004-02-12 11:03:07 UTC
*** Bug 75030 has been marked as a duplicate of this bug. ***
Comment 5 Michael Jahn 2004-07-26 20:47:51 UTC
*** Bug 81205 has been marked as a duplicate of this bug. ***
Comment 6 Tristan Miller 2004-11-29 11:10:49 UTC
Bug 55412 is a possible duplicate... perhaps someone with a better understanding could investigate.
Comment 7 Tristan Miller 2004-11-29 11:11:55 UTC
Bug 93843 is a possible duplicate... perhaps someone with a better understanding could investigate.
Comment 8 Ismail Donmez 2004-11-29 11:33:57 UTC
*** Bug 55412 has been marked as a duplicate of this bug. ***
Comment 9 Ismail Donmez 2004-11-29 11:35:21 UTC
Not sure about Bug 93843 but Bug 55412 was a duplicate. Thanks.
Comment 10 Till Adam 2004-12-14 09:22:53 UTC
*** Bug 93843 has been marked as a duplicate of this bug. ***
Comment 11 angela jones 2005-11-17 03:48:10 UTC
can you not fix it? I don't want to vote I just want it to go away without spending $60 for a tech to come over! Thankyou, Angela
Comment 12 Mark Martinec 2006-05-22 15:54:23 UTC
Five years later, KDE 3.5.2, KMail 1.9.1, latest gpg,
gpgsm 1.9.20 (or 1.9.19) (FreeBSD 5.4 or 6.0 or 6.1, KDE from ports)
I would hope the problem were resolved by now. It is very annoying
when kmail gets stuck for minutes or forever when just stepping
through a list of messages, when one of them happens to have an
unverifiable signature. I'm observing this behaviour for the last
two or three years, various versions in use.

> Additional Comment #1 ... 2001-10-06 18:37
> I'm working on making the GnuPG/PGP usage non-blocking. 

And? Any progress?

Killing a gpgsm process indeed unties a lock and lets KMail
come to life again. There should be an automatic timeout
or a manual abort option on the KMail side. Or prominent
instructions in the manual on how to unhang KMail.
Comment 13 Brendon Higgins 2006-05-23 02:41:13 UTC
I just wonder why KMail can't display something like "Processing Encryption" in the message pane and let the user continue or wait at their pleasure. I'm sure most people will say that a GUI being blocked is a broken design.

Come to think of it, why is this only a wishlist item? It's broken! It's a bug!

I don't get why this one seems to have gone ignored, either.
Comment 14 Stefan Gehn 2006-05-23 18:35:15 UTC
> I just wonder why KMail can't display something like "Processing Encryption" in the message pane
Because message display (and thus decryption) is a synchronous process right now and fixing that involves a redesign. Unfortunately nobody had the time/will to do that yet.

> I don't get why this one seems to have gone ignored, either.
It's not ignored, it's just not important enough for somebody to fix it. If it's important for you then either you have to fix it yourself (I know, no option for users) or find somebody that knows how to fix the problem.
Comment 15 Marcin Juszkiewicz 2007-02-17 22:43:00 UTC
KDE 3.5.6, Debian 'sid' on amd64 (Athlon64 2GHz) and KMail hangs on most of signed mails. And this is STILL 'wishlist'...

This is VERY, VERY annoying CRITICAL or BLOCKER but not wishlist. Five years passed since bug is known, MANY versions of KMail was released and simple bug still exists. I will be not suprised if KMail from KDE4 will still have it.

I hope that one day Mailody will be enough usable to allow me forget about KMail.
Comment 16 Marcin Juszkiewicz 2007-02-17 22:45:26 UTC
Created attachment 19722 [details]
Mail on which KMail blocks

This is one of mails on which KMail hangs for me. I have Koen Kooi gnupg key in
keyring so GnuPG does not have to fetch it.
Comment 17 Marcin Juszkiewicz 2008-03-09 22:00:01 UTC
Year passed - still nothing ;(
Comment 18 Kartik Mistry 2008-04-17 08:52:58 UTC
Marcin,

Is it still case with 3.5.9-2? Please update.

Thanks,
Kartik
Comment 19 Dominik Schulz 2008-10-14 10:31:42 UTC
This bug is still present in KMail 1.10.1 from KDE 4.1.2. It can also make KDE dead-lock when there is a stable lock on the GnuPG files. This way my KMail was rendered unusable until I did find the stale lock. Please fix this bug, as it is really annoying.
Comment 20 Thomas McGuire 2009-08-20 00:49:16 UTC
The mail viewer in KDE 4.4 is no non-blocking, so this is fixed.