Bug 332620 - Kontact crashed when dissociating calendar event from series.
Summary: Kontact crashed when dissociating calendar event from series.
Status: RESOLVED DUPLICATE of bug 327796
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.11.5
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-03-26 10:20 UTC by Andreas
Modified: 2014-03-29 07:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2014-03-26 10:20:01 UTC
Application: kontact (4.11.5)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.11.10-7-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I have a (weekly) series of calendar events. One of them exceptionally takes place at a different location. In order to manipulate that one exceptional event I tried to dissiciate it from the series. 

Kontact deleted the whole series of events, and then complained twice with an error dialog that it couldn't remove the event, because it didn't exist. Then it crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8c8e139880 (LWP 1787))]

Thread 4 (Thread 0x7f8c714c5700 (LWP 1788)):
#0  0x00007f8c857540af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8c88eeaf76 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f8c88eeafa9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f8c857500db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f8c8b67f90d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f8c30bc2700 (LWP 1789)):
#0  0x00007f8c857540af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8c88c5d2cd in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f8c88f12ad6 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f8c857500db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f8c8b67f90d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f8c1d83f700 (LWP 1935)):
#0  0x00007f8c8b676b3d in poll () from /lib64/libc.so.6
#1  0x00007f8c8518d604 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8c8518d70c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8c8bdfcd76 in QEventDispatcherGlib::processEvents (this=0x7f8c100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f8c8bdced0f in QEventLoop::processEvents (this=this@entry=0x7f8c1d83ed60, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8c8bdcf005 in QEventLoop::exec (this=this@entry=0x7f8c1d83ed60, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8c8bccdfef in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#7  0x00007f8c8bcd068f in QThreadPrivate::start (arg=0x1f36f90) at thread/qthread_unix.cpp:338
#8  0x00007f8c857500db in start_thread () from /lib64/libpthread.so.0
#9  0x00007f8c8b67f90d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8c8e139880 (LWP 1787)):
[KCrash Handler]
#6  KCalCore::Incidence::hasRecurrenceId (this=0x0) at /usr/src/debug/kdepimlibs-4.11.5/kcalcore/incidence.cpp:1035
#7  0x00007f8c0aa536b2 in EventViews::AgendaView::displayIncidence (this=this@entry=0x52bb2f0, aitem=..., createSelected=createSelected@entry=true) at /usr/src/debug/kdepim-4.11.5/calendarviews/agenda/agendaview.cpp:1726
#8  0x00007f8c0aa59a66 in EventViews::AgendaView::fillAgenda (this=this@entry=0x52bb2f0) at /usr/src/debug/kdepim-4.11.5/calendarviews/agenda/agendaview.cpp:1698
#9  0x00007f8c0aa5a10d in EventViews::AgendaView::showDates (this=this@entry=0x52bb2f0, start=..., end=..., preferredMonth=...) at /usr/src/debug/kdepim-4.11.5/calendarviews/agenda/agendaview.cpp:1595
#10 0x00007f8c0aa27368 in EventViews::EventView::setDateRange (this=0x52bb2f0, start=..., end=..., preferredMonth=...) at /usr/src/debug/kdepim-4.11.5/calendarviews/eventview.cpp:294
#11 0x00007f8c0adf73c1 in KOAgendaView::setDateRange (this=<optimized out>, start=..., end=...) at /usr/src/debug/kdepim-4.11.5/korganizer/views/agendaview/koagendaview.cpp:331
#12 0x00007f8c0adb93b7 in KOViewManager::updateView (this=0x5235d20, start=..., end=..., preferredMonth=...) at /usr/src/debug/kdepim-4.11.5/korganizer/koviewmanager.cpp:277
#13 0x00007f8c0ad7d65b in CalendarView::updateView (this=0x5218a00, start=..., end=..., preferredMonth=..., updateTodos=<optimized out>) at /usr/src/debug/kdepim-4.11.5/korganizer/calendarview.cpp:781
#14 0x00007f8c0ad92013 in CalendarView::qt_static_metacall (_o=0x5218a00, _c=QMetaObject::ReadProperty, _id=-1953229192, _a=0x5bf4510) at /usr/src/debug/kdepim-4.11.5/build/korganizer/calendarview.moc:571
#15 0x00007f8c8bde3d68 in QMetaObject::activate (sender=0x1f37b10, m=m@entry=0x7f8c0b050ea0 <DateNavigator::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff988122d0) at kernel/qobject.cpp:3556
#16 0x00007f8c0ad96867 in DateNavigator::datesSelected (this=<optimized out>, _t1=..., _t2=...) at /usr/src/debug/kdepim-4.11.5/build/korganizer/datenavigator.moc:184
#17 0x00007f8c0ad979b0 in DateNavigator::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdepim-4.11.5/build/korganizer/datenavigator.moc:106
#18 0x00007f8c8bde3d68 in QMetaObject::activate (sender=sender@entry=0x522b900, m=m@entry=0x7f8c0b051100 <DateNavigatorContainer::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff98812440) at kernel/qobject.cpp:3556
#19 0x00007f8c0ad98067 in DateNavigatorContainer::datesSelected (this=this@entry=0x522b900, _t1=..., _t2=...) at /usr/src/debug/kdepim-4.11.5/build/korganizer/datenavigatorcontainer.moc:169
#20 0x00007f8c0ad98df3 in DateNavigatorContainer::handleDatesSelectedSignal (this=0x522b900, dateList=...) at /usr/src/debug/kdepim-4.11.5/korganizer/datenavigatorcontainer.cpp:394
#21 0x00007f8c0ad99729 in DateNavigatorContainer::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdepim-4.11.5/build/korganizer/datenavigatorcontainer.moc:119
#22 0x00007f8c8bde3d68 in QMetaObject::activate (sender=0x52376a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff988125f0) at kernel/qobject.cpp:3556
#23 0x00007f8c0adaa76d in datesSelected (_t1=..., this=<optimized out>) at /usr/src/debug/kdepim-4.11.5/build/korganizer/kdatenavigator.moc:157
#24 KDateNavigator::qt_static_metacall (_o=0x52376a0, _id=1, _a=0x7f8c8b941678 <main_arena+88>, _c=<optimized out>) at /usr/src/debug/kdepim-4.11.5/build/korganizer/kdatenavigator.moc:86
#25 0x00007f8c8bde3d68 in QMetaObject::activate (sender=0x522af80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff98812730) at kernel/qobject.cpp:3556
#26 0x00007f8c0adaed61 in selected (_t1=..., this=<optimized out>) at /usr/src/debug/kdepim-4.11.5/build/korganizer/kodaymatrix.moc:123
#27 KODayMatrix::mouseReleaseEvent (this=0x522af80, e=0x1) at /usr/src/debug/kdepim-4.11.5/korganizer/kodaymatrix.cpp:567
#28 0x00007f8c8c830dfe in QWidget::event (this=this@entry=0x522af80, event=event@entry=0x7fff98812c20) at kernel/qwidget.cpp:8376
#29 0x00007f8c0adaee2d in KODayMatrix::event (this=0x522af80, event=0x7fff98812c20) at /usr/src/debug/kdepim-4.11.5/korganizer/kodaymatrix.cpp:497
#30 0x00007f8c8c7e18ac in QApplicationPrivate::notify_helper (this=this@entry=0x1c885b0, receiver=receiver@entry=0x522af80, e=e@entry=0x7fff98812c20) at kernel/qapplication.cpp:4562
#31 0x00007f8c8c7e7fad in QApplication::notify (this=this@entry=0x7fff98813470, receiver=receiver@entry=0x522af80, e=e@entry=0x7fff98812c20) at kernel/qapplication.cpp:4105
#32 0x00007f8c8d4f818a in KApplication::notify (this=0x7fff98813470, receiver=0x522af80, event=0x7fff98812c20) at /usr/src/debug/kdelibs-4.11.5/kdeui/kernel/kapplication.cpp:311
#33 0x00007f8c8bdd00ad in QCoreApplication::notifyInternal (this=0x7fff98813470, receiver=receiver@entry=0x522af80, event=event@entry=0x7fff98812c20) at kernel/qcoreapplication.cpp:949
#34 0x00007f8c8c7e7763 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#35 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x522af80, event=event@entry=0x7fff98812c20, alienWidget=alienWidget@entry=0x522af80, nativeWidget=nativeWidget@entry=0x523d480, buttonDown=buttonDown@entry=0x7f8c8d2bf278 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3173
#36 0x00007f8c8c858f7b in QETWidget::translateMouseEvent (this=this@entry=0x523d480, event=event@entry=0x7fff98812f90) at kernel/qapplication_x11.cpp:4528
#37 0x00007f8c8c8579ec in QApplication::x11ProcessEvent (this=0x7fff98813470, event=event@entry=0x7fff98812f90) at kernel/qapplication_x11.cpp:3651
#38 0x00007f8c8c87e882 in x11EventSourceDispatch (s=0x1c7e270, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00007f8c8518d316 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f8c8518d668 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f8c8518d70c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f8c8bdfcd55 in QEventDispatcherGlib::processEvents (this=0x1c455b0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#43 0x00007f8c8c87e936 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007f8c8bdced0f in QEventLoop::processEvents (this=this@entry=0x7fff98813370, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007f8c8bdcf005 in QEventLoop::exec (this=this@entry=0x7fff98813370, flags=...) at kernel/qeventloop.cpp:204
#46 0x00007f8c8bdd413b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#47 0x0000000000403960 in ?? ()
#48 0x00007f8c8b5b9be5 in __libc_start_main () from /lib64/libc.so.6
#49 0x0000000000403e29 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 327878.

Possible duplicates by query: bug 329099, bug 328425, bug 327878, bug 327796, bug 323433.

Reported using DrKonqi
Comment 1 Andreas 2014-03-26 10:22:48 UTC
After restarting Kontact, the event is still there. So, it hasn't been deleted after all. However, when I try to dissociate the event again, the same crash as above happens.

Some more details:
This time the error message about ~cannot delete non-existing event~ popped up only once. The whole series of events vanished from the calendar views, but the program still ran. Only after I clicked on a different day in the calendar view did Kontact crash.
Comment 2 Andreas 2014-03-26 10:23:26 UTC
The event series is still there after restarting Kontact
Comment 3 Jekyll Wu 2014-03-29 07:44:33 UTC

*** This bug has been marked as a duplicate of bug 327796 ***