Bug 329099 - Crash when moving instance of recurring event
Summary: Crash when moving instance of recurring event
Status: RESOLVED DUPLICATE of bug 327796
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.12
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-21 22:51 UTC by David Pyke
Modified: 2014-01-31 14:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.28 KB, text/plain)
2014-01-31 14:54 UTC, David Pyke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Pyke 2013-12-21 22:51:57 UTC
Application: kontact (4.12)
KDE Platform Version: 4.12.0
Qt Version: 4.8.4
Operating System: Linux 3.12.5 x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
I have a long term recurring event.  I had just moved on occurrace to a different time (not date) and when I pressed "This occurrance only" the crash happens.

It's happened three times now.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbb1853a7c0 (LWP 10647))]

Thread 8 (Thread 0x7fbaf99da700 (LWP 10648)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fbb133181cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fbb13318209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fbb0fa3df6e in start_thread (arg=0x7fbaf99da700) at pthread_create.c:311
#4  0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 7 (Thread 0x7fbab90d7700 (LWP 10649)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fbb13058bbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fbb13347a76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fbb0fa3df6e in start_thread (arg=0x7fbab90d7700) at pthread_create.c:311
#4  0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 6 (Thread 0x7fbaa919f700 (LWP 10655)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x00007fbb161003e4 in wait (time=30000, this=0x1b15660) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x1b15608, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbb160f38a5 in QThreadPoolThread::run (this=0x19bf240) at concurrent/qthreadpool.cpp:141
#4  0x00007fbb160fff2f in QThreadPrivate::start (arg=0x19bf240) at thread/qthread_unix.cpp:338
#5  0x00007fbb0fa3df6e in start_thread (arg=0x7fbaa919f700) at pthread_create.c:311
#6  0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7fbaa3fff700 (LWP 10656)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x00007fbb161003e4 in wait (time=30000, this=0x1c14000) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x1c142e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbb160f38a5 in QThreadPoolThread::run (this=0x1ac2ae0) at concurrent/qthreadpool.cpp:141
#4  0x00007fbb160fff2f in QThreadPrivate::start (arg=0x1ac2ae0) at thread/qthread_unix.cpp:338
#5  0x00007fbb0fa3df6e in start_thread (arg=0x7fbaa3fff700) at pthread_create.c:311
#6  0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7fbaa2b3d700 (LWP 10658)):
#0  0x00007fff2253389c in clock_gettime ()
#1  0x00007fbb15ac896d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fbb16154757 in do_gettime (frac=0x7fbaa2b3cb40, sec=0x7fbaa2b3cb38) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fbb1622dfe5 in updateCurrentTime (this=0x7fba90002660) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x7fba90002660, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x00007fbb1622c82c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fbaa2b3cbf4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fbb1622c8d5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fbb0f564d4d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fbb0f5655c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fbb0f5657ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fbb1622ca76 in QEventDispatcherGlib::processEvents (this=0x7fba900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fbb161fe5ef in QEventLoop::processEvents (this=this@entry=0x7fbaa2b3cdb0, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fbb161fe8e5 in QEventLoop::exec (this=this@entry=0x7fbaa2b3cdb0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fbb160fd88f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#15 0x00007fbb160fff2f in QThreadPrivate::start (arg=0x15c1360) at thread/qthread_unix.cpp:338
#16 0x00007fbb0fa3df6e in start_thread (arg=0x7fbaa2b3d700) at pthread_create.c:311
#17 0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7fba97dc9700 (LWP 10668)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x00007fbb161003e4 in wait (time=30000, this=0x1c587c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x1c58738, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbb160f38a5 in QThreadPoolThread::run (this=0x269b090) at concurrent/qthreadpool.cpp:141
#4  0x00007fbb160fff2f in QThreadPrivate::start (arg=0x269b090) at thread/qthread_unix.cpp:338
#5  0x00007fbb0fa3df6e in start_thread (arg=0x7fba97dc9700) at pthread_create.c:311
#6  0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fba96e3a700 (LWP 10669)):
#0  __GI___pthread_mutex_lock (mutex=0x2) at pthread_mutex_lock.c:47
#1  0x00007fbb0f5a53a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbb0f564f3b in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbb0f565612 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fbb0f5657ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fbb1622ca76 in QEventDispatcherGlib::processEvents (this=0x7fba840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fbb161fe5ef in QEventLoop::processEvents (this=this@entry=0x7fba96e39d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fbb161fe8e5 in QEventLoop::exec (this=this@entry=0x7fba96e39d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fbb160fd88f in QThread::exec (this=this@entry=0x14d2cb0) at thread/qthread.cpp:542
#9  0x00007fbb161dfd13 in QInotifyFileSystemWatcherEngine::run (this=0x14d2cb0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fbb160fff2f in QThreadPrivate::start (arg=0x14d2cb0) at thread/qthread_unix.cpp:338
#11 0x00007fbb0fa3df6e in start_thread (arg=0x7fba96e3a700) at pthread_create.c:311
#12 0x00007fbb15ab39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fbb1853a7c0 (LWP 10647)):
[KCrash Handler]
#6  KCalCore::Incidence::hasRecurrenceId (this=0x0) at ../../kcalcore/incidence.cpp:1036
#7  0x00007fbaa2bc33a2 in EventViews::AgendaView::displayIncidence (this=this@entry=0x1fa33f0, aitem=..., createSelected=createSelected@entry=true) at ../../calendarviews/agenda/agendaview.cpp:1726
#8  0x00007fbaa2bc9756 in EventViews::AgendaView::fillAgenda (this=this@entry=0x1fa33f0) at ../../calendarviews/agenda/agendaview.cpp:1698
#9  0x00007fbaa2bc9e0a in EventViews::AgendaView::showDates (this=this@entry=0x1fa33f0, start=..., end=..., preferredMonth=...) at ../../calendarviews/agenda/agendaview.cpp:1595
#10 0x00007fbaa2b973d8 in EventViews::EventView::setDateRange (this=0x1fa33f0, start=..., end=..., preferredMonth=...) at ../../calendarviews/eventview.cpp:294
#11 0x00007fbaa2f60871 in KOAgendaView::setDateRange (this=<optimized out>, start=..., end=...) at ../../korganizer/views/agendaview/koagendaview.cpp:331
#12 0x00007fbaa2f227f7 in KOViewManager::updateView (this=0x1ded1e0, start=..., end=..., preferredMonth=...) at ../../korganizer/koviewmanager.cpp:277
#13 0x00007fbaa2ee76fb in CalendarView::updateView (this=0x1d53200, start=..., end=..., preferredMonth=..., updateTodos=<optimized out>) at ../../korganizer/calendarview.cpp:765
#14 0x00007fbaa2efbee1 in CalendarView::qt_static_metacall (_o=0x1d53200, _c=QMetaObject::ReadProperty, _id=366454680, _a=0x7fbb15d7a748 <main_arena+8>) at ./calendarview.moc:563
#15 0x00007fbb16213a58 in QMetaObject::activate (sender=0x1ddf1d0, m=m@entry=0x7fbaa31b9ee0 <DateNavigator::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff22415640) at kernel/qobject.cpp:3539
#16 0x00007fbaa2f003f7 in DateNavigator::datesSelected (this=<optimized out>, _t1=..., _t2=...) at ./datenavigator.moc:185
#17 0x00007fbaa2f01540 in DateNavigator::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./datenavigator.moc:107
#18 0x00007fbb16213a58 in QMetaObject::activate (sender=sender@entry=0x1c57190, m=m@entry=0x7fbaa31ba140 <DateNavigatorContainer::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff224157b0) at kernel/qobject.cpp:3539
#19 0x00007fbaa2f01bf7 in DateNavigatorContainer::datesSelected (this=this@entry=0x1c57190, _t1=..., _t2=...) at ./datenavigatorcontainer.moc:170
#20 0x00007fbaa2f02983 in DateNavigatorContainer::handleDatesSelectedSignal (this=0x1c57190, dateList=...) at ../../korganizer/datenavigatorcontainer.cpp:394
#21 0x00007fbaa2f032b9 in DateNavigatorContainer::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./datenavigatorcontainer.moc:120
#22 0x00007fbb16213a58 in QMetaObject::activate (sender=0x22bd6d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff22415960) at kernel/qobject.cpp:3539
#23 0x00007fbaa2f13c1d in datesSelected (_t1=..., this=<optimized out>) at ./kdatenavigator.moc:158
#24 KDateNavigator::qt_static_metacall (_o=0x22bd6d0, _id=1, _a=0x7fbb15d7a798 <main_arena+88>, _c=<optimized out>) at ./kdatenavigator.moc:87
#25 0x00007fbb16213a58 in QMetaObject::activate (sender=0x20422f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff22415aa0) at kernel/qobject.cpp:3539
#26 0x00007fbaa2f181f1 in selected (_t1=..., this=<optimized out>) at ./kodaymatrix.moc:124
#27 KODayMatrix::mouseReleaseEvent (this=0x20422f0, e=0x1) at ../../korganizer/kodaymatrix.cpp:567
#28 0x00007fbb16c4031e in QWidget::event (this=this@entry=0x20422f0, event=event@entry=0x7fff22415f90) at kernel/qwidget.cpp:8375
#29 0x00007fbaa2f182bd in KODayMatrix::event (this=0x20422f0, event=0x7fff22415f90) at ../../korganizer/kodaymatrix.cpp:497
#30 0x00007fbb16bf0dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1349d60, receiver=receiver@entry=0x20422f0, e=e@entry=0x7fff22415f90) at kernel/qapplication.cpp:4567
#31 0x00007fbb16bf75ad in QApplication::notify (this=this@entry=0x7fff224167f0, receiver=receiver@entry=0x20422f0, e=e@entry=0x7fff22415f90) at kernel/qapplication.cpp:4110
#32 0x00007fbb178fac6a in KApplication::notify (this=0x7fff224167f0, receiver=0x20422f0, event=0x7fff22415f90) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007fbb161ff8bd in QCoreApplication::notifyInternal (this=0x7fff224167f0, receiver=receiver@entry=0x20422f0, event=event@entry=0x7fff22415f90) at kernel/qcoreapplication.cpp:946
#34 0x00007fbb16bf6d63 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x20422f0, event=event@entry=0x7fff22415f90, alienWidget=alienWidget@entry=0x20422f0, nativeWidget=nativeWidget@entry=0x1e189d0, buttonDown=buttonDown@entry=0x7fbb176d52f8 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3178
#36 0x00007fbb16c6b7db in QETWidget::translateMouseEvent (this=this@entry=0x1e189d0, event=event@entry=0x7fff22416310) at kernel/qapplication_x11.cpp:4631
#37 0x00007fbb16c6b079 in QApplication::x11ProcessEvent (this=0x7fff224167f0, event=event@entry=0x7fff22416310) at kernel/qapplication_x11.cpp:3624
#38 0x00007fbb16c92922 in x11EventSourceDispatch (s=0x134b400, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00007fbb0f5653b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007fbb0f565708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fbb0f5657ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fbb1622ca55 in QEventDispatcherGlib::processEvents (this=0x1310690, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#43 0x00007fbb16c929d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007fbb161fe5ef in QEventLoop::processEvents (this=this@entry=0x7fff224166f0, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007fbb161fe8e5 in QEventLoop::exec (this=this@entry=0x7fff224166f0, flags=...) at kernel/qeventloop.cpp:204
#46 0x00007fbb16203e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#47 0x00007fbb16bef34c in QApplication::exec () at kernel/qapplication.cpp:3828
#48 0x0000000000403660 in main (argc=1, argv=0x7fff22416938) at ../../../kontact/src/main.cpp:219

The reporter indicates this bug may be a duplicate of or related to bug 327878.

Possible duplicates by query: bug 328425, bug 327878, bug 327796, bug 323433.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-22 01:31:50 UTC

*** This bug has been marked as a duplicate of bug 327796 ***
Comment 2 David Pyke 2014-01-31 14:54:53 UTC
Created attachment 84921 [details]
New crash information added by DrKonqi

kontact (4.12.1) on KDE Platform 4.12.1 using Qt 4.8.6

- What I was doing when the application crashed:

I had moved a single instance of a recurring appointment that is attached to a Google Calendar.  When I pressed the "This instance only" button, the application crashed.

-- Backtrace (Reduced):
#6  KCalCore::Incidence::hasRecurrenceId (this=0x0) at ../../kcalcore/incidence.cpp:1036
#7  0x00007ff92b7f7322 in EventViews::AgendaView::displayIncidence (this=this@entry=0x3200840, aitem=..., createSelected=createSelected@entry=true) at ../../calendarviews/agenda/agendaview.cpp:1726
#8  0x00007ff92b7fd6d6 in EventViews::AgendaView::fillAgenda (this=this@entry=0x3200840) at ../../calendarviews/agenda/agendaview.cpp:1698
#9  0x00007ff92b7fdd8a in EventViews::AgendaView::showDates (this=this@entry=0x3200840, start=..., end=..., preferredMonth=...) at ../../calendarviews/agenda/agendaview.cpp:1595
#10 0x00007ff92b7cb3a8 in EventViews::EventView::setDateRange (this=0x3200840, start=..., end=..., preferredMonth=...) at ../../calendarviews/eventview.cpp:294